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Extension Activity

Astral Count 
How many small bright

objects are out there?

© 2007 Center for Image Processing in Education

Introduction

This lesson requires ImageJ, available for free download 
from http://rsb.info.nih.gov/ij/. Help files are available 
at http://rsb.info.nih.gov/ij/docs/index.html. For more 
assistance, Discovering Image Processing, v.2, (DIP), 
revised and expanded in 2006, teaches the fundamental 
concepts of digital image processing and image analysis 
in ten step-by-step lessons. More information and a free 
sample DIP lesson is available on the Science Approach 
Web site. Visit http://www.science-approach.com/, click 
Purchase Products and navigate to the DIP product page.

Although we won’t be tackling the absolute number of 
stars in the universe, you will be introduced to a technique 
for counting visible stars on digitized images.

Your mission

Have you ever gazed up at the night-time sky and 
wondered just how many stars are there? 

If so, you’re not alone. In the 1780s, disfigured by smallpox 
and stunted by typhus, Caroline Lucretia Herschel spent 
most nights crouched over a candle writing notes. Above 
her, perched on the top of a ladder, her brother William 
dictated what he saw in the sky as he peered through a 
telescope the two had built.

In 1781, he was the first to identify the planet Uranus 
(although he misidentified it at first as a comet). Two years 
later, Caroline, who had begun her own independent 
work, spotted three new nebulae and later discovered 
seven comets and many stars.

In 1787, King George agreed to provide a salary for her, 
making her the first woman to be a paid scientist.  

Your toolkit

Instead of bending over candlelit notes or peering out 
from a hole in the roof, you will be using ImageJ to view 
and analyze two images of a night sky. Your task is to 

IP Skills
• Image adjustment and thresholding
 • Analyze particles 

ImageJ Skill Sheets

• Thresholding
• Measuring

What’s a nebula?
A nebula (plural nebulae) is a hazy cloud 
where stars are formed.

Two astronomy ‘stars’
William Herschel also discovered infrared 
light (which he referred to as “calorific” rays), 
and the European Space Agency named 
the planned Herschel Space Observatory 
in his honor.  The observatory will collect 
infrared radiation from distant stars.
Lucretia, an asteroid (a type of minor 
planet) was named for Caroline in 1889.
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obtain star counts for these images and to investigate how 
the numbers are influenced by the limits you set.

Step 1: Gather the data

a.	 There are two images for this activity, NorthSky-
8bit.tif and MilkyNebula-8bit.tif,  inside the folder 

where you found this lesson PDF.  

Step 2: Enhance the image

a.	 Launch ImageJ. Choose File > Open, and navigate 
to NorthSky-8bit.tif. 

b. Although it appears to be a solid black box, this 
image actually shows a night sky in southeastern 
Arizona during September. 

	 Choose Image > Adjust > Brightness/Contrast. 
Adjust the Maximum, Minimum, Brightness, and 
Contrast slider bars until you can see hills, low 
clouds, and multiple stars. 

	 As you adjust the sliders, notice how the numbers 
change below the graph. 

Qn. 1. What levels of Maximum, Minimum, Brightness, 
and Contrast are most effective in enhancing this 
image? (You may use the Data Sheet at the end of the 
lesson for your answers.)

c. Choose Reset to return NorthSky-8bit.tif to its 
original form. 

d. Now choose Process > Enhance Contrast, and 
accept all the defaults in the Enhance Contrast 
window.

Qn. 2. What happens?  

Step 3: Define a region of interest

a. Your goal is to count stars in a specific region of 
the sky––one without clouds, hills, or trees. You’ll 
first need to define a region of interest (ROI) that 
excludes the lower 35-40 percent of the image.	

b. Choose the Rectangular Selections tool, , and 
draw a rectangle starting from (270, 450). 

	 Your rectangle should be 140 pixels wide and 180 
pixels high, as shown on the next page.

Getting to know the Status Bar 
The status bar on the image window shows

• image dimensions (648 x 486), 
• bit depth (8-bit),  and 

• image size (307K). 

Inverting the Y coordinates
The Y coordinates in this lesson are 
expressed starting at the bottom of the 
image. If they run from 0 at the top to 
larger values at the bottom, you can 
invert them by choosing Analyze > Set 
Measurements and then clicking Invert 
Y Coordinates. 
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    The four brightest stars within your rectangle are 
part of the constellation Cassiopeia. The fifth is at 
(270, 300), right at the left edge of your ROI. 

Step 4: Threshold the image

a. Next, you need to tell ImageJ to set an upper and 
lower limit for the brightness of the stars you want 
to count. This process is called thresholding.

	 To threshold the image, choose Image > Adjust > 
Threshold. (For more tips on thresholding, see the 
Thresholding Tips sidebar.)

b. Set the minimum value to 0, and you’ll see that all 
the image changes to red. 

	 Set it to 1. Now all pixel values greater than 0 will 
be colored red. 

	 Designating the appropriate minimum requires 
some judgment. You will want to highlight 
meaningful pixel values but not those that may 
represent noise or artifacts.

c. Try setting the minimum threshold slider to 2 and 
then 3. 

Qn. 3. How does the appearance of the image change 
according to the thresholding? 

  Thresholding tips   
 • In the thresholding window, pixels 
with values between the minimum 
(upper slider) and maximum (lower 
slider bar) are highlighted and colored 
red.

 • To count all the bright objects in your 
rectangle, the maximum slider should 
be moved to the right – at or past the 
maximum pixel value in your region.

 • The minimum slider sets the minimum 
pixel value for objects to be thresholded 
– and colored red.

•  Thresholding and particle counting 
can only be applied to 8-bit, 16-bit, 
or 32-bit grayscale images. If you are 
starting with an RGB image, you’ll first 
need to convert it to a grayscale image 
by choosing Image > Type.

  Observing the histogram
Before thresholding the image, you may 
find it helpful to view a histogram of pixel 
values. Choose Analyze > Histogram to 
obtain a graphical depiction of the range of 
pixel values.  

Cassiopeia’s chair
The five stars in a shape of a sideways 
stretched-out W form the constellation 
Cassiopeia. Those with a particularly 
vivid imagination may be able to discern 
a woman sitting in a chair. According 
to Greek mythology, Cassiopeia was 
sentenced to sit for eternity for bragging 
that she was even more beautiful than 
the Neredis (blue-haired sea nymphs who 
always accompanied Poseidon, god of the 
sea).
This constellation is visible in the northern 
sky all year around; however, during part 
of the year, Cassiopeia’s chair is upside-
down, an indignity the Greeks deemed 
appropriate for her eternal punishment.. 

  Hint ...

The dimensions of your rectangle will be 
shown under the ImageJ toolbar. 
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Step 5: Count the stars 

a. Choose 3 as your minimumthreshold slider. 

	 Now you’re ready to count the highlighted pixels. 
Choose Analyze > Analyze Particles... . In the 
Analyze Particles... window, select values as shown 
below, and click OK.

b. When the processing is complete, the Results 
window will appear, which lists data (area, mean 
pixel value, perimeter) for the objects.

	 Scroll down to the bottom of the window. The last 
number indicates the number of stars.

Qn. 4. How many stars are in your rectangle? Explain 
how you could tell.

Step 6: Analyze another image 

a. Open the second image, MilkyNebula.jpg. This is a 
larger image of a nebula in the Milky Way, which 
is the galaxy that contains our solar system. 

b. Enhance the image, then define your ROI as a 
rectangle that again measures 140 x 180 pixels. 
Your starting point should be (700, 570).

c. Threshold the image, again using a maximum of 
206 and a minimum of 3.

d. Count the stars.

Qn. 5. How many stars are in your rectangle now? 

How many stars are there?
Scientists use several methods to estimate 
the number of stars in the universe. Stars 
are not randomly distributed throughout 
the Universe but are gathered in groups 
known as galaxies. 

1. The number of stars in the Milky Way 
galaxy has been estimated from the 
amount of light and mass in the	
galaxy  to be 100 billion (or1011 ). 

2. The number of galaxies in the 
Universe has been judged to be 1011 - 
1012, 	giving a total number of stars 
somewhere around 1022 or more.

3. An alternative technique to survey 
the number of visible stars in a strip of 
sky by viewing the strip  with powerful 
telescopes. came up with a number of 7 
x 1022.

 These figures are estimates, but they point 
out that the number of stars is vast–far 
more than the number of grains of sand in 
all the world’s beaches and deserts.

  Hints ...
Process > Enhance Contrast

Analyze > Analyze Particles...

Image > Adjust > Threshold...

  Hint ...
To clear the Results table between images,  
select Edit > Clear Results in the 
Results Window.
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Step 7: Compare two regions within one image

a. Being careful to click inside your ROI, drag the 
rectangle to (330, 280). 

b. ImageJ will remember your Threshold settings, so 
you should be able to choose Analyze > Analyze 
Particles... . 

Qn. 6. How many stars are there in this location? 

The Milky Way is shaped like a thick disk with four long 
spiralling arms (thus its name of a spiral galaxy)––much 
like a spinning Frisbee with four streamers. Our solar 
system resides on a tiny part of a very short, fifth arm, 
that’s disconnected.

To give you an idea of scale, while light can travel across 
our solar system in a day, it would take about 100,000 
light years to cross our galaxy! 

Further Exploration

Try taking pictures of the night sky at different locations 
and analyze them, using the star counts as a measure of 
light pollution.

Visible light made by living creatures is known as 
bioluminescence. Fireflies are bioluminescent, and so 
are a few other land dwellers, such as some earthworms, 
centipedes, and fungi. On land, bioluminescence is rare, 
but in the oceans, it is very common. You can acquire 
digital images of bioluminescent organisms, such as 
fireflies or marine dwellers, and analyze the images to 
identify patterns of distribution. 

Actually, you don’t have to restrict yourself to bright 
objects––any objects that have a clear boundary and that 
can be thresholded are appropriate. Thresholding works 
best when the objects are distinct from or contrast with 
the background. You could look at lakes in Alaska from 
aerial photos or satellite images (has the total lake area 
increased or decreased?), cells on a slide, or structures in 
Landsat images. 

With this technique, you don’t have to be like William 
and Caroline Herschel peering through a hole in the roof. 
With ImageJ, you’re only limited by the availability of 
digital images and your imagination.

		  Mission accomplished!

Shooting the night sky
The images for this lesson were captured 
using: 

• a Canon Rebel XT digital camera with a 
28-70 mm (non-digital) zoom lens,

• a tripod and cable release,
• ISO 400, and 
• f/16 for 2 secs.

You can do astrophotography with a point-
and-shoot digital camera, as long as it will 
allow you to make exposures longer than 
15 secs.

What is light pollution?
Light pollution refers to the illumination 
of the night sky caused by artificial light 
sources on the ground (streetlights, 
billboards, etc.). Both the light and the 
loss of contrast make it difficult to find 
fainter stars and nebulae. – an increasing 
problem for both amateur and professional 
astronomers.


