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The Center for Image Processing in Education
Founded in 1992, the Center for Image Processing in Education (CIPE) 
is a nonprofi t organization whose mission is to promote the use of 
visualization technologies for innovative educational ap pli ca tions. CIPE 
offers pro fes sion al de vel op ment work shops on using state-of-the-art image 
pro cess ing and geographic information system (GIS) tools and tech niques 
and pub lish es award-winning soft ware prod ucts for the class room. 
With support from the Na tion al Science Foun da tion, National Institutes 
of Health, and other funders, CIPE is bringing image pro cess ing and 
geospatial technology in struc tion al ma te ri als to tech no log i cal education at 
the high school and community college levels.

For more information on workshops and instructional materials available 
through the Cen ter for Image Processing in Education, contact:

Steven Moore, PhD
Executive Director
Center for Image Processing in Education
PO Box 13750
Tucson, AZ  85732-3750
800/322-9884
stevem@evisual.org

Opportunities for
professional growth
The Center for Image Pro cess ing 
in Education off ers a wide range of 
experiences for teachers who want 
to continue their growth in image 
pro cess ing, in clud ing:

 • Workshops. We off er 
pro fes sion al development 
workshops at your institution 
and at national education 
conferences.

 • Lesson Development. We 
are look ing for qual i fi ed 
de vel op ers, testers, and 
con trib u tors for fu ture 
in struc tion al ma te ri als.

 • Presentations. We make 
presentations at national, 
re gion al, state, and local 
science, math e mat ics, and 
technology con fer enc es.

If you would like to know more 
about these and other exciting 
opportunities, call CIPE at:

800/322-9884

Or check our Web site:

http://www.evisual.org
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Introduction
About digital image processing

What is a digital image?
A digital image is:

 • a rectangular array of measurements (light, temperature, X-rays, etc.),

 • sampled at regular intervals, and

 • displayed according to a lookup table, which assigns a specifi c color to 
each different pixel value.

This concept is illustrated by the series of mag ni fi  ca tions of Mona Lisa 
at right. Unlike graph ics, where mean ing comes only from the patterns 
formed by many pixels, each pixel in a digital image can contain 
meaningful in for ma tion.

Image processing and analysis
The bright ness or color of each pixel often rep re sents a mea sure ment 
of some kind, such as elevations of points on the surface of Earth, or the 
intensity of infrared radiation across a scene. Pixels also represent distances 
and areas. A length of 20 pixels in an image may represent one micron in an 
electron micrograph or one hundred kilometers in a satellite image.

 • Image processing involves manipulating the numeric data contained in Image processing involves manipulating the numeric data contained in Image processing
a digital image to improve or alter its appearance for either aesthetic 
reasons or to make image features easier to measure. Contrast 
enhancement, noise reduction, and edge sharpening are examples of 
image processing functions.

 • Image analysis involves collecting, measuring, and analyzing data from 
processed digital images.

 • Image interpretation is the process of extracting meaning from the 
analyses in a larger scientifi c context.

ImageJ—a powerful image processing tool
ImageJ is public domain image pro cess ing and analysis software written 
and maintained by Wayne Rasband of the National Institutes of Health and 
used by sci en tists in many dis ci plines around the world. The program can 
ac quire, display, edit, en hance, analyze, print, and animate digital images.

ImageJ has tools for measuring distance, area, bright ness, lo ca tion, and 
an gles on digital images. Measurement results can be print ed or exported 
to other soft ware packages for fur ther analysis. Users can enhance images 
through false col or ing, con trast enhancement, and digital fi ltering using both 
built-in and user-defi ned digital fi l ters. ImageJ also provides tools for editing 
images, al low ing the user to draw lines, shapes, and text. The program can 
fl ip, rotate, invert, and scale se lec tions. It supports multiple windows and 
many levels of mag ni fi  ca tion, and most processes can be undone.

A series of mag ni fi  ca tions of Mona's 
face, revealing in di vid u al pixels and 
numeric values for each pixel. 
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What is Discovering Image Processing?
Discovering Image Processing is a creative and powerful introduction to the Discovering Image Processing is a creative and powerful introduction to the Discovering Image Processing
techniques and applications of digital imaging technology. These hands-
on lessons use real-world images and ImageJ software to model the work 
that scientists and technicians do every day. Using this extraordinary tool, 
students learn fundamental concepts of digital image processing, analysis, 
and interpretation. In addition to science, mathematics, and technology, 
these lessons explore issues and problems from a variety of fi elds ranging 
from forensics to graphic arts.

Most of the images in Discovering Image Processing were not created Discovering Image Processing were not created Discovering Image Processing
for classroom use—they are data culled from research laboratories, 
government agencies, medical facilities, and the Internet.

Exploration, problem solving, and creative thinking
Discovering Image Processing lessons are designed to engage students in Discovering Image Processing lessons are designed to engage students in Discovering Image Processing
ex plo ra tion and directed discovery. Using ImageJ, stu dents explore im ag es 
from a variety of sources, including satellite photos, digital elevation 
models, and images from space probes, scanners, and digital cam er as. 
Stu dents make measurements, collect and analyze data, and de vel op their 
own solutions as they work through prob lems.

Integrating science, mathematics, and technology
The lessons in Discovering Image Processing integrate basic concepts in Discovering Image Processing integrate basic concepts in Discovering Image Processing
sci ence, mathematics, and technology by presenting lesson content in 
an applied context, such as using animation to visualize the motion and 
tra jec to ry of a storm, or creating histograms of pixel values in an image 
to analyze and enhance the image for better visualization of details. As a 
result, students learn that digital imaging technology is a technical skill 
relevant to the workplace.

Philosophy
We believe that technology should be presented in a way that encourages 
students to actively participate, utilize materials currently in use in the 
world outside the classroom, and apply learned skills to a variety of 
vocations. The lessons in Dis cov er ing Image Processing were de vel oped Dis cov er ing Image Processing were de vel oped Dis cov er ing Image Processing
with the fol low ing goals in mind:

 • Teach fundamental concepts in technology through hands-on 
par tic i pa tion, guid ed dis cov ery, and critical thinking.

 • Explore real-world data with appropriate technology tools.

 • Integrate different disciplines through the use of image processing 
technology.

Teaching fundamental concepts in technology
With Discovering Image Processing, your students will learn fundamental Discovering Image Processing, your students will learn fundamental Discovering Image Processing
but important concepts in digital technology by actively participating in 
guided dis cov ery, image analysis, and problem solving. Using the tools of 
ImageJ, they will collect, organize, analyze, and interpret data from digital 
images, and can work independently or cooperatively in sharing and 
com mu ni cat ing their results with others.

“It may help to recall that image 
processing, like food processing 
or word processing, does not 
re duce the amount of data present 
but simply re ar rang es it. Some 
ar range ments may be more 
ap peal ing to the senses, some may 
convey more meaning…”

John C. Russ
The Image Processing Handbook, 
2nd Edition

What’s included
Discovering Image 
Processing CD-ROM

 • ImageJ software and installer

 • Lesson data

 • Lesson text

Discovering Image 
Processing guidebook

 • Introductory materials

 • ImageJ Skill Sheets

 • Teaching notes

 • Classroom lessons

 • Student data sheets

The images in Discovering Image 
Processing come from:

 • students and teachers using 
scanners, video, and digital 
cameras

 • re search laboratories

 • medical facilities

 • government agencies

 • industry
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Exploring real-world data
Discovering Image Processing is designed to provide your students with Discovering Image Processing is designed to provide your students with Discovering Image Processing
op por tu ni ties to experience technology through the analysis of digital 
im ag es collected from the world around us. This approach offers them a 
context for the relevancy of the technology skills they will acquire. They 
will use image pro cess ing to ex plore and an a lyze the data in the images 
with more precision and detail than can typically be conveyed with 
traditional classroom tech niques.

Integrating disciplines
The lessons in Discovering Image Processing integrate concepts not only Discovering Image Processing integrate concepts not only Discovering Image Processing
from math e mat ics, science, and technology, but also from language arts 
and social studies. Image pro cess ing tools and tech niques are taught 
in applied contexts rang ing from motion analysis of weather to travel 
planning to the in ves ti ga tion of crime scene evidence. Lesson materials 
also lend themselves to further discovery about numerous professional 
fi elds that currently utilize image processing, ranging from the arts to 
aerospace.

The les sons em pha size many of the work place com pe ten cies and 
foun da tion al skills rec om mend ed by the Skills and Tasks for Jobs: A SCANS 
Report for America 2000. These abilities include the pro duc tive use of 
re sourc es, information, systems, and tech nol o gy, as well as teamwork 
and thinking skills. In par tic u lar, using com put ers to process information 
and applying tech nol o gy to tasks are two com pe ten cies fulfi lled by all 
Dis cov er ing Image Pro cess ing lessons. When the lessons are employed Dis cov er ing Image Pro cess ing lessons. When the lessons are employed Dis cov er ing Image Pro cess ing
in a col lab o ra tive learn ing en vi ron ment, interpersonal com pe ten cies may 
also be at tained. Think ing skills, such as problem solving, decision making, 
rea son ing, and creative thinking are utilized through out Discovering Image 
Pro cess ing and are a key com po nent of the guided discovery approach.Pro cess ing and are a key com po nent of the guided discovery approach.Pro cess ing

“A major question about this 
technical world is, ‘Who will develop 
and control the technologies so that 
they can best serve all citizens?’ In 
the broadest sense, the answer has 
to be, for a democratic society, a 
technically literate citizenry.”

    American Association for the 
    Advancement of Science

    Technology:  A Project 2061 
    Panel Report
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Image processing in the classroom
Each lesson in Discovering Image Processing uses one or more image Discovering Image Processing uses one or more image Discovering Image Processing
pro cess ing skills to ma nip u late, analyze, and interpret digital images. 
Lesson instructions guide the student through the required techniques. The 
following table shows which skills are used in each lesson.
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Pixelated Pictures • • • •
Lights, Camera, Action! • • • • • •
Digital Detective • • • • • • • • • •
More Than Numbers • • • • •
North American Tour • • • • • • • •
Digitizing Details • • • • • •
Picture Yourself • • • • • • •
Color by Number • • • • •
Photo Eff ects • • • • •

Images for Science • • • • • • • • • •

Cross-curriculum integration
The lessons in Discovering Image Processing integrate well with other Discovering Image Processing integrate well with other Discovering Image Processing
subject areas:

Mathematics
Digital image processing is an inherently mathematical process. Working 
with scaling factors in “Picture Yourself” and analyzing histograms in 
“Photo Effects” provides practice with the mathematics skills of using 
ratios and interpreting graphs. Furthermore, measurements from digital 
images can be exported as data to a spread sheet pro gram for detailed 
analyses. Con verse ly, digital images can be created by entering for mu las 
into a spread sheet, allowing patterns to be readily de tect ed and analyzed.

Science
Many of the images used in Discovering Image Processing are from Discovering Image Processing are from Discovering Image Processing
scientifi c research. Parts of “Digital Detective” can serve as a lead-in to 
a unit on forensic science. Digital Elevation Models (DEMs) can be used 
to study landforms and to po graph ic features. Animation can be used to 
visualize dynamic processes in science.

Social studies
The geography in “North American Tour” easily ties into social studies. 
Students can identify the states in the U.S. as well as locate cities and other 
points of interest. They might choose to investigate the population den si ties 
of dif fer ent re gions.

“The study of technological systems 
should be used as a basis for 
providing integrated and holistic 
learning.”

National Science Board
Educating Americans
for the 21st Century
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Language and media arts
All of the above subject areas can be tied together by language and 
media arts. Students can compile what they have learned into a report 
using a variety of formats and media. If they have used an integrated 
software package con tain ing word pro ces sing, spread sheet, and graphics 
ca pa bil i ties, everything they have done can be brought together using the 
computer.

Discovering Image Processing lesson length
The lessons in Discovering Image Processing are designed to cover all Discovering Image Processing are designed to cover all Discovering Image Processing
of the major image processing and analysis capabilities of ImageJ. Each 
lesson is centered around one or more major image processing or analysis 
concepts or themes. As a result, some of the lessons are longer than many 
school class periods. To facilitate the implementation of these lessons, we 
have sub di vid ed them into sections.

Curriculum planning grid
Use the grid below to help you integrate science, math, social studies, 
lan guage arts, and media arts into your technology program.
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Pixelated Pictures • • •

Lights, Camera, Action! • • • •

Digital Detective • • •

More Than Numbers • • •

North American Tour • • • •

Digitizing Details • • •

Picture Yourself • •

Color by Number • • •

Photo Eff ects • • • •

Images for Science • • • • •

A platform for independent investigation
ImageJ is an image analysis research tool used by scientists around the 
world. The program is simple but powerful, capable of sophisticated 
image processing techniques but easy to learn and understand. As such, 
its ap pli ca tion to the classroom is a natural. Used on its own, ImageJ is 
completely open-ended. Student researchers must conceive, design, and 
create original images through such procedures as videomicroscopy or 
photography and fl atbed scanning. They must then develop a process for 
gathering data from the images, such as image en hance ment, fi ltering, 
thresholding, and mea sur ing. In these en deav ors, they mirror the 
pro cess es of research sci en tists.
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Instructional materials:  A launchpad to discovery
Computer and imaging technology are increasingly prevalent in the 
workplace. Good computer and image interpretation skills will be 
in valu able to information professionals of the 21st century. However, 
many students lack experience and confi dence with both com put ers and 
advanced imaging technologies. As a result, independent use of ImageJ as 
a learning tool becomes a formidable and even frightening prospect to the 
uninitiated.

CIPE instructional materials are designed to familiarize both the instructor 
and the student with the tools and techniques of digital image processing
as well as to model science process skills. Through these guided-discovery 
lessons, students learn con tent while building confi dence and ex pe ri ence 
with image processing as an in ves ti ga tive tool. After completing a few 
lessons, students may be ready to capture images to create their own 
digital data sets for independent analysis and exploration.

Creating your own images
The Discovering Image Processing CD-ROM provides all the images Discovering Image Processing CD-ROM provides all the images Discovering Image Processing
needed for the ac tiv i ties. How ev er, we encourage teachers and students to 
apply the image processing tech niques they learn from Discovering Image 
Processing to images that they have produced them selves. Students can Processing to images that they have produced them selves. Students can Processing
analyze images created by mi cro scopes, tele scopes, still and video cam er as, 
and medical and industrial equip ment.

Digital still and video cameras and inexpensive fl atbed scanners produce 
images that can easily be imported into the computer and analyzed using 
ImageJ. Analog images from videotapes, laserdiscs, and traditional 
fi lm cameras can also be converted to digital format using appropriate 
hardware and software. You can even create images directly from grids 
of measurement data. With digital imaging, you are limited only by your 
imagination!

Image resources
Parents, neighbors, friends, and relatives of students
A rich source of sup port and great connections to other sources.

Physicians and hospitals
X-rays; CT, MRI, and PET scans; EKG tracings; sonograms, etc.

Veterinarians, animal clinics, and zoos
X-rays of do mes tic and exotic animals, fur, feathers, and other structures 
for anal y sis.

Colleges and universities
Medical schools, nursing colleges, medical technician programs, biology 
de part ments, ed u ca tion al outreach programs, etc.

City/county government
Departments of transportation, engineering, and law enforcement; also 
libraries, zoos, museums, etc.

Fair use guidelines
The guidelines for fair use of 
copyrighted works for educational 
purposes have recently been 
updated and clarifi ed to deal 
with the use of in tel lec tu al 
property in digital technologies. 
These fair use guidelines were 
adopted on September 27, 1996, 
as a nonlegislative report by the 
Subcommittee on Courts and 
Intellectual Property, Committee 
of the Judiciary, U.S. House of 
Representatives.

To get a copy of the guidelines, visit 
their Web site:

http://www.libraries.psu.edu/
avs/fairuse/default.html

Important reminders
 • Exercise caution in down load ing 

works from the Internet. Some 
works may be copyrighted and 
may not be reused without 
permission.

 • When using an image under 
fair use, credit the source and 
display the copyright notice 
and ownership if shown in the 
original work.

 • Include a notice that certain 
materials in your pre sen ta tion 
are included under the fair use 
ex emp tion of U.S. Copy right Law 
and are restricted from further 
use.

 • If you make alterations to 
copyrighted works to achieve 
specifi c instructional objectives, 
note that alterations have been 
made.
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State government 
Departments of health, environmental quality, water resources, land, fi sh 
and game, and ag ri cul ture. Co op er a tive extension, geological survey, 
mines, parks, law enforcement, historical society, museums, etc.

Federal government
Federal government sources of image data include the USDA Forest 
Service, Department of Energy (DOE), National Park Service, Drug 
Enforcement Agency (DEA), Department of Defense (military bases), 
National Oceanographic and Atmospheric Administration (NOAA), as 
well as the Food and Drug Ad min is tra tion (FDA), Federal Bureau of 
In ves ti ga tion (FBI), En vi ron men tal Pro tec tion Agency (EPA), National 
Aeronautics and Space Administration (NASA), National Institutes 
of Health (NIH), etc. Many federal agencies publish image data on 
inexpensive CD-ROMs or via the Internet.

The Internet
ImageJ reads most of the popular image fi le formats found on the Internet. 
Larger images may be compressed for faster download, requiring the user 
to decompress or expand image fi les before they can be opened. CIPE’s 
Web site at http://www.evisual.org provides links to many images and  
resources.

Student assessment
In Discovering Image Processing, students organize in for ma tion, apply Discovering Image Processing, students organize in for ma tion, apply Discovering Image Processing
pre vi ous ly learned information to new situations, make con jec tures based 
on data they have gathered, and explain and justify their analyses. Teachers 
may use a variety of tools and methods for assessing how well students 
have ac com plished these tasks as they com plete the lessons in Discovering 
Image Processing. These tools are described below:

Image printouts and Data Sheets
The most direct method is to print out fi nal images and use the Data 
Sheet included with each lesson. The Data Sheets provide students with 
a struc tured format to respond to the ques tions in the lessons. Answer 
keys to these questions are included in the Teaching Notes section of the 
lessons.

Direct observation
The lessons in Discovering Image Processing present open-ended Discovering Image Processing present open-ended Discovering Image Processing
prob lems, giving students the chance to work cooperatively, think 
critically, and form conclusions. Spot-checking students as they work 
at the computer, asking ques tions that probe for com pre hen sion, and 
al low ing the students to ask for instructor feedback are all effective ways to 
informally assess student un der stand ing.

A few image resources
on the Web
 • American Memory

(Library of Congress)
http://memory.loc.gov

 • Astronaut Photography of Earth
http://eol.jsc.nasa.gov

 • Earth Observatory
http://earthobservatory.
nasa.gov

 • NASA ESA Landsat Photography
http://landsat.gsfc.nasa.gov

 • NASA Planetary Photojournal
http://photojournal.jpl.nasa.
gov

 • NOAA Image Library
http://www.photolib.noaa.
gov

 • National Space Science Data 
Center (NSSDC) Image Library
http://nssdc.gsfc.nasa.gov/
photo_gallery/

 • Terraserver
http://terraserver.microsoft.
com

 • USGS EROS Data Center
http://edc.usgs.gov

 • USGS Seamless Map Server
http://seamless.usgs.gov

 • Visible Earth
http://visibleearth.nasa.gov

 • Visible Human Project
http://www.nlm.nih.gov/
research/visible
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Image Processing Skills Checklist
A sample checklist for assessing basic image processing skills is provided 
on the next page. The list can be used to assess student skill mastery or for 
student self-evaluation. Modify it to meet your specifi c needs.

The list includes real-world, marketable computer skills that your students 
can learn through the Discovering Image Processing lessons. Students Discovering Image Processing lessons. Students Discovering Image Processing
can also apply these skills to conduct authentic scientifi c research using 
ImageJ. For more about each skill, see the ImageJ Skill Sheets on pages 
25-40.

Student collaboration
Many of the lessons in Discovering Image Processing are particularly suited Discovering Image Processing are particularly suited Discovering Image Processing
to col lab o ra tive learn ing environments. When all groups have fi nished a 
lesson, they can come back together as a class and share their results.

Student journals
Many teachers assess students’ written work by reading daily journal 
entries. For teachers who already include this tool in their technology 
curriculum, stu dents can record journal entries for each lesson. They might 
be asked to refl ect on things that they have learned on their own or from 
a classmate while completing the lesson or to tell something about their 
favorite image from a lesson.

Student portfolios
For teachers who use student portfolios in their assessment repertoire, 
im ag es can be printed and saved as hard copies along with other samples 
of student work. Students can include printouts showing images before 
and after they completed the assigned task. If the portfolio is in an 
electronic format, students’ work may be saved to disk as well.

Student presentations
A very effective way to assess student understanding of these lessons is to 
have them present what they have learned to the class or another group. 
These pre sen ta tions demonstrate both the students’ understanding of 
the underlying technology concepts taught in the lesson, as well as their 
ability to apply image processing to these concepts. Students could be 
en cour aged to use the computer as part of their dem on stra tion.

Web sites
Many educators have students construct imaging-based Web sites using 
simple WYSIWYG (what-you-see-is-what-you-get) HTML editors.

HTML
HTML stands for HyperText Markup 
Language. It is a set of instructions, 
called tags, that describe the layout 
and format of text, images, and 
other elements on Web pages.
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Name _________________________________________ Class _____________

Image Processing Skills Checklist

Window management
  Activating windows ____

  Organizing windows ____

  Changing window size and location ____

Image modes
  Changing image modes ____

  Selecting appropriate image mode ____

Lookup tables
  Applying new lookup tables to images ____

  Adjusting image brightness and contrast ____

  Adjusting lookup table windowing for 16- and 32-bit images ____

Selecting
  Making selections ____

  Modifying selections ____

  Moving selections ____

Editing
  Cutting and copying selections ____

  Pasting selections/using the Paste Control ____

  Cropping images ____

  Rotating and fl ipping images ____

  Resizing images ____

Drawing & Text
  Drawing lines and shapes ____

  Painting with selection tools ____

  Changing foreground/background color ____

  Changing line width ____

  Drawing text ____

Thresholding
  Adjusting the threshold range ____

  Measuring with thresholding ____

  Using the auto-selection (wand) tool ____

Using the skills
checklist
These skills are not all taught in 
every lesson. The matrix on page 
4 identifi es the major image 
processing skills that are utilized in 
each lesson.

Use the following scale to assess 
skill level. You may want to establish 
criteria for each level de pend ing 
upon your students’ abilities and 
ex pe ri enc es.

 1 Novice (just beginning to learn, 
needs much help)

 2 Beginner (needs a little help)

 3 Able (can accomplish by 
referring to in struc tions)

 4 Accomplished (can help others)

 5 Expert (highly skilled)

The list can be also used for student 
self-assessment.
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Image enhancement
  Enhancing image contrast ____

  Applying image fi lters ____

Calibration
  Spatial calibration ____

  Density calibration ____

  Removing image calibration ____

Measurement
  Setting measurement options ____

  Measuring distance and area ____

  Measuring angles ____

Analysis
  Making and interpreting histograms ____

  Making and interpreting profi le plots ____

  Making and interpreting surface plots ____

Stacks
  Creating stacks ____

  Flipping through slices in stacks ____

  Animating stacks ____

  Editing stacks ____

  Making montages ____

  Split color images/merge RGB channels ____

  Create Z-axis profi les of stacks ____
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Installation
Windows installation

System requirements
 • 200 MHz Pentium II or faster computer with color monitor

 • Windows 98, ME, 2000, or XP

 • Minimum 64 MB available RAM (256 MB or more preferred)

 • The ImageJ application requires 21 MB available hard drive space. 
Approximately 200 MB is required for installing the lesson data.

Install ImageJ
 • Insert the Discovering IP 2 CD-ROM into your computer’s CD drive.

 • Click the Start button on your computer’s desktop, choose Start button on your computer’s desktop, choose Start My 
Computer, then double-click the CD drive icon to view the CD 
contents.

 • Open the Software folder on the CD (in Windows, a folder is also 
called a directory), then open the directory), then open the directory Windows folder.

 • Double-click the ImageJ.msi application icon to start the ImageJ 
installer.

  • Follow the on-screen instructions in the ImageJ Setup Wizard to install 
ImageJ. 

 • On the Ready to Install screen, review your installation settings, 
then click Install to complete the installation.

 • An ImageJ application shortcut should now be available on your 
desktop. Double-click 

application shortcut should now be available on your 
  to launch the ImageJ application.

Need more help?
Additional installation instructions 
and troubleshooting notes are 
available via the Internet at

http://rsb.info.nih.gov/ij/
download.html

When you insert the CD-ROM into 
your computer’s CD drive, you’ll see 
a dialog box that reads: “What do 
you want Windows to do?”

Just click Cancel. 

When you open the Windows
folder inside the Software folder, 
you’ll see the ImageJ Installer.msi 
icon. (Many Windows computers 
are set to hide the three-letter 
fi lename extensions, so you may 
see “ImageJ” instead of “ImageJ.
msi,” as shown below.).
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Install lesson data
Lesson images can be accessed directly from the Discovering IP 2 CD-
ROM. However, for best performance, it is recommended that you copy the 
lesson data to your computer’s hard drive.

 • Open the Lesson Data folder on the Discovering IP 2 CD-ROM.

 • Copy the desired lesson folders to your computer’s hard drive. You may 
copy them into the ImageJ folder or to any convenient location. (Refer 
to your computer’s documentation for instructions on copying fi les.)

Test your installation
 • If you have not already launched ImageJ, double-click  (on your 

desktop) to open it, or choose Start > All Programs > ImageJ.Start > All Programs > ImageJ.

 • Choose File > Open…, navigate to a lesson data folder on the CD or 
your hard drive, and open an image fi le.

Displaying fi le extensions
In this guide, computer fi lenames end in three-character fi le extensions 
such as .txt, .tif, .jpg, and .gif. Unfortunately, many Windows computers are 
set to hide these extensions. To force fi le extensions to display:

 1. Choose Start > My Computer.

 2. Choose Tools > Folder Options... (Windows XP, NT, 2000, or ME) or 
View > Folder Options... (Windows 98).

 3. On the View tab, uncheck the box next to Hide extensions for 
known fi le types.

 4. Click Apply, then OK to close the Folder Options window.

 5. Close the My Computer window.

Uninstalling ImageJ
The MSI installer used to install ImageJ on your PC creates an entry in the 
Windows registry, a database of installed software. To remove ImageJ: 

• Click Start in the lower left of your screen, and then click Start in the lower left of your screen, and then click Start Control 
Panel.

• In the Control Panel, double-click Add or Remove Programs. 
Choose ImageJ from the list and click Remove. 

Both ImageJ and the quick launch icon on the desktop will then be 
removed from your computer.

Re-installing ImageJ
You can install ImageJ again from 
the CD if you wish or from the 
ImageJ Web site (http://rsb.info.
nih.gov/ij). However, if you install 
a newer version from the Web site, 
you will have to separately install the 
several plugins used in the lessons.
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Macintosh installation

System requirements
 • Power Macintosh Computer with color monitor

 • MacOS 8.x or newer or Mac OS X.x

 • Minimum 64 MB RAM (256 MB or more preferred)

 • The ImageJ application requires 3 MB available hard drive space. 
Approximately 200 MB is required for installing the lesson data, and 
additional space is needed for the Images to Explore folder.

Install ImageJ
 • Insert the Discovering IP 2 CD-ROM into your computer’s CD drive.

 • Double-click the Discovering IP 2 CD icon on your desktop to view 
the CD contents.

 • For OS X, double-click the Software folder, then the Mac OS X 
folder. Drag and drop the entire ImageJ folder to the Applications
folder on your hard drive.

 • For OS 8/9, double-click the Software folder, then the Macintosh 
folder. Drag and drop the entire ImageJ 1.34 folder to the 
Applications (Mac OS 9) folder or a convenient location on your 
hard drive. 

 • To run ImageJ, double-click on the ImageJ icon. 

Create an ImageJ alias
 • Open the ImageJ folder you installed, single-click    to select ImageJ, 

and choose File > Make Alias.

 • Drag the alias you created to the desktop or to the OS X dock. You may 
move or rename the alias at any time, as long as you do not move the 
original application.

Install the lesson data
Lesson images can be accessed directly from the Discovering IP 2 CD-
ROM. However, for best performance, it is recommended that you copy the 
lesson data from the CD-ROM to your computer’s hard drive.

 • Open the Discovering IP 2 CD-ROM.

 • Copy the entire Lesson Data folder, or open the Lesson Data folder 
and copy selected lesson folders to your computer’s hard drive. You may 
copy the lesson data folders into the ImageJ folder you installed earlier.

Test your installation
 • Double-click the ImageJ alias icon on your desktop.

 • Choose File > Open… from the ImageJ menu bar, navigate to a lesson 
data folder on the CD or your hard drive, and open an image fi le.
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Uninstalling ImageJ
 • For OS X, drag and drop the entire ImageJ folder from the 

Applications folder on your hard drive to the Trash. In the Finder, 
choose Finder > Empty trash ..., and click OK. 

 • For OS 8/9, drag and drop the entire ImageJ 1.34 folder from the 
Applications (Mac OS 9) folder (or other location where you stored 
it on your hard drive) to the Trash.  From the Special menu, choose 
Empty trash.

Locking images to prevent changes
The fi les on the Discovering IP 2 CD-ROM cannot be modifi ed or 
overwritten. However, after copying image fi les to your hard drive, they 
can be changed. To lock these fi les to prevent them from accidentally being 
altered, follow the instructions below. If a fi le is accidentally changed or 
deleted, replace it with a fresh copy from the CD.

Macintosh
 • In the Finder, select the icon of the image fi le you want to lock

 • Choose File > Get Info to open the fi le’s Info window.

 • Check the Locked checkbox, and close the Info window.

Windows
 • In My Computer, right-click the icon of the image fi le you want to 

lock.

 • Choose Properties from the menu that appears, and select the General
tab.

 • Check the Read-only attribute checkbox, and click OK.

Locking fi les

Re-installing ImageJ
You can install ImageJ again from 
the CD if you wish or from the 
ImageJ Web site (http://rsb.info.
nih.gov/ij). However, if you install 
a newer version from the Web site, 
you will have to separately install the 
several plugins used in the lessons.
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Update with care!
Warning: Program features and the 
user interface of future versions 
of ImageJ may not match the 
instructions given in the Discovering 
Image Processing lessons. The 
instructions are based on ImageJ 
Version 1.34s provided on the 
Discovering IP 2 CD.

Troubleshooting
Updating ImageJ (Mac & Win)
ImageJ is a work in progress, and is continuously being updated and 
improved by its author, Wayne Rasband of the National Institutes of Health.

Problem: “How do I update ImageJ?”

Solution: Download the latest ij.jar fi le from http://rsb.info.nih.gov/ij/
upgrade. To install the fi le:

 • Windows and MacOS 8-9: Open the ImageJ folder, and replace the 
old ij.jar fi le with the new version.

 • Mac OS X: Open the ImageJ folder, control-click the ImageJ icon, 
and choose Show Package Contents from the contextual menu. 
Replace the old ij.jar fi le in the Contents\Resources\Java folder with 
the new version.

Increasing ImageJ memory (Mac & Win)
By default, ImageJ is set to reserve 128 MB of RAM for storing and 
processing images. If you need to work with more or larger images, you 
may wish to make more memory available to ImageJ.

Problem: “How do I increase the amount of memory available to ImageJ?”

Solution: To increase the memory allocation for ImageJ:

 • Launch the ImageJ application.

 • Choose Edit > Options > Memory..., enter a new Maximum Memory size, 
and click OK.

 • Quit and re-launch ImageJ.

Missing fi le extensions (Win)
Problem: “I don’t see the .txt fi le extension at the end of the fi le names.”

Solution: In Windows, open the Files and Folders control panel, and 
uncheck the Hide known fi le extensions option. 

ImageJ won’t let me do anything (Mac & Win)
Problem: “ImageJ seems to be frozen and won’t let me do anything. I can 
activate and move windows but can’t modify the images in any way.”

Solution: There may be a hidden window or dialog box waiting for input 
that must be closed before you can proceed. Move windows around, close 
or hide other applications, and look for this window or dialog box.

The ImageJ menus disappear (Mac)
Problem: “When I switch between windows, the ImageJ menu headings 
sometimes disappear.”

Don’t overdo it!
Entering more than 75 percent of 
your installed RAM is not advised. 
The maximum amount of memory 
that can be allocated to ImageJ 
regardless of the amount of installed 
RAM is about 1.7 GB.
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Solution: Press the Enter key on your keyboard to move the ImageJ 
window to the front. This should update the menu.

ImageJ is labeling and drawing in the wrong
colors (Mac & Win)
Problem: “When I draw labels, shapes, text, etc. on an image, they are not 
drawn in the foreground color, but in another color or a shade of gray.”

Solution: Choose Image > Type > RGB Color to convert the image (even Image > Type > RGB Color to convert the image (even Image > Type > RGB Color
grayscale images) to an RGB color image.

I can’t copy and paste between ImageJ and other 
applications (Mac & Win)
Problem: “I selected and copied (Edit > Copy) an image in ImageJ, but 
when I try to paste it into my word processor (or other application), 
nothing is there to paste.”

Solution: Use the System Clipboard plugin to copy and paste between 
ImageJ and other applications. Choose Plugins > System Clipboard to 
display the System Clipboard window. Click the Copy button to copy the Copy button to copy the Copy
current ImageJ selection to the system clipboard, and click the Paste
button to paste the contents of the system clipboard into the current 
ImageJ window. (Note: The System Clipboard plugin does not work with 
Mac OS 8 or OS 9.)

I don’t see the ___________ plugin. Where is it? 
(Mac & Win)
Problem: “I am doing a lesson that calls for a specifi c plugin, but I don’t 
see it listed at the bottom of the Plugins menu.”

Solution: Copy the TurboReg and Stacks folders from the Plugins folder 
on the Discovering IP 2 CD to the Plugins folder of your ImageJ location. 

My Y-coordinates do not match those in the
answer key (Mac & Win)
Problem: “My answers are different from those in the answer key. The X-
coordinates agree, but all of my Y-coordinates are different.”

Solution: Choose Analyze > Set Measurements… and turn on (check) the 
Invert Y Coordinates option.

ImageJ dialog boxes, menus, or tools don’t 
match those shown in the book (Mac & Win)
Problem: “The dialog boxes, menus, or tools in ImageJ look or work 
differently than the ones shown in this book.”

Solution: You are using a version of ImageJ that is older or newer than the 
one provided with this book (1.34n). Do so at your own risk.

ImageJ quits for no apparent reason (Mac)
Problem: “At random times, ImageJ quits and gives the message ‘The 
application JavaApplicationStub has unexpectedly quit.’”

More info...
Most applications hold copied data 
in a section of memory called the 
system clipboard, which is managed 
by the operating system. ImageJ 
uses its own clipboard memory for 
these operations, and this clipboard 
is not available to other applications.

More info...
The colors available for drawing on 
an image are limited by the type of 
image. Grayscale images can only be 
drawn on with grays. 

More info...
At the time of this writing, this 
issue has been mostly fi xed, but 
still occurs occasionally. It is simply 
a menu update issue that can be 
forced by changing windows.

More info...
Plugins for ImageJ can be 
downloaded from the ImageJ Web 
site. Choose Help > ImageJ Web 
Site…, and click the Plugins link on 
the Web page. Read and follow all 
installation instructions carefully.

More info...
ImageJ displays images starting at 
the upper left corner of the window, 
so the default origin (0,0) is located 
there. The Invert Y Coordinates
option is a convenience for those 
preferring the origin in the lower 
left corner, to match the Cartesian 
coordinate system.

More info...
If you want to use a newer (or an 
older) version of ImageJ, you can 
install more than one version on 
your computer. Just give each a 
name that helps you tell the versions 
apart.
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Solution: This is a known issue when running ImageJ under Mac OS X, 
but there is no defi nitive solution. While not a solution, it may be helpful 
to increase the memory allocated to ImageJ. Choose Edit > Options… 
Memory… and enter a higher value. It’s probably wise to keep your 
memory allocation to about half of the installed RAM. (For example, on a 
computer with 1 GB of installed RAM, set the memory allocation to 512 
MB.) Fortunately, the crash does not affect other applications, so re-launch 
ImageJ, re-open the images you were using, and pick up where you left off. 
If you are performing complex processes on images, be sure to save your 
work often.

Problems opening fi les by drag-and-drop (Mac)
Problem: “When I drag a group of fi les and drop them onto the ImageJ 
application or alias icon, some of the fi les open, some open multiple times 
(identical copies), and some don’t open at all.”

Solution: This is another known issue with ImageJ. Instead of dropping 
the fi les onto the ImageJ icon, you can drop them on the ImageJ window 
and they will open properly. However, it is usually best to use the File > 
Open… menu command within ImageJ to open fi les. Type either the letter 
O or Control-O as a shortcut to quickly open the Open dialog box.
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The ImageJ user interface
The ImageJ user interface is nearly identical for Windows and Macintosh 
operating systems, except for the location of the menu bar.

Windows
 Under Windows, the menu bar is at the top of the ImageJ window.

Macintosh
On the Macintosh, the menu bar is at the top of the screen, separate from 
the ImageJ window.

The ImageJ toolbar

ImageJ
Quick Reference

image status bar

image window

status bar

title bar

tool bar

ImageJ window

menu bar

Need to know more?
For additional information about 
ImageJ’s tools and menus, refer to 
the online user’s guide at:

http://rsb.info.nih.gov/ij/docs/

This guide can be opened from 
within ImageJ by choosing Help > 
Online Docs...

ImageJ updates
ImageJ is constantly being updated 
and improved. Updating your copy 
of ImageJ from the version included 
with this package may result in 
changes to the user interface. The 
capabilities of the program may 
also change signifi cantly, and lesson 
instructions and results may need to 
be modifi ed.

You can have access to the latest 
tools and functions while retaining 
compatibility with these materials by 
installing multiple copies (versions) 
of ImageJ on your computer. Each 
copy can be launched and run 
independently.

image status bar

image window

status bar

title bar

tool bar

ImageJ window

menu bar

Freehand line selections
Segmented line selections

Straight line selections
Freehand selections

Polygon selections
Oval selections

Rectangular selections

Color picker
Scrolling tool

Magnifying glass
Text tool

Wand (tracing) tool
Point selections
Angle tool

Freehand line selections Pencil toolPencil tool
Paintbrush tool

Eraser tool
Flood fi ll tool

Drawing Tools
(available via macro fi le)

Drawing tools
The blank buttons  will be replaced 
by additional tools in future versions 
of ImageJ.
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Tool descriptions

Area selection tools
The area selection tools allow you to select an area, or region of interest
(ROI), of the image using a rectangle, oval, polygon, or freehand shape, 
or some combination of these shapes. To move a selection, click and drag 
within the selection outline, or use the arrow keys to nudge the selection 
one pixel at a time in any direction. The selected areas can be edited, 
enhanced, analyzed, outlined, fi lled, or copied using menu commands and 
keyboard shortcuts. As you make a selection, the location and dimensions 
of the selection are displayed in the ImageJ status bar.

To measure the selected area, press M (measure); to outline the selected 
area using the foreground color, press D (draw); to fi ll the selected 
region with the foreground color, type F (fi ll); and to fi ll the area with the 
background color, press the Backspace key (Delete key on Macs).

To subtract from an existing selection using any of these tools, hold down 
the Alt (Win) or Option (Mac) key as you make the selection. To add to 
an existing selection, hold down the Shift key as you make additional Shift key as you make additional Shift
selections. Note: When adding selections with the rectangle and oval tools, 
you can avoid constraining your selection to a square or circle by releasing 
the Shift key before you release the mouse button.Shift key before you release the mouse button.Shift

Rectangle
  When creating rectangular selections, click on one corner of the 

area and drag to the opposite corner. Hold the Shift key down to Shift key down to Shift
constrain the selection to a square. You can modify the selection 
by dragging any of the eight square handles around the edges 
of the selection. In addition, you can use the Alt (Win) or Alt (Win) or Alt Option
(Mac) key combined with the Arrow keys to change the height 
and width of the selection by one pixel at a time.

Oval
  Creates elliptical selections that can be moved and resized using 

the same methods as rectangular selections.

Polygon
  Creates irregularly shaped selections composed of a series of line 

segments. Click at the end of each segment, then click in the small 
box at the starting point to complete the selection. Alternatively, 
you can double-click at the end of the next-to-last segment, and 
ImageJ will automatically complete the last segment. To modify 
the polygon, drag the square handles at each vertex. To delete a 
vertex, hold down the Alt (Win) or Option (Mac) key and click 
on the vertex. To add a vertex, hold down Shift and click on a Shift and click on a Shift
segment.

Freehand area
  The freehand area tool lets you drag the cursor to create 

irregularly shaped selections. The area will automatically close 
when you release the mouse button. To edit a freehand area, 
choose Edit > Selection > Fit Spline. The resulting selection can 
then be edited using the same methods as the polygon selection 
tool.

Setting line width
To set the drawing line width for all 
of the selection tools, double-click 
any of the line selection tools and 
set the desired width in pixels.

Changing the selection 
outline color
By default, ImageJ uses a yellow line 
to outline selection. This may not 
always be appropriate, such as when 
selecting against a light (or even 
yellow) background. To change the 
selection outline color, choose Edit 
> Options > Colors... and choose 
a diff erent color.

Editing selections
with handles

To modify a selection with editing 
handles (the small squares along the 
selection line), drag a handle to the 
desired location.

With polygon selections, you can 
Alt-(Win) or Option-(Mac) click on click on click
a handle to delete it, and Shift-click 
on a handle to add a new handle.

To modify a selection with editing 
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Line selection tools
The line selection tools create straight, segmented, or freehand line 
selections. Drag or use the arrow keys to move line selections, and drag 
handles to edit the selection. To measure the selected line, press M
(measure); to draw the selected line using the foreground color, press D
(draw) or F (fi ll); and to draw the line with the background color, press the 
Backspace key.

Caution: Regardless of the shape selected, measurements made 
with the line selection tools include only the pixels under or under or under behind
the line. Using the segmented or freehand line selection tools to 
select and measure areas will produce incorrect results.

Straight line
  Click, drag, and release the mouse button to defi ne the endpoints 

of a line selection. Hold down the Shift key while dragging to Shift key while dragging to Shift
constrain the line to vertical or horizontal. While dragging, the 
length and angle of the line is displayed in the status bar.

Segmented line
  Use the segmented line tool to select lines made of straight line 

segments. Click once at the end of each segment, and double-click 
at the fi nal endpoint. If double-clicking is diffi cult, you can also 
click in the box at the beginning of the line. (Unlike the polygon 
area tool, the segmented line tool cannot “close in” an area.)

Freehand line
  Use the freehand line tool to create irregular line selections by 

dragging on the image. To convert the freehand line to an editable  
curved line, choose Edit > Selection > Fit Spline.

  Angle tool
The angle tool selects angles on images using three clicks—the fi rst defi nes 
one leg, the second the vertex, and the third the other leg. After the fi rst 
click, the status bar displays the angle of the cursor, measured ±180° 
relative to the 3 o’clock position. After the second click, the status bar 
displays the interior angle (≤ 180°) of the angle defi ned by the fi rst leg and 
the current cursor position.

To edit an angle, drag any of the three handles. As you drag a handle, the 
changing angle measurement is displayed in the status bar.

  Point selection tool
Click on the image with the point selection tool to select, mark, and record 
locations on the image. To select multiple points, hold down the Shift key Shift key Shift
while clicking on each location. Drag a point to move it, and Alt-click (Win) 
or Option-click (Mac) a point to delete it.

In Auto Measure mode, each click on the image records the coordinates 
and brightness value of the pixel in the Results window. Double-click the 
point selection tool button to turn on the auto-measure mode option or set 
the mark width. If a mark width greater than zero pixels is selected, a point 
will automatically be drawn each time you click on the image. To draw 
points without measuring, turn off Auto Measure, select a point, and 
press the D (draw) key.

Using the Angle tool
Selecting with the angle tool 
requires three clicks: (1) the fi rst leg, 
(2) the vertex, and (3) the second leg.

1

2
3

Point tool optionsPoint tool options

Line tool areas
Although it appears possible to 
select an area using the freehand 
line tool, the area reported when 
you measure the selection is not
the area enclosed by the selection. 
Rather, it is the area of the pixels 
crossed by the selection line, 
shown here in black. Always use the 
area selection tools to select and 
measure areas.
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Foreground
color

BackgroundBackground
color

Foreground &
background colors
The current foreground and 
background colors are shown on the 
color picker tool button. Double-
click this button to set these colors.

Note: with RGB color images, pixel values are reported on the status bar 
as separate red, green, and blue channel values. The value recorded in the 
Results window is the average of the R, G, and B values (not very useful!).

  Wand (tracing) tool  Wand (tracing) tool
The wand tool automatically fi nds the edge of an object and traces its The wand tool automatically fi nds the edge of an object and traces its 
shape. It works best with high contrast images. Place the wand to the left of 
an edge, and click to have ImageJ trace along the edge of the object until it 
returns to the starting point.

An object is defi ned as a cluster of pixels having the same color or value. 
ImageJ does not currently have the ability to defi ne an object based on a 
range of pixel values.

  Text tool

The text tool is used to add text labels to images. Adding text is a simple 
four-part process:

 • Click at the text’s desired location.

 • Type the text. This creates a selection shaped like the desired text, 
which expands as you type. Type Return (Enter on some keyboards) 
to create multi-line text. Use the backspace key to edit the text.

 • Drag the text selection, or use the arrow keys to move the selection to 
the proper location.

 • Draw the text using Ctrl+D or by choosing Edit > Draw.

Double-click the text tool button to select the text font, size, and style. Text 
draws in the foreground color defi ned in the color picker tool button.

Note: Drawing text on an image destroys data by replacing the original 
pixel values with the foreground color. Text cannot be edited after it is 
drawn, but it can be deleted by immediately choosing Edit > Undo. After 
this, the only way to delete text is to choose File > Revert, which will undo 
all changes made to the image since it was last saved.

  Magnifying glass (zoom) tool
To zoom in or magnify the image up to 32×, click on the image or press To zoom in or magnify the image up to 32×, click on the image or press 
the + key repeatedly. To zoom out or reduce an image down to 1/32×, you 
may right-click, Option-click (Mac), Alt-click (Win), or press the - key 
repeatedly. Double-clicking 

Option-click (Mac), 
 returns the image to full size. returns the image to full size.

  Scrolling tool

This tool allows you to move the image within its window if it is larger than 
the window. While using any other tool except the text tool, you can quickly 
toggle on the scrolling tool by holding down the space bar.

  Color picker tool
This tool sets the foreground drawing color or text color by “picking up” This tool sets the foreground drawing color or text color by “picking up” 
colors from images with the cursor. Colors may also be picked up from 
the CP (color picker) window by double-clicking the color picker button. 
Alt-click (or Option-click) in the CP window to change the background 
color. The eyedropper in the color picker tool button shows the current 
foreground color while the frame around it shows the background color.

Selecting areas using
the wand tool

Image of leaf selected using the 
wand (tracing) tool. To isolate the 
background, the contrast had to 
be increased using the Brightness 
and Contrast control panel, and 
the contrast change permanently 
applied to the image.

Text tip
To add color labels to grayscale or 8-
bit color images, convert the image 
to RGB color fi rst, using Image > 
Type > RGB.
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Caution: Even though colors appear in the color picker tool, 
accurate colors are only available when working with RGB color 
images. On 8-bit color images, drawing colors will not match the 
foreground and background colors; on grayscale images, actual 
drawing colors will be shades of gray.

Drawing tools
In addition to drawing and fi lling shapes using the selection tools, 
ImageJ provides familiar drawing tools like those found in most graphic 
applications. The actual tools are provided through a macro fi le that ImageJ 
loads automatically at startup. If these tool buttons do not appear on the 
toolbar, you may need to install or replace this fi le.

Remember that the drawing tools permanently modify pixel values, and 
that scientifi c analysis may not be valid if the image has been modifi ed in 
any way.

  Pencil tool
  The pencil tool draws points and lines in the foreground color. Double-

click the tool button to set the diameter of the pencil tool.

  Paint brush tool
  The paint brush tool draws with a circular brush, using the foreground 

color. Double-click the tool button to set the diameter of the paintbrush 
tool.

  Eraser tool
  The eraser tool draws with a circular shape, using the background 

color. Double-click the tool button to set the diameter of the eraser 
tool.

  Flood fi ll tool
  The fl ood fi ll tool fi lls the pixel you click on and any adjacent pixels 

having the same value with the foreground color. Double-click the tool 
button to set the foreground color.
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Need to know more?
For a more detailed description of 
ImageJ’s tools and menus, refer to 
the online user’s guide at:

http://rsb.info.nih.gov/ij/docs

This guide can be opened from 
within ImageJ by choosing Help > 
Online Docs...

ImageJ menus

File menu
The File menu allows you to create 
new image windows, open existing 
image fi les, as well as print and save 
image fi les.

Edit menu
The Edit menu provides standard 

editing functions such as undo, cut, 
copy, and paste. In addition, it off ers 

the powerful Paste Control feature, 
drawing commands, and selection 

and program options.

Image menu
The Image menu provides 
functions for manipulating 
the display of images.

Process menu
The Process menu includes 

powerful data fi ltering and 
manipulation tools.

Analyze menu
The Analyze menu off ers a variety of 
tools and functions for measuring and 
representing image data.

Plugins menu
The Plugins menu provides 

access to ImageJ plugins 
and macros that expand the 

power and convenience of 
the application.

Help menu
The Help menu links to the 
ImageJ Web site and online 

documentation.

Window menu
The Window menu allows the user 
to control the placement of image 
and program windows in ImageJ.
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Lesson features

Computer icons 
indicate actions 
to carry out on 
the computer.

Microscope Microscope 
icons indicate icons indicate 
ImageJ menu ImageJ menu 
commands, commands, 
tools, or tools, or 
detailed detailed 
instructions.instructions.

Right-hand column gives menu com mands, 
helpful hints, defi nitions, and references to 

“ImageJ Skill Sheets”  for further instruction.

Image fi le 
name

Background information and 
introduction to lesson

Defi nitions, Defi nitions, 
explanations, explanations, 
tips, and tips, and 
diagramsdiagrams

Numbered 
items are 

questions to 
answer on the 

Data Sheet.
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ImageJ Skill Sheets 
Using the ImageJ Skill Sheets
There is no right or best way to use these resources. Here are two 
suggestions for using them in your classroom.

 • Copy and laminate the Skill Sheets, and post them near the computers.

 • Bind copies of the Skill Sheets, along with other useful reference 
materials, into handbooks. Give a copy to each student or workgroup, 
or place one at each computer.

If you need to know more
For more extensive information on image processing techniques using 
ImageJ, consult the online ImageJ user manual at:

http://rsb.info.nih.gov/ij/docs/index.html

The online documentation can also be accessed directly from ImageJ by 
choosing Help > Online Docs. Additional information is provided in the 
Troubleshooting section of this guidebook.
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What is a lookup table?
Digital images are produced by matching numerical values to colored 
pixels using a lookup table (LUT). The diagram below shows this 
relationship.

Manipulating the lookup table using the
Brightness and Contrast (B&C) window
Choose Image > Adjust > Brightness/Contrast to open the B&C window. 
The B&C window shows a histogram of the pixel values in the image and 
provides sliders to control how ImageJ maps pixel values to the lookup 
table. The following example shows how to enhance the contrast of an 
image using these controls.

Lookup tables and image types
Computers store and process information in the form of binary digits or 
bits. The number of bits that are used to represent each pixel in an image 
determines the number of possible values a pixel can have. ImageJ can 
work with 8-bit, 16-bit, and 32-bit grayscale images, as well as 8-bit and 

Lookup Tables
ImageJ
Skill

In the original low-contrast 
image, the pixel values 
cluster near the center of the 
histogram.  This corresponds 
to the middle shades of gray 
in the lookup table.

Adjust the Minimum and 
Maximum slider controls to 
match the lookup table to 
the range of pixel values. 

To make the contrast 
change permanent, click the 
Apply button in the B&C
window. Note: this changes 
the original pixel values!

0
1
2
3
4
5
6
7
8
9

10
11
12
13
14
15

0 0 0 0 3 8 9 5 5 5 8 3 0 0 0 0
0 0 0 7 9 12 6 4 4 5 6 11 13 3 0 0
0 0 8 6 4 10 5 4 10 10 11 12 12 11 7 0
0 8 12 6 5 4 4 6 12 12 11 15 12 11 6 3
2 11 12 10 11 4 4 10 12 11 11 11 12 10 5 4
7 6 12 12 10 1 4 13 10 14 14 14 14 6 4 4
4 6 15 12 4 1 8 13 8 14 14 14 14 8 4 4
5 5 11 5 1 3 9 14 14 14 13 10 13 1 1 4
5 4 6 5 1 3 13 14 14 14 7 7 8 1 1 4
4 4 4 6 10 3 7 13 14 13 2 3 9 7 4 4
7 5 4 9 12 9 2 7 14 9 2 3 7 4 9 4
2 5 4 5 14 9 3 7 14 9 3 2 3 13 10 7
0 7 5 4 10 9 3 3 10 9 3 3 8 10 13 2
0 0 7 4 10 4 1 3 4 3 3 1 4 8 3 0
0 0 0 7 6 7 3 3 3 3 1 7 7 2 0 0
0 0 0 0 3 7 7 7 7 7 7 3 0 0 0 0

Numerical values Lookup table Digital image

pixels = picture elements, the small 
colored squares or rectangles that 
make up a digital image.

Transfer function
The diagonal line on the histogram 
in the B&C window represents the 
transfer function (equation) that 
mathematically relates pixel values 
to the lookup table.

Clicking the Apply button uses 
the transfer function equation to 
convert the old pixel values to new 
pixel values.

Apply button uses 

transfer
function

histogram = graph showing the 
number of pixels in an image with 
each diff erent pixel value. Also called 
a frequency distribution chart.

N
um

be
r o
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ix
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s

2560
Pixel Value
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RGB Color and
Lookup Tables
RGB Color images do not use lookup 
tables. Rather, they defi ne the color 
of each pixel using three values, one 
each for the Red, Green, and Blue 
brightness of the pixel. Since each 
pixel can have any of 256 possible 
values for red, green, and blue, there 
are a total of 256 x 256 x 256 or 16.7 
million color combinations!

8-bit color
8-bit color images are like “paint-by-
number” pictures. Each image has a 
unique palette of up to 256 colors. 
In the same way that the colors 
from one picture may not work 
well for painting a diff erent scene, 
the lookup tables from 8-bit color 
images are not interchangeable. 
Thus, cutting and pasting between 
8-bit color images usually does not 
work well. To combine 8-bit color 
images, you must fi rst convert each 
image to RGB color using Image >
Type > RGB Color.

24-bit (RGB) color images. 8-bit images can have up to 256 different values, 
16-bit images can have over 65 thousand values, and 32-bit images can 
have billions of possible values.

In ImageJ, all lookup tables contain a maximum of 256 colors. In 8-bit 
grayscale and color images, each value corresponds to one color of the 
lookup table. Since the human eye cannot distinguish billions, or even 
thousands of different colors, it would be pointless to use 16- or 32-bit 
lookup tables. Therefore, these images are displayed using an 8-bit lookup 
table, with each color representing a range of adjacent pixel values, rather 
than a single value.

The process of displaying 16- and 32-bit data using a 256-color lookup 
table is called windowing. In ImageJ, windowing is controlled using the 
Window and Level (W&L) panel. To open the W&L panel, choose Image 
> Adjust > Window/Level. The Window control determines the number of 
adjacent pixel values that the 256-color lookup table is applied to. The Level
control sets the center pixel value of the range defi ned by the Window
control. Pixel values above this range appear white, and values below the 
range appear black. The example below, using a 16-bit image of a galaxy, 
shows the use of the Window and Level controls.

Using a different lookup table
ImageJ includes several built-in lookup tables and can open saved ImageJ
and NIH Image lookup tables. Lookup table fi les have a .lut fi le extension.

 • Choose Image > Lookup Tables to use a built-in lookup table,  and pick 
a lookup table from the list.

 • Use File > Open… to open lookup table (.lut) fi les.

Combining images with different lookup tables
To copy and paste between two images, or to combine multiple images into 
a montage or a stack, they must have the same lookup table. If they have 
different lookup tables, change the image type of all images involved in the 
operation to 8-bit grayscale (Image > Type > 8-bit) or RGB color (Image > 
Type > RGB Color).

The original 16-bit image 
contains more information 
than a 256-color lookup 
table can display eff ectively.  
As a result, only the bright 
center of the galaxy and a 
nearby star can be seen.  

By narrowing the window 
and adjusting the level, 
additional detail can be 
seen in the central region 
of the galaxy.

Narrowing the window 
further shows more detail 
in the faint, outer parts 
of the galaxy. The inner 
part of the galaxy is now 
outside the range of the 
lookup table, and appears 
“overexposed.”

bit = “binary digit”bit = “binary digit”bit

Bits and colors
4 bits = 24 = 16 colors

8 bits = 28 = 256 colors

16 bits = 216 = 65,536 colors

32 bits = 232 = 4.3 billion colors

Combining the two 8-bit color 
images above does not produce 
the desired result (below left). 
Converting the images to RGB color 
before combining them produces 
the appropriate result (lower right).
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Selecting
ImageJ
Skill

Selecting tells the computer which pixels you are interested in. This is 
done using the selection tools in the ImageJ window. Selected pixels are 
defi ned by a colored line or outline. The selected pixels can be copied, 
fi lled, erased, outlined, fi ltered, or measured. The ImageJ status bar 
displays relevant information about selections as you make them.

Area selection tools
Use these tools to create area selections.

Rectangle - Creates rectangular or square selections. Holding the 
Shift key down forces the selection to be a square. Use the Shift key down forces the selection to be a square. Use the Shift arrow
keys with the Alt (Win) or Alt (Win) or Alt Option (Mac) key pressed to change the 
width or height one pixel at a time.

Oval - Creates elliptical selections. Holding the Shift key down forces Shift key down forces Shift
the selection to be circular. Use the arrow keys with the Alt (Win) or Alt (Win) or Alt
Option (Mac) key pressed to change the width or height by one pixel.

Polygon - Creates irregularly shaped selections defi ned by a series of 
line segments. Click at each vertex of the polygon, and either double-
click or click in the box at the starting point to complete the polygon.

Freehand - Creates irregularly shaped selections by clicking and 
dragging with the mouse. When you release the mouse button, the 
area automatically completes.

Wand Tool - Creates a selection by tracing objects of uniform color 
or thresholded objects. To trace an object, either click inside near the 
right edge, or outside to the left of the object.

Line selection tools
Use these tools to create line selections.

Straight Line - Creates straight line selections. Holding the Shift key Shift key Shift
down forces the line to be horizontal or vertical.

Segmented Line - Creates segmented line selections by repeatedly 
clicking with the mouse. Each click defi nes a vertex. Double-click 
when fi nished.

Freehand Line - Creates freehand line selections by clicking and 
dragging with the mouse.

Angle - Creates angle selections using three mouse clicks. After the 
second click defi nes the angle vertex, the status bar displays the angle 
until you click the third time.

Menu Bar
Tool Bar

Status Bar

Selection ToolsSelection Tools

Reshaping selections
To resize or reshape selections, drag 
the small handles on the selection 
outline. To create editable handles 
on freehand selections, choose Edit 
> Selections > Fit Spline.

handle
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Creating complex selections
Area selections can be added to and subtracted from to create complex 
geometric and freehand selections. To add to an existing selection, hold 
down the Shift key while you select using any of the area selection tools. Shift key while you select using any of the area selection tools. Shift
(When using the rectangle or oval selection tools, release the Shift key Shift key Shift
after you begin making the new selection unless you want to constrain 
your selection to a square or circle.) An example of a complex selection is 
shown at right.

Moving selections
Position the cursor inside the se lect ion and drag it to a new location. You 
can nudge a selection one pixel at a time in any direction by pressing the 
arrow keys on your keyboard.

Selecting the entire image
Choose Edit > Selection > Select All, or press the A key.A key.A

Cancelling selections
Click anywhere on the image out side the selection boundary, choose Edit > 
Selection > Select None, or press Shift-A.

Restoring cancelled selections
Choose Edit > Selection > Re store Selection or press Shift-E.

Drawing selection boundaries
Choose Edit > Draw or press D. Set the drawing color using the Color 
Picker tool , by choosing , by choosing Image > Color > Color Picker, or press Image > Color > Color Picker, or press Image > Color > Color Picker Shift-K. 
Set the line width by choosing Edit > Options > Line Width… or by double-
clicking one of the line selection tools.

Filling selections
Choose Edit > Fill or press F. Set the drawing color (also called the 
foreground color) with the Color Picker tool by choosing Image > Color > 
Color Picker, by pressing Color Picker, by pressing Color Picker Shift-K, or by double-clicking the Color Picker 
tool itself. (Note: if the image type is 8-, 16-, or 32-bit, the drawing color will 
be the shade of gray closest to the chosen foreground color. See Image 
types and drawing colors at right.)

Erasing selections
Press the Backspace key to erase the selection to the background color.

Measuring selections
After making a selection, choose Analyze > Measure (or press M). To 
measure in spatially calibrated units, fi rst set the image scale by choosing 
Analyze > Set Scale….  To spatially calibrate an image, create a line 
selection corresponding to a known distance (e.g. 10 mm), then enter that 
distance in the Analyze > Set Scale dialog box. (See the Measuring Skill 
Sheet for more information on setting scale and measuring.)

Image types and
drawing colors
“Help! The foreground color is set to 
red, but outlines are drawn in gray!”

This “problem” is normal ImageJ 
behavior. Colors are only available 
when working with color images. If 
the image type is 8-, 16-, or 32-bit, 
lines and fi lls will be made in shades 
of gray rather than the selected 
foreground color.

If you need to draw on a grayscale 
image in color, you must fi rst 
convert the image to RGB color 
(Image > Type > RGB Color). RGB Color). RGB Color

A complex selection created using A complex selection created using 
the rectangle, oval, and polygon 
area selection tools by adding to a 
simple rectangular selection.

Saving selections
for later use
There may be times when you need 
to use the same selection over and 
over on a series of images. To save 
a selection, choose File > Save 
As... > Selection... and name the 
selection (do not change the .roi fi le 
extension).

To select the same region on 
another image or at another time, 
choose File > Open... and locate 
and open the saved selection fi le.
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Drawing & Text
ImageJ
Skill

Drawing tools
ImageJ includes four drawing tools that work the same as similar tools 
found in most graphic applications.

  The Pencil tool draws in the foreground color. The line width can be 
set by double-clicking the pencil tool button.

  The Paintbrush tool draws in the foreground color. The brush 
diameter is set by double-clicking the paintbrush tool button.

  The Eraser tool “erases” to the background color. The eraser 
diameter is set by double-clicking the eraser tool button.

  The Flood fi ll tool fi lls groups of adjacent pixels that have the same 
value with the foreground color.

In addition to the drawing tools, you can use any selection as a paintbrush. 
Create an area or line selection, and drag it slowly while holding down the 
F (fi ll) key to paint in the foreground color, or the Backspace key to paint 
with the background color.

Drawing lines and shapes
Use one or more selection tools to make a selection on the im age. (See 
the Se lect ing ImageJ Skill Sheet for more in for ma tion on mak ing Se lect ing ImageJ Skill Sheet for more in for ma tion on mak ing Se lect ing ImageJ Skill Sheet
se lec tions.) To draw the selection boundary, choose Edit > Draw or press 
the D key. Choose Edit > Fill or press the F key to fi ll the shape with the 
foreground color. Choose Edit > Clear or press the Edit > Clear or press the Edit > Clear Backspace key to fi ll 
the selection with the background color.

To set the width of the outline, choose Edit > Options > Line Width… or 
dou ble-click any of the line selection tools.

Adding text to images
To add text to an image:

 • Choose Edit > Options > Fonts… or double-click the text tool   to set 
the font, size, and style of text.

 • Click on the image using the text tool , and enter the desired text 
(backspace to delete and edit the text).

 • Drag the text frame to reposition the text, if necessary.

 • Press Ctrl-D (Win) or Cmd-D (Mac) to draw the text in the foreground 
color. (To delete text, choose Edit > Undo or press Ctrl-Z immediately.)

If you want your text to look less jagged, 
choose Edit > Options > Misc... and turn 
on the Antialiased Text option. For crisper 
(but jaggier) text, turn the antialiased text 
option off.

Image types and
drawing colors
If the image type is 8-, 16-, or 32-bit, 
lines and fi lls will be made in shades 
of gray rather than the selected 
foreground color.

To draw on a grayscale image in 
color, convert the image to RGB color 
(Image > Type / RGB Color).Image > Type / RGB Color).Image > Type / RGB Color

Foreground and
background colors?
The foreground 
and background 
colors appear in 
the Color Picker 
tool on the 
ImageJ tool bar.

To set the 
foreground color, 
click on a pixel 
in an image or in 
the Color Picker 
window using the Color Picker tool window using the Color Picker tool window using the Color Picker tool window using the Color Picker tool window using the Color Picker tool 

. Alt-click (Win), or click the Color 
Picker’s toggle button (Mac) to set Picker’s toggle button (Mac) to set 
the background color. Double-click 
the Color Picker tool to open the 
Color Picker window.

window using the Color Picker tool 

Foreground Color

Background Color

Precision color
Double-click anywhere in the Color 
Picker window to open a window 
with sliders for adjusting the red, 
green, and blue components of the 
foreground color.
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Cutting & Pasting
ImageJ
Skill

Basic cutting, copying, and pasting
 1. Make a selection (see the Selecting Skill sheet for more about making 

selections).

 2. Choose Edit > Cut or Edit > Copy to copy the selected pixels to the 
ImageJ clipboard.

 3. Choose Edit > Paste to put the copied selection back in the image 
window as a fl oating layer that can be moved around with the cursor.

 4. Drag the pasted selection to the desired location.

 5. Click outside the colored selection boundary to fi nish the paste 
operation. The original pixels are replaced with the pasted pixels.

Cutting and pasting between different image types
Different image types handle lookup tables differently. When you cut or 
copy a selection from an 8-bit grayscale image and paste it into an 8-bit 
color image, the results usually look awful. For best results, the images you 
are cutting or copying and pasting between should be of the same type.

 • If you need a grayscale result, convert all images to 8-bit grayscale.

 • If you need a color result, convert all images to RGB color.

The Paste Control
Normally, when you paste a selection, the original pixel values of the image 
are re placed by the pixel values of the fl oat ing layer. The Paste Con trol
al lows you to perform op er a tions be tween the pixel values of the two 
layers, pro duc ing in ter est ing transparency and blending effects.

To show the Paste Control window, choose Edit > 
Paste Control. The Paste Control only works while 
the pasted layer is still “fl oating” over the original 
image, and has no effect after the paste operation 
has been fi nished. Click the Close box in the Paste 
Control window to close the window.

What is the Transfer Mode?
The Transfer Mode de ter mines how the pixel 
values in the original image and the fl oating layer interact to produce new 
pixel values. Different Transfer Modes cause the fl oating layer to appear 
solid, trans par ent, or blend with the original image.

Changing the Transfer Mode 
Pull down the Trans fer Mode pop-up menu and choose a transfer mode.

Cut or Copy?
What is the diff erence between 
the Cut and the Copy commands? 
Both com mands copy the se lect ed 
pixels to the clip board, but Cut
re plac es the se lect ed pixels with 
the background color, while 
Copy leaves the se lect ed pixels 
unchanged.

What does each
Transfer Mode do?
To learn what each transfer mode 
does, refer to the ImageJ online 
documentation at:

http://rsb.info.nih.gov/ij/docs

Copying and pasting 
between ImageJ and 
other applications
ImageJ currently does not utilize ImageJ currently does not utilize ImageJ
the system clipboard that is used 
to move data between diff erent 
applications.

You may, however, be able to 
copy to or paste from the system 
clipboard through the System 
Clipboard plugin. Choose Plugins 
> System Clipboard and click 
the appropriate button. (Note: The 
System Clipboard plugin is not 
available for Mac OS 8.x or 9.x.) 
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Threshold display
options
Thresholding off ers three diff erent 
display options:

 • Red - pixels with values in the 
specifi ed range of values are 
highlighted red.

 • Black & White - pixels within 
the specifi ed range appear 
black, and pixels outside the 
limits appear white.

 • Over/Under - pixels with values 
below the specifi ed range are 
highlighted blue, and pixels 
above the range are highlighted 
green. Pixels within the specifi ed 
range are not highlighted.

Thresholding
ImageJ
Skill

What is thresholding?
Thresholding allows you to highlight the pixels throughout an image 
whose values are in a specifi c range. For example, if pixel values represent 
elevation, you can select all of the pixels with values between 10 and 20 
meters to represent a specifi c fl ooding region. Once thresholded, you can 
perform many functions on the highlighted pixels, such as measuring the 
area they cover.

Turning Thresholding on and off
 • To turn Thresholding on, choose Image > Adjust > Threshold….

 • To turn Thresholding off, click the Reset button in the Reset button in the Reset Threshold
window.

Adjusting the range of thresholded values
Drag the Lower and Upper Level slider controls in the Threshold
window or click the Set button and enter the Upper and Lower 
Threshold levels manually.

Measuring only the thresholded pixels
 • Choose Analyze > Set Measurements… and check the Limit to Threshold

checkbox.

 • Make measurements as described in the Measuring Skill Sheet.

 • To measure all of the pixels in the image, either turn off Thresholding 
mode or choose  Analyze > Set Measurements… and uncheck the Limit 
to Threshold checkbox.

Black & White - pixels within 

limits appear white.

Over/Under - pixels with values 
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Calibrating Images
ImageJ
Skill

Calibrating an image allows you to measure distance, area, and pixel value 
in meaningful units.

Spatial calibration
Spatial calibration defi nes horizontal and vertical dimensions of an image 
in real-world units such as millimeters, centimeters, miles, etc.

When there is a known distance in the image
When the image contains a grid, ruler, or object of known size:

 1. Use the straight line selection tool  to select a known distance on the  to select a known distance on the 
image.

 2. Choose Analyze > Set Scale….

 3. Enter the Known Distance.

 4. En ter the Unit of Length.

 5. Click OK.

When you know the scale (e.g., 1 pixel = 0.025 mm)
 1. Choose Analyze > Set Scale….

 2. Enter the Distance in Pixels (1).

 3. Enter the Known Distance (0.025).

 4. Enter the Unit of Length (mm)

 5. Click OK.

Uncalibrating an image (removing the scale)
 1. Choose Analyze > Set Scale…

 2. Enter 0 for the Known Distance, or delete the Unit of Length.

 3. Click OK.

Density calibration
Pixel values often represent measurements—temperature, elevation, 
brightness, etc.—recorded at regular intervals in a grid pattern. Sometimes 
the pixel values are the actual measurements, but often they are only 
proportional to the actual measured values. Density calibration is the process 
of scaling the pixel values to approximate the original measured quantities.

The information needed to density calibrate an image can come from either 
of two sources—measurements made on the image itself (such as from a 
calibration bar), or from image metadata (information about the image, 
often provided in a separate text fi le, printed manual, or Web page).

Setting scale

What is the Pixel
Aspect Ratio?
ImageJ always displays pixels as 
squares, but some imaging devices 
use rectangular pixels. The Pixel rectangular pixels. The Pixel rectangular
Aspect Ratio setting tells ImageJ 
how to adjust for non-square 
pixels, so that length and area 
measurements are accurate.

You can determine the pixel aspect 
ratio of a camera or scanner by 
creating an image of a circular 
object and carefully measuring the 
height and width of the object in 
the image. Divide the measured 
width by the height (both in pixels) 
to get the pixel aspect ratio.

For example, the width of this 
scanned nickel was 255 px and the 
height was 250 px, a 
pixel aspect ratio 
of 1.02. Unless 
otherwise noted, 
leave the pixel 
aspect ratio set to 1 
(square pixels).
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Density calibration from image measurements
If an image includes a density scale or 
regions of known value, you can calibrate 
it by taking measurements directly from 
the image. In this example, the image 
represents sea surface temperature near 
the East coast of the United States. The 
calibration bar relates pixel brightness to 
the temperature in degrees Celsius.

 1. Choose Analyze > Clear Results to 
delete any previous measurements.

 2. Use a selection tool to select a small 
portion of the calibration bar on the 
image, and press M to measure the 
average pixel value of the selection. 
Repeat this for one or more other 
regions of known temperature.

 3. Choose Analyze > Calibrate… to open the Calibrate window.

 4. The average pixel values you measured should be listed in the left-hand 
column of the Calibrate window. Enter the known value (Temperature 
in this case) in the right-hand column for each measured value.

 3. Enter the appropriate units in the Unit box.Unit box.Unit

 4. Select Straight Line from the Function popup menu.

 5. Click OK. A plot of the calibration function and a list of pixel values 
and their corresponding calibrated values are displayed. Close these 
windows.

As you move the cursor around the image, the status bar will now display 
both the calibrated and uncalibrated pixel values. Pixel measurements 
(mean, minimum, maximum, etc.) will also be made using calibrated values.

The Calibrate window

Calibration functions
Not all image calibrations use a 
straight line function. In general, you 
should choose the simplest function 
that “fi ts” the calibration data you 
entered.

The correlation coeffi  cient, labeled 
R2 on the calibration plot, tells how 
well the function you chose fi ts 
the data.  The closer this value is to 
1, the better the fi t. (A correlation 
coeffi  cient of 1 represents a “perfect 
fi t.”  However, don’t get too excited 
if your R2 = 1. With only two points, 
you will always get a perfect fi t, 
but that doesn’t mean that your 
calibration is perfect!)

Image calibration barImage calibration bar
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Density calibration from image metadata
In this example, you are working with an image of the surface of Mars. The 
pixel values represent elevation (dark = low, bright = high).

The image is accompanied 
by a label (.lbl) fi le containing 
image metadata (information 
about the image data). From about the image data). From about
this fi le, you learn that the 
elevation values in the image 
range from -8068 meters to 
21134 meters. The minimum 
and maximum values in the 
image range from 0 to 255.

 1. Choose Analyze > Calibrate… to open the Calibrate window.

 2. Enter the known minimum and maximum pixel values in the left-hand 
column and the corresponding minimum and maximum elevation 
values in the right-hand column.

 3. Enter the appropriate units in the Unit box.Unit box.Unit

 4. Select Straight Line from the Function popup menu.

 5. Click OK. A plot of the calibration function and a list of the pixel values 
and their corresponding calibrated values are displayed. Close these 
windows. The ImageJ status bar and Results window will now display 
calibrated pixel values.

How to tell if an image is calibrated
Spatially calibrated  images show X and Y in both calibrated units and 
pixels in the ImageJ status bar. The image window status bar also shows 
the dimensions of the image in calibrated distance units.

Density calibrated images show pixel values in both calibrated units and 
raw values in the ImageJ status bar.

Removing density
calibration
To remove the density calibration 
from an image:

 • Choose Analyze > Calibrate…

 • Set the calibration function to 
None.

 • Click OK.

The Calibrate window
To enter or change values in the 
Calibrate window, click in a column 
and type the number. Press the 
Return key to enter the next value.

Be an image detective
Spatial and density calibration data 
can come from many sources. It 
may be found in separate label 
(.lbl) or header (.hdr) fi les, or it may 
be embedded at the beginning of 
the image fi le itself or in the image 
documentation. You may even be 
able to get the information from the 
person or agency that provided the 
images.

Spatially Spatially 
Calibrated

Density Density 
Calibrated

Spatially Spatially 
Calibrated
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Before you begin measuring images, you may need to:

 1. Calibrate the image (see the Image Calibration Skill Sheet.)

 2. Choose (set) the measurements you want to make.

Setting measurements
 1. Choose Analyze > Set Measurements….

 2. Check the measurements you wish to make and set the number 
of decimal places for your measurements. See opposing page for 
descriptions of each measurement.

 3. Click OK.

Measuring
 1. You can measure the entire image or select a portion of the image 

using the selection tools. See the Selecting Skill Sheet for more 
information about making selections. If nothing is selected, ImageJ
measures the entire image.

 2. Choose Analyze > Measure, or press M to measure the selection.

 3. After the fi rst measurement, the Results window appears. The 
Results window is updated after each measurement.

The Results window
Measurement results are displayed in the Results window. Measurements 
can be saved to a text fi le, cut, or copied for use in other programs such as 
spreadsheets or graphing applications using the options available from the 
Results window menu bar. On Windows computers, the results menu bar 
is part of the Results window; on Macintosh computers, the results menus 
appear at the top of the screen when the Results window is active.

Deleting all measurements
To delete all measurements, choose Analyze > Clear Results on the ImageJ 
menu bar or Edit > Clear Results on the Results window menu bar.

Summarizing measurements
To calculate basic statistics (mean, standard deviation, minimum, and 
maximum) for each measurement fi eld, choose Analyze > Summarize or Edit 
> Summarize in the Results window menu bar.

Measuring
ImageJ
Skill

Changing Results
column widths
If the columns of numbers in the 
Results window overlap or are 
diffi  cult to read, resize the columns 
by dragging the line separating 
column headings.

Measurement summaries 
appear at the bottom of 

the Results window.

Measurement summaries 

Measurement optionsMeasurement options
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Measuring angles
Use the angle tool  to measure angles with three clicks as shown  to measure angles with three clicks as shown 
below. After the second click, the interior angle formed by the two rays is 
displayed in the ImageJ status bar as you move the cursor.

To record angle measurements, choose Analyze > Measure, or press M. 
When measuring with the angle tool, the angle measurement option is 
automatically enabled.

Redirecting measurements
There are times when it is necessary to 
use the features of one image to select 
areas to measure in another image.

The image at right shows elevation data 
for the area around Mt. Denali, Alaska. 
The lower image shows vegetation in the 
same area. To measure the vegetation 
within a specifi c elevation range:

 • Open the source image, and select 
the region you want to measure.

 • Open the target image containing target image containing target
the data you want to measure.

 • Choose Analyze > Set 
Measurements… and set Redirect 
To: to the target image.

 • With the source image active, 
press the M key to measure. The 
measurements will be made using 
the pixel values of the target image.

This technique is also used for measuring 
changes in images created at different 
times, or images that have to be highly 
processed to see the features you want to 
measure, where the processing changes 
the original pixel values.

Click 3 Click 2

Click 1

Measurement options
Area  - Area in pixels, if uncalibrated, 

square units if calibrated.

Mean Gray Value - Average gray value 
within the selection.

Standard Deviation - Standard 
deviation of the values used to 
generate the mean gray value.

Modal Gray Value - Most frequently 
occurring gray value within the 
selection.

Min & Max Gray Level - Minimum and 
maximum gray values within the 
selection.

Centroid - The center point of the 
selection. This is the average of the x 
and y coordinates of all of the pixels 
in the selection.

Center of Mass - The brightness-
weighted average of the x and 
y coordinates of all pixels in the 
selection.

Perimeter - The length of the outside 
boundary of the selection.

Bounding Rectangle - Defi nes the 
smallest rectangle enclosing the 
selection.

Fit Ellipse - Fits an ellipse to the 
selection.

Circularity - A value of 1.0 indicates a 
perfect circle.

Feret’s Diameter - The longest distance 
between any two points along the 
selection boundary.

Integrated Density - Sum of pixel values 
in selection (number of pixels x 
mean pixel value).

Median - The “middle” value of the 
distribution.

Skewness - Statistical measure of the 
symmetry of the distribution.

Kurtosis - Statistical measure of the 
“sharpness” or “fl atness” of the 
distribution.

Limit to Threshold - Only thresholded 
pixels are included in measurement 
calculations.

Display Label - Lists the image name 
and slice number (for stacks) in the 
fi rst column of the results table.

Invert Y Coordinates - If checked, the 
XY origin is assumed to be the lower 
left corner of the image window 
instead of the upper left corner.

Redirect To - Allows you to outline a 
structure on one image and measure 
the corresponding region in another 
image.

Decimal Places - This is the number of 
digits to the right of the decimal 
point in real numbers displayed in 
the results table.
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Stacks & Animation
ImageJ
Skill

What is a stack?
A stack is a series of two or more images in a single window. These images, 
called slices, can represent motion, time, space, or wavelength. Slices can 
be displayed in sequence either manually or automatically, and can be 
used to create two- and three-dimensional views of a scene or object. The 
features of a stack window are shown below.

Moving through a stack
 • Manually—Use the  • Manually—Use the  • Manually > and < keys or the scroll bar (slice slider) to move 

forward and back ward through the slices in a stack. (Hold the > and <
keys down to move quickly through many slices.)

 • Animation—Choose Image > Stacks > Animate or press the backslash 
(\) key to start and stop the animation. (You can also click on the image 
to stop the animation.)

Making a stack
To make a stack, all images must be the same type and have the same 
dimensions (height, width, and bit depth).

From a series of open images—Choose Image > Stacks > Convert Images 
to Stack. The new stack window is named Stack. (The original image names 
are shown to the right of the slice counter, but are lost when you save the 
stack.)

From a series of saved fi les—Choose File > Import > Image Sequence,
and specify the sequence options for the slices you want to import.

Order of slices
When you make a stack, the slices are arranged in the order in which they 
were created or opened, which is shown at the bottom of the Win dows
menu. When you import an image sequence, images are opened in import an image sequence, images are opened in import
alphanumeric order by image name.

Setting the animation 
speed and direction
Choose Image > Stacks > 
Animation Options…, and enter 
the desired speed in frames per 
second (0.5 = one frame every two 
seconds).

Normally, the animation plays in 
1-2-3-1-2-3 order. By checking the 
Loop Back and Forth option, the 
animation will play in 1-2-3-2-1 
order.

Slice sliderSlice slider

Slice Counter
(current/total)

Image TypeImage Type

Memory

Image SizeImage Size The slice counter
The stack window status bar shows 
the cur rent slice num ber and the 
total number of slices.

Sequence options
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Unstacking a stack
To separate a stack into separate windows, choose Image > Stacks > 
Convert Stack to Images. The windows are numbered 001, 002, 003, etc.

Editing a stack
To add a slice after the current sliceafter the current sliceafter —choose Image > Stacks > Add 
Slice.

To add a slice before the current slice—hold down the Alt (Win) or Alt (Win) or Alt
Option (Mac) key, then choose Image > Stacks > Add Slice.

To delete a slice—choose Image > Stacks > Delete Slice.

Creating a montage
Since a stack cannot be printed for a report or poster, ImageJ provides a 
way to arrange the slices of a stack in rows and columns as a single image 
called a montage.

To make a montage, choose Image > Stacks > Montage…, specify the 
number of rows and columns, and click OK.

Converting a stack to an .avi movie
To convert a stack into an .avi movie that can be played on many freeware 
movie player applications such as QuickTime Player, choose File > Save 
As... > AVI… and save the fi le. Optional plugins are available from the 
ImageJ download site that may allow users to save stacks in other movie 
formats.

Montage options
In addition to the number of rows 
and columns, you can resize the 
images, include every Nth image, 
and other options.

Processing stacks
When you conduct processing 
operations on a stack, you are given 
the option to process the current 
slice only (No), all slices (Yes), or 
cancel the process.
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Managing Windows
ImageJ
Skill

Parts of a window

To activate a window
Click on part of the window, or choose the window you want from the 
Window menu. The active window has a shaded title bar or lines along it.

To move a window
Drag the window by its title bar to a new lo ca tion.

To show the ImageJ window
If the ImageJ window is hidden, press the Enter key (Return on Macs) to 
move it to the front.

To put an image window behind other windows
Sometimes, one image completely covers another. To move an image 
behind other images, choose Window > Put Behind. 

Organizing windows
The Window menu provides several ways to organize image windows on 
the screen.

 1. Cascade—Piles and fans out the windows, in order, so that you can 
see the title bars.

 2. Tile—Lays out the image win dows on the screen so they do not 
overlap.

Image Type
Image Memory

Image Size

Image NameImage Name
File Extension

Title Bar

Minimize
Maximize
CloseClose

To resize, drag corner To resize, drag corner 
or edge of window
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Lesson Introduction
What is image processing technology?
Image processing technology allows users to gather and analyze an 
incredible amount and range of information from digital images. Digital 
images are composed of rows and columns of picture elements or pixels, 
each representing a num ber. Like a paint-by-number picture, each number 
corresponds to a specifi c color or shade of gray. Digital images contain 
information that may not be visible at fi rst. Image processing can help you 
“see” this information.

The lessons in this guide will teach you how to use image processing tools 
to view, analyze, and evaluate images for various purposes. For example, 
you may be asked to do forensic detective work on images of fi ngerprints 
or plan a cross-country rock-and-roll tour by measuring distances on 
a satellite image. Once you’ve mastered some of these tech niques, the 
possibilities are endless. You can even tu al ly capture and analyze your own 
images. Image pro cess ing allows you to use your math and science skills, 
as well as your creativity, so have fun and enjoy!

Lesson Descriptions
Pixelated Pictures  .................................................... 43

  Use a “stadium picture” to discover what a digital image is and 
how it can be manipulated. Explore different uses of digital 
images in fi elds ranging from medicine to art to geography.

Lights, Camera, Action!   ......................................... 55
  Learn how to create and manipulate image stacks. Make your own 

animated cartoon, track a hurricane, see a lightning strike in slow 
motion, and slice a brain to see inside it.

Digital Detective  ...................................................... 67
  Process low-contrast images to reveal the picture of a suspected 

drug dealer, compare fi ngerprints from a crime scene with those of 
the suspects, and look for evidence of a forger using a new alias.

More Than Numbers  ............................................... 83
  Construct two- and three-dimensional graphs to help you “see” 

the numbers in digital maps, photographs, and other images.

North American Tour  .............................................. 99
  Plan your band’s cross-country concert tour using image 

processing! Locate cities and other features on a satellite image and 
measure distances as you search for the most cost-effective route.

image, n. An optically formed 
representation of an object.

process, v. In computer science, to 
perform operations on data.

technology, n. The application of 
scientifi c knowledge, especially in 
industry or business.
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Digitizing Details  ................................................... 107
  Learn about image resolution, bit depth, and fi le formats, and 

how to use them to get the best possible images for a variety of 
situations and uses.

Picture Yourself  ..................................................... 125
  Have you ever dreamed of yourself as president or a famous 

sports or entertainment fi gure? Ever wanted to see your face on 
a $100 bill? Using digital images, measurement, scaling, copying 
and pasting, you can picture yourself doing what you’ve always 
dreamed of!

Color by Number  ................................................... 133
  Take color images apart and put them back together to learn 

the principles of color imaging. Make both true- and false-color 
satellite images, and use color to create cool “three-dimensional” 
images!

Photo Effects  .......................................................... 149
  Edit and enhance images to create zany, as well as useful, 

photographic effects. Put yourself on the moon, become fi sh bait, 
turn into an animal, design an ad for a product, or bring an old 
photo back to life!

Images for Science  ................................................ 167
  Download a set of raw images from the Internet (alternative 

images are provided if Internet access is unavailable) and prepare 
them for scientifi c analysis and display.
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Pixelated Pictures
Understanding Digital Images

Overview
Digital image processing is used by professionals in many fi elds, from 
bio med i cal imaging to graphic arts. This lesson introduces students to 
digital images and a few basic image processing techniques.

In Part 1, students ex am in e the pixels (picture elements) that make up 
digital images. They are introduced to the concept of a digital image as 
a series of numbers that are displayed according to a color lookup table. 
With image processing tech nol o gy, students can change the appearance 
of images for aesthetic or scientifi c purposes by changing the numerical 
values of pixels using drawing tools, mathematical operations, or by 
modifying the lookup table.

In Part 2 of the lesson, students compare digital images to the large 
pictures formed by sports fans holding up colored cards in a stadium. 
By de vel op ing this analogy, students better un der stand how digital 
in for ma tion is displayed and ma nip u lat ed. The X,Y co or di nates used as 
pixel “ad dress es” in a digital image are shown to be analogous to seat and 
row num bers in a stadium. Students also compare this coordinate system 
to the Cartesian coordinate system used for drawing mathematical graphs. 
Students explore the relationship be tween pixel values and the lookup table 
by changing color tables and reading pixel values. They use the stadium 
picture analogy to build an understanding of image histograms and the use 
of thresholding to highlight specifi c ranges of pixel values.

In the fi nal section, students explore images that demonstrate how image 
pro cess ing is used in the workplace. Students are in tro duced to a few 
simple imaging tech niques as they interact with the images.

Goal
Students use the tools of ImageJ
to discover the characteristics of 
digital images and explore how 
they are used.

IP Skills
 • Changing image modes

 • Changing color tables

 • Interpreting histograms

ImageJ Skill Sheets
 • Lookup Tables

 • Thresholding

 • Managing Windows

Vocabulary
 • pixel

 • digital image

 • image processing

 • lookup table

Teaching
NotesNotes
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Objectives
Students will:

 • explain the key properties of pixels, their coordinates, and their values;

 • explain relationships between pixel values, lookup tables, and images;

 • use lookup table manipulation and fi ltering to process digital images, 
and

 • discover how digital images are used in a different careers.

Related Activities
 • See “Digital Detective” for an introduction to image processing in the 

fi eld of  fo ren sics.

Career Links
Many government and public agencies use digital images to archive 
in for ma tion. For example, space agencies, weather service bureaus, and 
hospitals either create digital images or scan images and doc u ments for 
storage onto CD-ROM, DVD, and other media. Image pro cess ing is also 
common in fi elds such as graphic arts and city planning.

Important Setup Note
The “normal” origin (0,0) for ImageJ is in the upper left corner of the image, 
with Y values increasing toward the bottom. Before your students do 
this lesson, you should modify this behavior so that ImageJ matches the 
familiar graphing space of Quadrant I of the Cartesian coordinate system.

 • Choose Analyze > Set Measurements.

 • Turn on (check) the Invert Y Coordinates option.

This will move the origin (0,0) to the lower left corner. This setting is saved 
with other ImageJ preferences, and will remain in effect until it is turned 
off. (It is not saved with the image.)

Acknowledgments
Lesson developed by Carla McAuliffe and LuAnn Dahlman, Center for 
Image Pro cess ing in Education, Tucson, Arizona. Updated for use with 
ImageJ by Larry Kendall.

Parts of this lesson are based on the lesson “Stadium Pictures,” developed 
by LuAnn Dahlman and Larry Kendall, Image Processing for Teaching 
project, Uni ver si ty of Ar i zo na, Tucson, Arizona.

Slice one of Stadium Picture © Herb Weitman/NFL Photos, slice two 
of Stadium Picture © Baron Wolman/NFL Photos, and slice three of 
Stadium Picture © Paul Spinelli/NFL Photos. Used with permission.

House Drawing is courtesy of Patti Parsons, Phoenix, Arizona. Winter 
and First Eagle are courtesy of Nelson Begay, Tuba City, Arizona.

Other images courtesy of the National Institutes of Health, National 
Aeronautics and Space Administration (NASA), and the authors.

Inverting Y Coordinates
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Answers
 1. Small squares or pixels are visible.

 2. Numbers in the status bar (the X and Y coordinates and the pixel value) 
change as the cursor is moved.

 3. Answers will vary. Dragging the sliders to the right:

  Minimum—increases contrast and decreases brightness; pixels 
with lower values are rendered lighter.

  Maximum—increases contrast and brightness; pixels with lower 
values are rendered lighter.

  Brightness—increases brightness.

  Contrast—increases contrast.

 4. If fans traded cards randomly, they would not form a recognizable or 
meaningful picture.

 5. The value reported for X changes one unit for every one pixel moved 
in the horizontal direction. 

 6. The value of Y shows a pixel’s vertical, or up-and-down location.

 7. Answers will vary. X is equivalent to the seat number, and Y is 
equivalent to the row number in a stadium.

 8. The X,Y coordinate system of this digital image is the same as 
mathematical graphs, X increases to the right and Y increases toward 
the top.

 9. The origin (0,0) is in the lower left corner of the image.

 10. To fi nd the total number of pixels, go to the upper right (don’t forget 
to add 1 to the X and Y coordinates, since the row and seat numbers 
begin with zero). Multiply the number of rows (Y) by the number of 
seats or columns (X).

 11. 415 × 640 = 265,600 total pixels.

 12. Answers will vary. The values range from 0 to 255.

 13. Answers will vary. Complete answers will show numbers for X, Y, and 
Value.

 14. No. The test pixel’s value does not change when a new lookup table is 
used.

 15. The pixel value does not change. Changing lookup tables only changes 
the color assigned to each value, not the pixel values.

 16. The lookup table determines the colors currently assigned to each of 
the 256 possible pixel values in the image. Each pixel in the image is 
shown as the color or shade of gray assigned to it in the lookup table. 
Changing the color assignments by applying a new color (i.e. lookup) 
table can dramatically change the appearance of the image, although 
the pixel values are not changed.

 17. Answers will vary since changing one value changes the other. Setting 
the Level to around 900 and the Window to 1700 looks pretty good.

 18. The pixel value of 40 appears most frequently in the Mona Lisa image.

Note: questions 8 and 9 assume 
that you have set the origin (0,0) of 
the images from the default position 
in the upper-left corner to the lower-
left corner of the image window. 
See the Troubleshooting section 
of this lesson for instructions on 
changing the location of the origin.
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 19. Pixels with a value of 227 are mostly located in Mona Lisa’s face and 
neck.

 20. The noisy pixels disappeared. This makes the actual surface features 
easier to see. You may notice that remaining objects in the image are 
more blurry or less sharp. 
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What is a digital image?
 Open X-ray.tif.X-ray.tif.X-ray.tif

You are looking at an X-ray image of major arteries in the neck and chest. 
The patient is facing you, although his head is turned to the side. Notice 
how the fi llings in the patient’s teeth are visible. The large loop at the 
bottom of the image is the aorta. When pictures like this are displayed on 
a computer screen, they are digital images. But, what exactly are digital 
images? How are they used, and what char ac ter is tics do they possess?

 Use the Magnifying Glass tool   to click on the image four or fi ve  to click on the image four or fi ve 
times to zoom in. (You can click  

 to click on the image four or fi ve  to click on the image four or fi ve 
  while holding down   while holding down Control

[Win] or Option [Mac] to restore the image.)

 1. What do you see?

The small squares that make up a digital image are called picture el e ments 
or pixels.

 Watch the status bar as you move the  tool across the pixels. tool across the pixels.

 2. What do you notice about the status bar? (Be specifi c!)

You should see numbers changing. The pixels in a digital image represent a 
grid or table of numerical values. Each pixel value is a single measurement 
recorded at a specifi c time and place. By assigning a specifi c color to each 
different pixel value, a picture or digital image is formed. An X-ray is an 
image made up of X-ray “brightness” mea sure ments. Where the X-rays are 
blocked, by bone for example, the brightness is low. Where the X-rays pass 
through, in substances such as air or soft tissue, the brightness is high. 
Scan ners and digital cameras collect these bright ness mea sure ments and 
display them as digital images.

With image pro cess ing technology you can analyze and change fea tures of 
pixels such as their brightness, contrast, or numerical value.

 Choose Image > Adjust > Brightness/Contrast to open the B&C
(Brightness & Contrast) window. Adjust each of the four slider 
controls, and watch how each slider affects the image appearance.

 3. Describe what happens to the appearance of the image when you 
move each of the four sliders in the B&C window.

You should have noticed that changing the brightness and contrast 
changes the appearance of different features in the image. Changing the 
appearance of an image to make features easier to see is called image 
enhancement. Another simple way to enhance images is to change the 
colors used to display the pixel values.

 Choose Image > Lookup Tables > Spectrum, and observe the details 
now visible in the image. (Feel free to “try on” some of the other 
color tables.)

 Close X-ray.tif and the X-ray.tif and the X-ray.tif B&C window.

Pixelated Pictures
Understanding Digital Images

Gray is a color too!
Most people don’t think of black, 
white, and gray as colors, but we’ll 
call them colors and we encourage 
you to do it too!

File > Open

Enhancing science
Image enhancement is a powerful 
tool. For example, being able to 
better see the details of a person’s 
heart and vessels can help a doctor 
to make a more accurate diagnosis.

File > Close

Student
Guide
Student
Guide



48 Discovering Image Processing
©2006 The Center for Image Processing in Education and 

portions ©1998 Arizona Board of Regents.
Limited classroom reproduction rights are granted earlier in this work.

Big pictures from little squares      
 Open Stadium Picture.tif. This image is really three images, Stadium Picture.tif. This image is really three images, Stadium Picture.tif

each in a separate layer, or slice.

 Press the > and < keys to move through the slices of Stadium 
Picture.tif. Or use the arrows on the slider bar at the base of the Picture.tif. Or use the arrows on the slider bar at the base of the Picture.tif
image.

Have you ever seen fans in a stadium form a big picture as part of a 
halftime show? Each seat in the “card section” is assigned one or more 
large cards, each a solid color. On command, each fan holds up the 
appropriate card. Viewed from across the fi eld or from high above the 
stadium, the individual cards blend together to form a large picture.

Close up, all you can see are the individual colored cards. The pixels in a 
digital image are similar to the cards held by each fan.

 4. How would the stadium picture look if the fans ran dom ly traded cards 
with each other?

The location of each colored card is extremely important for displaying the 
picture. Stadium sections have “addresses” for every seat—locations are 
given by seat and row numbers. Digital images have a similar system for 
describing the location of each pixel.

 Close Stadium Picture.tif.Stadium Picture.tif.Stadium Picture.tif

Discovering pixel “addresses”
 Open Mona Lisa.tif.Mona Lisa.tif.Mona Lisa.tif

 Click , then click the image several times until you can see , then click the image several times until you can see 
individual pixels.

 Move your cursor hor i zon tal ly across a row of pixels, and watch 
the changes in the status bar.

 5. Which number in the status bar changes one unit for every one pixel 
you move in the horizontal direction?

 Move the cursor ver ti cal ly (up or down) in a column of pixels, and 
again watch the changes in the status bar.

 6. Which item in the status bar shows a pixel’s vertical location?

 7. Describe how seat and row numbers in a stadium compare to the 
co or di nate system used to locate specifi c pixels in a digital image.

 8. How is the X,Y coordinate system in this digital image similar to 
math e mat i cal graphs you have used?

 Double-click  to view the entire image again.  to view the entire image again. 

 Based on what you observed, move your cursor to the origin of 
the image (the pixel with the lowest X,Y coordinates).

 9. Where is the origin (row 0, seat 0) of the image?

 10. How could you fi nd out the total number of pixels in this image?

 11. How many pixels are in this image?

Image width and height
Remember that in ImageJ, the “row” 
and “seat” numbers start with 0,0 
not 1,1. That means that you have 
to add 1 to the maximum X and Y 
coordinates to get the width and 
height of the image.

Mona Lisa’s pixel 
locations 
The Mona Lisa image is moderately 
large and is not displayed at full size 
by ImageJ. As a result, pixel locations 
will not change uniformly as you 
move the cursor over the image. 

To display it at full size, select Edit 
> Options > Image . . . and click 
Open Images at 100%. Then 
reopen Mona Lisa.tif.  

Make sure you reset this option 
when you have fi nished this part of 
the lesson (click Open Images at 
100%). 
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The value of a pixel
Besides the specifi c address given by X and Y coordinates, each pixel in a 
digital image has another number associated with it.

 Use the  tool to zoom in several times until you can see  tool to zoom in several times until you can see 
individual pixels.

 Place your cursor on the lightest pixel in your fi eld of view and 
read its Value in the status bar. Do the same for the darkest pixel 
you see.

 12. What are the highest and lowest pixel values you can fi nd in this image?

Assigning colors to values
In a stadium picture, each fan is given a card with a specifi c color.  
Likewise, in a digital image each pixel value is represented by a specifi c 
color. In digital images, a color is assigned to every pixel value using a 
lookup table. A simple lookup table for an image with up to 16 different 
values is shown at the right.

ImageJ uses 8-bit lookup tables containing 28, or 256, different colors. 
Normally, pixels with a value of 0 are shown as white and pixels with a 
value of 255 are shown as black. (If that seems backward to you, ImageJ 
can also be set to assign 0 to black and 255 to white—both ways are 
“correct.”) Two hundred fi fty-four colors or shades of gray are used to show 
the values be tween white and black.

 13. Zoom in on any pixel in your image. Write down its location and value.

 Choose Image > Lookup Tables, and pick a new lookup table from 
the available choices. The new lookup table assigns new colors to 
each pixel value.

 Move your cursor back to your test pixel from question 13.

 14. Has the pixel value changed?

 Try other lookup tables, and check the value of your test pixel.

 15. What happens to the pixel values when you apply a new lookup table 
to an image?

 16. Describe how the lookup table affects the appearance of a digital image.

 Change the lookup table back to grayscale when you are fi nished 
by choosing File > Revert.

Bit depth
The number of possible pixel values in an image is often called the bit depth
of the image. Bit depth is determined by the number of binary digits, or 
bits, that are used to represent the value of each pixel. ImageJ can work 
with 8-, 16-, and 32-bit images. The table below shows the number of 
different values that are possible at each bit depth.

Bit Depth Possible Pixel Values
8-bit 28 = 2568 = 2568

16-bit 216 = 65,53616 = 65,53616

32-bit 232 = 4,294,967,29632 = 4,294,967,29632

15
14
13
12
11
10

9
8
7
6
5
4
3
2
1
0

A 4-bit lookup table
A 4-bit lookup table has 24 or 16 
diff erent colors or shades of gray.
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More practice
If you want to practice working with 
more 16- and 32-bit images, you will 
fi nd them in the 16-bit Images and 
32-bit Images folders.

Mona a la mode
Another name for the most 
frequently used value is the Mode.

32-bit fl oating point
The 32-bit image format used by 
ImageJ represents values using 
32-bit fl oating point notation. This 
allows pixels to represent values 
containing a decimal point.  It 
is especially useful for scientifi c 
imaging, because each pixel value 
can be an actual measurement 
value, such as 31.625 W/m2. (The 
units, of course, are not stored with 
the pixel value.) These “32-bit fl oat” 
values can represent numbers 
ranging from about 1.7 x 1038 to 
5.9 x 10-39. The possibilities are nearly 
endless!

0 255

Sorting the cards

Wow! A pixel in a 32-bit image can represent any one of more than 4 billion 
possible values! Unfortunately, ImageJ uses lookup tables with only 256 
colors. When displaying 16- and 32-bit images, ImageJ divides the range of 
possible pixel values into 256 groups, called bins, and assigns a single color 
to all of the pixels in each bin. That means that in a 16-bit image, a single 
color can represent a range of up to 256 different pixel values, and in 32-bit 
images, each color of the lookup table can represent nearly 16.8 million 
different values! The trick to working with 16- and 32-bit images is learning 
how to assign the 256 available colors to the range of pixel values you’re 
most interested in. This process is called windowing.

 Open the Galaxy.tif image. (Do not close Galaxy.tif image. (Do not close Galaxy.tif Mona Lisa.tif.)Mona Lisa.tif.)Mona Lisa.tif

This is a 16-bit image of the Andromeda Galaxy taken with a digital 
camera mounted on a telescope on Kitt Peak in Arizona. The image doesn’t 
contain a full 65,000 different pixel values, but it does use far more than 256 
different values to record faint details of the galaxy. At fi rst, it doesn’t look 
like much, but looks can be deceiving.

   Choose Image > Lookup Tables > Fire.

Our eyes are more sensitive to different colors, so you should see a little 
more detail in the image using the Fire lookup table.

   Choose Image > Adjust > Window/Level.

The Window/Level (W&L) panel contains two sliders. One controls the 
window width—the range of pixel values in the image that the lookup table 
is applied to. Pixel values above this range are displayed as black, and 
values below it are displayed as white. The other slider controls the Level—
the pixel value where the window (and the lookup table) is centered. These 
adjustments will make more sense after you experiment with them a bit.

 Adjust the Window and Level controls in the W&L panel until 
you think the maximum detail is visible in the image.

 17. What Window and Level settings produce the best range of detail in 
the image?

 Close the Galaxy.tif image and the Galaxy.tif image and the Galaxy.tif W&L window.

Back to the stadium
Imagine that you want to create the Mona Lisa as a stadium picture. To 
produce the individual cards to give to the fans, you will need to know how 
many cards of each shade to paint.

 Choose Analyze > Histogram to see a histogram of the pixels used 
to create Mona Lisa.

Think of a histogram as a way of organizing your stadium cards. If you sort 
them by pixel value along a number line from 0 to 255, the resulting piles 
of cards would resemble a histogram. The most-used colors (values) would 
have the highest piles while the least-used colors would have smaller piles. 
The piles show the amount (the number of cards) of each color (value) 
needed to produce the picture.

 18. What is the most frequently used pixel value (color) in Mona Lisa?

 Close the Histogram window.
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MRI = NMR
Magnetic resonance imaging is 
sometimes called nuclear magnetic 
resonance imaging (NMR) because 
it measures the response of atomic 
nuclei to strong magnetic fi elds.

Essentially, MRI maps the locations 
of diff erent kinds of atoms along a 
plane or slice of an object, usually 
some part of a person’s body.

Thresholding
The Threshold dialog box lets 
you choose from three diff erent 
methods of highlighting a range of 
pixel values.

Highlighting pixels in the image
Sometimes it is useful to identify the pixels in an image whose values are 
within a certain range. For example, let’s pretend for a moment that the 
pixel values in Mona Lisa represent temperature instead of brightness. As 
part of a diagnostic procedure or research study, you might want to know 
which parts of the image are between 30oC and 45oC.

If the back of each “card” used to create the image was colored bright red, 
you could highlight where specifi c pixel values occur in the image. Imagine 
fl ashing this message on the scoreboard while the card section is showing 
the Mona Lisa image:

You can do something similar in ImageJ. It is a process called Thresholding.

 Choose Image > Adjust > Threshold to turn on Thresholding mode.

In Thresholding mode, the pixels whose values are within a range of values 
are highlighted.

 Highlight all of the pixels with values be tween 30 and 45 by 
adjusting the Threshold range using the two slider controls in the 
Threshold panel.

 You can also set the upper and lower Threshold limits precisely by 
clicking the Set button and entering exact values. Use this method 
to set the Threshold range to 49–73.

 With Thresholding on, create a new histogram to see which pixels 
are within the Threshold limits.

You can highlight a single pixel value by setting the upper and lower limits 
of the Threshold to the same value.

 Set the Threshold to highlight pixels with a value of 227 in the 
Mona Lisa image.

 19. Where in the image are most of the pixels with a value of 227 located?

 Close Mona Lisa.tif and the Mona Lisa.tif and the Mona Lisa.tif Threshold window.

Careers using digital images
Many careers use digital images. Government and public agencies as well 
as private businesses use digital images to display, interpret, and archive 
in for ma tion. For example, space agencies, weather bureaus, and hospitals 
make digital images or scan images and doc u ments for storage onto CD-
ROMs and other media. Today, image processing is used in a variety of fi elds 
ranging from graphic arts to medical tech nol o gy to city planning. In this 
section, you will explore a few workplace applications of digital imaging.

 Open Medical Image.tif.Medical Image.tif.Medical Image.tif

This is a mag net ic res o nance image (MRI) of a patient’s head. In the fi eld 
of medicine, image processing techniques can allow a doctor to visualize 
anatomy without surgery. Health-care technicians use a wide variety of 
spe cial ized equip ment for collecting images like this.
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Filtering noise, Part II
Another way to fi lter noise is to 
choose Process > Filters >
Median.  Try this method on 
another part of the Mercury image, 
and compare the results to the fi rst 
method you used. Experiment with 
the Median fi lter’s radius setting to 
fi nd the radius that gives the best 
results. 

Sinuses?
The sinuses are the large, air-fi lled 
cavities between the forehead, eyes, 
nose, and the brain. The air outside 
the patient is black, so black areas 
inside the head are likely fi lled with 
air.

On your own
 • Look at a newspaper photo with 

a magnifying glass. Describe 
how the picture is similar to and 
diff erent from a digital image.

 • Design and create your own 
stadium picture. Use a piece 
of graph paper to create your 
design.

 • Visit some one in a career that 
uses digital images. Describe 
how they use digital images in 
their job.

Since an MRI is in a digital format, tech ni cians can easily isolate and select 
specifi c struc tures and types of tissue for further analysis. In this image, the 
dark areas behind the eyes and nose are the sinus cavities. A doctor may 
want to study these to identify or diagnose breathing disorders.    

 Turn on Thresholding, and adjust the range to highlight the 
sinuses.

 Close Medical Image.tif and the Medical Image.tif and the Medical Image.tif Threshold window.

When an image is in a digital format, technicians can easily isolate and 
enhance particular portions of the image, whether it’s the image of a heart 
or the surface of another planet.

 Open Mercury Surface.tif.Mercury Surface.tif.Mercury Surface.tif

In 1974-75, the Mariner 10 spacecraft made three passes by the planet 
Mer cu ry. This image of Mercury’s surface is one of the photos taken by 
Mariner 10. In ter fer ence from radio waves and the sun produced static, or 
noise, that gives the image a salt-and-pepper appearance. Noise like this 
can be removed by pro cess ing the image with a digital fi lter that identifi es 
and replaces the noisy pixels with new, more realistic values. Planetary 
geologists and as tron o mers fre quent ly use such fi l ter ing tech niques to 
en able them to more clearly see features they might not otherwise notice or 
be able to detect.

 Use the Rectangular selection tool  to select part of the image. to select part of the image.

 Choose Process > Noise > Despeckle to pro cess the image.

 20. What happened to the part of the image inside the area you selected?

 Close Mercury Surface.tif.    Mercury Surface.tif.    Mercury Surface.tif

 Open Math Image.tif.Math Image.tif.Math Image.tif

Any grid of num bers can be displayed as a digital image. This image was 
created using a spreadsheet program and shows the equations xy = 1 and 
xy = -1. Some math e mat i cal functions show intricate and attractive patterns 
when displayed as digital images. Artists, scientists, and engineers create 
interesting and beautiful images using math e mat i cal func tions to generate 
pixel values. The colors in the image depend on the lookup table used.

 Apply various lookup tables to the image, and observe how its 
appearance changes.    

 Close Math Image.tif.Math Image.tif.Math Image.tif

 Open Painting.tif.Painting.tif.Painting.tif

This image is a drawing created by artist Patti Parsons. She selectively 
changed pixel values from white to a new color using the selection tools 
as drawing tools. Patti uses the computer as a sketchbook to try out 
different color combinations before painting her works on canvas. Graphic 
artists rely heavily on digital imagery to create print and electronic art, 
ad ver tise ments, and video special effects.

 Close Painting.tif.Painting.tif.Painting.tif
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Data
Sheet

Pixelated Pictures

Name(s)   ______________________________ Class  _________   Date  __________________

 1. What do you see?

 2. What do you notice about the status bar? (Be specifi c!)

 3. Describe what happens to the image when you move each of the four sliders in the B&C Window.

 a. Minimum

 b. Maximum

 c. Brightness

 d. Contrast

 4. How would the stadium picture look if the fans ran dom ly traded cards with each other?

 5. Which number in the status bar changes one unit for every one pixel you move in the horizontal 
direction?

 6. Which item in the status bar shows a pixel’s vertical location?

 7. Describe how seat and row numbers in a stadium compare to the co or di nate system used to locate 
specifi c pixels in a digital image.

 8. How is the X,Y coordinate system in this digital image similar to math e mat i cal graphs you have used?

 9. Where is the origin (row 0, seat 0) of the digital image?
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 10. How could you fi nd out the total number of pixels in this image?

 11. How many pixels are in this image?

 12. What are the highest and lowest pixel values you can fi nd in this image?

 a. highest = _____

 b. lowest = _____

 13. Zoom in on any pixel in your image. Write down its location and value.

 a. location:  X = _____, Y = _____

 b. value = _____

 14. Has the pixel value changed?

 15. What happens to the pixel values when you apply a new lookup table to an image?

 16. Describe how the lookup table affects the appearance of a digital image.

 17. What Window and Level settings produce the best range of detail in the image?

 a. Window = _____

 b. Level = _____

 18. What is the most frequently used pixel value (color) in Mona Lisa?

 19. Where in the image are most of the pixels with a value of 227 located?

 20. What happened to the part of the image inside the area you selected?
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Lights, Camera, Action!
Creating and using image stacks

Teaching
Notes

Goal
Students create digital an i ma tions, 
analyze motion, and vi su al ize 
three-di men sion al data.

IP Skills
  • Animation

  • Editing stacks

 • Creating stacks

 • Reslicing and projecting stacks

ImageJ Skill Sheets
 • Stacks & Animation

 • Cutting & Pasting

 • Stacks

 • Drawing & Text

 • Managing Windows

Overview
From special effects in movies to weather fore cast ing to interpreting 
structures within the brain, digital animation is a technique used in a wide 
variety of fi elds. Graphic artists, meteorologists, sports physiologists, and 
biomedical engineers all use animation in some facet of their work. In this 
lesson, students learn to create animations using image stacks. They begin 
by exploring and interacting with a ready-made cartoon animation. They 
unstack and edit the animation to learn the basics of working with stacks. 
Next, students construct their own animation.

In the second half of the lesson, students discover that animation provides 
a means for analyzing motion and visualizing three-dimensional structures. 
They observe how a hurricane travels and how lightning strikes as they 
use animation to speed up and slow down processes. Last, they reslice and 
project magnetic resonance images (MRIs) of the brain to reveal anatomical 
structures. More advanced stack techniques can be found in the On your 
own section at the end of the les son.

Objectives
Students will:

 • create and manipulate digital animations

 • use digital animation to analyze motion

 • visualize three-di men sion al stacked data

Related Activities
See the “Digitizing Details” lesson for information on how to capture and 
make movies using scanners and digital video and still cameras.

Career Links
Graphic arts, meteorology, sports physiology, medical imaging, anatomy, 
and bio me chan ics are some of the fi elds that employ digital animation.

Teaching
Notes
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Answers
 1. Answers will vary. The maximum animation speed depends on the 

computer. It may be 100 fps or more. The minimum speed is 0.1 fps 
(one frame every ten seconds).

 2. There are nine slices in Galloping Horse.tif.Galloping Horse.tif.Galloping Horse.tif

 3. Galloping Horse.tif is 292K.Galloping Horse.tif is 292K.Galloping Horse.tif

 4. Answers will vary. Nine individual images are listed in place of the one 
stack. The names of all of the open image windows and the memory 
occupied by each appear at the bottom of the Window menu. The 
active window is indicated with a checkmark.

 5. Each window is 32K, or roughly 1/9 the size of Galloping Horse.tif.Galloping Horse.tif.Galloping Horse.tif

 6. Added slices are inserted before the currently active slice.

 7. Only the About Andrew WV.tif image opens and a About Andrew WV.tif image opens and a About Andrew WV.tif Log window 
appears with the following messages:

 8. In order to calculate the speed, students would need to measure the 
distance the hurricane travels over a known time period.

 9. Answers will vary. Examples may include photo fi nishes of horse, car, 
and foot races or analysis of fi gure skating. 

 10. Answers will vary but may include features like the ventricles, sinuses, 
and cerebellum.
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Lights, Camera, Action!
Creating and using image stacks

Lesson

Have you ever wanted to make a movie? Well, here’s your chance! With 
your imagination and a little help from image processing technology you 
can easily create digital animations using stacks of images. You can even 
save them as QuickTime® and AVI movies for use with other applications.

At the movies
First, let’s observe a ready-made animation.

 Open Galloping Horse.tif.Galloping Horse.tif.Galloping Horse.tif

 Drag the scroll bar at the bottom of the stack window left and 
right to see the frames, or slices, of the stack.

This series of images was created in 1878 by Eadward Muybridge, an early 
pioneer in the use of photography to study animal locomotion.

 Press the backslash (\) key while holding down Control (Win) or 
Command (Macs) to start the animation. Click on the image to 
stop the animation, or use the \ key alone.\ key alone.\

 Experiment with changing the speed of the animation. To change 
the speed, choose Image > Stacks > Animation Options….

 1. What are the fastest and slowest animation speeds in frames per 
second?

What is a stack?
A set of images displayed within a single window is called a stack. A stack 
is similar to a pad of paper or a deck of cards, except that each “card” is a 
digital image. These images can show many things—a sequence of events, 
parts of a larger image, or slices through an object at different depths. In 
fact, ImageJ refers to the individual, “still” images within the stack as slices.

This lesson will focus on the use of stacks for animating a series of images. 
Perhaps you have created a simple fl ip-book animation using a stack of 
paper. When the images are shown quickly, the eye “sees” motion. This is 
the basic principle that is used for making movies. Films and videos are 
really just series of still pictures shown in a rapid sequence. By arranging a 
series of images in a stack and fl ipping through them, you can create your 
own animation.

 Use the > and < keys or the scroll bar to move forward and 
backward through the stack as you view the individual slices.

 Below the title bar of the Galloping Horse.tif window is a row of Galloping Horse.tif window is a row of Galloping Horse.tif
numbers. The fi rst number refers to the slice of the stack that you 
are currently viewing, and the second number refers to the total 
number of slices in the stack.

 2. How many slices are there in Galloping Horse.tif?Galloping Horse.tif?Galloping Horse.tif

File > Open…

Stack Window

Slice
Counter

Scroll BarScroll Bar

Dimensions

Memory Size
Bit Depth

Image > Stacks >
Animation Options…
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 The other numbers below the title bar refer to the image’s 
dimensions (width × height), bit depth (number of possible 
colors), and size (amount of computer memory the stack occupies). 
The size of each open image is also listed next to the image name 
in the bottom section of the Window menu.

 3. How large (in kilobytes, kb) is Galloping Horse.tif?Galloping Horse.tif?Galloping Horse.tif

Unstacking and restacking
The slices of a stack can be separated into individual windows using the 
Image > Stacks > Convert Stack to Images command. The images can be 
reassembled into a stack using the Image > Stacks > Convert Images to 
Stack command.

 Practice unstacking and restacking Galloping Horse.tif.Galloping Horse.tif.Galloping Horse.tif

 4. Look at the bottom of the Window menu when Galloping Horse.tif
is unstacked. How is it different from when the images are in a stack?

 5. How do the sizes of the individual images compare to the size of the 
stack?

 If necessary, reassemble the galloping horse images into a stack.

Editing a stack
 To draw on an image, select a line or region by using one of the 

selection tools ( , , , , , , , , , , , or , or  ). Hold down the  ). Hold down the F key 
(for “Fill”) while you drag the selection around on the image to use 
the selection as a paintbrush. Use this drawing technique to make 
changes to the images in the stack.

 Try inserting and deleting individual slices in the stack using 
Image > Stacks > Add Slice and Delete Slice. Experiment with 
holding down the Alt (Win) or Alt (Win) or Alt Control (Mac) key while inserting 
slices and notice where the slice is added.

 6. When you add a slice with the Alt or Alt or Alt Control key pressed, is the slice 
added before or after the current slice?

 Close Galloping Horse.tif.Galloping Horse.tif.Galloping Horse.tif

Make your own movie
Try creating your own animation.

 Choose File > New to create a new blank stack named My Movie. 
To make a convincing animation, you will probably need at least 
12 slices.

 On the fi rst slice, draw a simple scene. Be sure to include an object 
that you want to move in the animation.

 Use the > key to advance to the next slice, and draw the next frame 
of your animation. Use the scroll bar at the bottom of the stack 
window to move through the stack and test your animation. (See 
Drawing hints on the next page.)

Creating a new 
blank stack

Can’t see the image 
size?
If you can’t see the size of the image  
in the window, try stretching the 
window out a bit. 
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 Here are the basic techniques you will use:

To do this… …follow these procedures

Make a selection Use  , , , , , , , or , or   to select a region of interest.  to select a region of interest.

Copy a selection Choose Edit > Copy.

Paste a selection Choose Edit > Paste.

Draw or paint
on the image

Make a selection using any of the selection tools. Press 
the D key to draw an outline, F to fi ll the shape, or 
hold down F while dragging the selection to use the 
selection shape as a “paintbrush.”

Add text Use  to enter text, then choose  to enter text, then choose Edit > Draw.

Change the text 
or drawing color

Double-click  , and choose a new color from the  , and choose a new color from the 
palette.

 When you are fi nished with your animation, press \ (Control\  for 
Windows and Command \ for older Macs) to start the animation. Command \ for older Macs) to start the animation. Command \
If your movie runs too slow or too fast, choose Image > Stacks >
Animation Options to change the speed. (Movies and television 
both animate at a rate of around 30 frames per second.)

A stack is great for looking at a series of images one after the other. 
However, if you want to include the stacked images in a printed report, you 
need a different way to display them. A montage allows you to see all of a 
stack’s slices in a single image.

 Choose Image > Stacks > Make Montage to create a montage 
of your stacked animation. Experiment with the set tings in the 
montage dialog box until you are pleased with the results.

 If possible, print your montage.

 Save the montage and/or the stack if you like. Choose the AVI 
format to save your stack as a movie fi le that will play on most 
computers.

 Close all open images.

“Seeing” with animation
In addition to its use in the fi lm industry, digital animation is a valuable 
technique widely used in other fi elds. Processes that occur too quickly 
or too slowly for the eye to perceive can be “seen” using animation. 
Images captured over an extended period of time can be sped up to 
show changes taking place that might not otherwise be noticeable. For 
example, me te o rol o gists use an i ma tion to follow the move ment of clouds, 
hurricanes, and weather fronts.

Choose File > Import > Image Sequence. Navigate to the 
Hurricane Andrew folder, and open it. In the Open Image 
Sequence dialog box, select the fi rst fi le, named About Andrew 
WV.tif, and click Open.

 In the Sequence Options dialog box, accept the default settings, 
and click OK.

 7. Describe what happens.

 Close all open image windows and the Log window.

Drawing hints
You can either draw each frame 
of your animation from scratch, or 
modify a copy of the previous slice. 
To duplicate a slice:

 • Choose Edit > Selection > 
Select All.

 • Choose Edit > Copy.

 • Use the slider at the bottom of 
the stack window to advance 
to the next slice.

 • Choose Edit > Paste.
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You have just learned an important rule for stacking a set of images—all of 
the images must be the same size (width and height) in order to stack them.

 Choose File > Import > Image Sequence... again, and open 
Hurricane Andrew. This time, in the Sequence Options dialog 
box, enter 2 for the starting image. ImageJ will now skip over 
the fi rst image (the one that’s a different size than the others) and 
should create a stack from the remaining images in the folder.

In 1992, Hurricane Andrew swept through the Caribbean, Florida, 
and Louisiana in 72 hours. Using animation to track the movement of 
hurricanes like Andrew can help provide early warnings for people seeking 
safety during dangerous storms.

 Animate the hurricane stack.

 8. What measurements would you need to make to be able to calculate 
the speed of the hurricane?

 Close the hurricane stack.

In a similar manner, animation can be used to slow down events that 
happen too fast for us to see. Sports trainers often use an i ma tion to analyze 
motion such as the swing of a golfer or tennis player. Physicists study the 
paths of moving objects and the forces that cause them to move using 
animation. Bio me chan i cal en gi neers some times use an i ma tion to help them 
determine the points of greatest wear when designing running shoes.

 Import the sequence of images in the Lightning folder.

 Animate the images.

Carefully observe these images of lightning taken during a typical Arizona 
summer thunderstorm. This event lasted less than two seconds.

 Use the animation slider or set the animation speed to move slowly 
through the stack and observe the behavior of the lightning.

 9. Write down  another phenomenon that occurs too quickly to “see” 
with our eyes. Describe how imaging could be used to slow down the 
event so that it can be analyzed.

 Close the Lightning stack.

Animation makes it easier to observe, interpret, and predict patterns.

Using stacks to show three dimensions
In the fi eld of medicine, animation is often combined with other imaging 
techniques to provide noninvasive methods for visualizing anat o my.

 Import the sequence of Brain images in the Makes My Head 
Spin folder.

Magnetic Resonance Imaging (MRI) is a powerful way to examine the 
struc ture of a human body without cutting it open. This tool is es pe cial ly 
useful when ex am in ing delicate structures like the human brain. An MRI is 
made by placing a patient in a strong magnetic fi eld, exposing him or her to 
radio waves, and then recording and analyzing the way the patient’s atoms 
respond. Unlike x-rays, which reveal bone and other hard tissue, MRI excels 
at creating images of soft tissue. For example, a brain tumor that cannot be 
detected with an x-ray might be easily identifi ed in an MRI.

Wrong image
sequence?
When importing an image 
sequence, the images are added 
to the stack in alphabetical (or 
numerical) order.

If the images are not named in the 
order that they are to be animated, 
you will have to open them one 
at a time in the correct sequence, 
then choose Image > Stacks 
> Convert Images to Stack to 
create the animation stack.

Remember to close any windows 
that are not part of the animation 
before building the stack.

File > Import >
Image Sequence…

File > Import >
Image Sequence…

File > Import >
Image Sequence…
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Another advantage of MRI technology is that its images represent very thin 
slices through the subject, making the exact size and location of features 
easy to determine. The 27 images in the Makes My Head Spin stack show 
cross-sections of a human head (with no tumors, fortunately!). Images were 
made every 5 mm, starting from the middle of the nose and continuing up 
through the eyes.

Animating the brain
 Animate the Brain stack.

When you animate the stack, you take a trip through the brain from the nose 
to the top of the head. Although each individual slice has only two di men sions, 
the stack of slices gives us a three dimensional view.

Reslicing the brain
ImageJ can use data from the individual slices in a stack to create new 
views of an object. Imagine cutting straight down through the brain stack 
and looking at the cut from the side. This is called reslicing.

Use  to make a straight line selection across the brain image in  to make a straight line selection across the brain image in 
any direction.

 Choose Image > Stacks > Reslice. Set the Input Z Spacing to 5,
and click OK. (For comparison, try setting the spacing to 3.)

 Reslice the stack along other straight line selections drawn at 
various angles, and experiment with the options in the Reslice
dialog box.

 10. What structures can you see within the brain? Use the diagram at right 
or a textbook to help you identify and describe a few of them.

Projecting the brain
Imagine that each slice of the brain stack was printed on a sheet of clear 
plastic and you held the stack of plastic sheets in your hand. By tilting and 
rotating the stack of images, you could view them from different angles. 
ImageJ can create a series of images that show how a stack would appear as 
it is rotated around any of three axes.

 Close all of the resliced images, but leave the brain stack open.

 Choose Edit > Selection > Select None to make sure there are no 
selections on the brain stack.

 Choose Image > Stacks > 3D Project to project the stack. Fill in the 
3D Projection dialog box as shown at right. Don’t worry for now 
what all of these settings mean. They were chosen to allow you 
to look “through” the hard bone tissue of the skull at the softer, 
fainter brain tissue. Click OK.

 To increase the contrast of the images, choose Image > Adjust >
Brightness/Contrast, and click the Auto button.

 Click the Apply button, then click Apply button, then click Apply Yes when asked if you want to 
adjust the contrast of all of the slices in the stack.

 Close the B&C window.

 Animate the completed projection stack.

Major structures
of the brain

Cerebral CortexCerebral Cortex

MedullaMedulla

CerebellumCerebellum

MidbrainMidbrainMidbrain

Corpus

CallosumCallosum

ThalamusThalamus PonsPons

Spinal CordSpinal Cord

Upside-down?
Your resliced brain image will be 
upside-down with this procedure. To 
make it right-side up, check the Flip 
Vertically box. 
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On your own
Use the images in the On Your Own folder to try out the following 
techniques and to explore stacks and animation techniques.

Making a stack from a montage
Earlier in this lesson you turned a stack into a single image called a montage. 
You can also go the other direction, turning a montage into a stack.

 Close all open images, and open 1 Running Horse.tif.1 Running Horse.tif.1 Running Horse.tif

 Click  , and select the fi rst frame of the running horse. , and select the fi rst frame of the running horse.

 Choose Image > Duplicate to duplicate the selection into its own 
window. Click OK. Drag the new window out of the way.

 Choose 1 Running Horse.tif from the 1 Running Horse.tif from the 1 Running Horse.tif Windows menu to 
activate the source image again.

 Drag the selection outline you made to the second running horse 
frame.

 Duplicate this selection. Repeat this process until you have made a 
sep a rate image from each of the nine running horse frames.

 Close the Running Horse montage image.

 Stack and animate the running horse frames. Close the stack.

Registering slices in a stack
The Rocket Stack shows a model rocket being launched. Unfortunately, 
the camera moved, making it diffi cult to analyze the motion of the rocket. 
Philippe Thevenaz, a researcher of the Biomedical Imaging Group of the 
Swiss Federal Institute of Technology, created an amazing ImageJ add-on 
that automates the process of registering the images in a stack.

 Open the 2 Rocket Stack.tif image.

 Choose Image > Duplicate to make a copy of the fi rst slice of the 
stack (not the whole stack, though it will still work if you do.)

 Choose Plugins > TurboReg > TurboReg.

 Use the default settings, and select the Accurate option.

 Click the Batch button.

The plugin takes over and registers the stack!

 Animate the registered rocket stack. To compare the stacks before 
and after the registration process, you can click on one of the 
original rocket stack copies and animate it.

Batch button.

Image registration —correcting for 
diff erences in position of features in 
two or more images due to camera 
motion and other eff ects.

Note to Mac OS 9 users —
TurboReg is only available for 
Windows and Mac OSX.
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Data
Sheet

Lights, Camera, Action!
 1. What are the fastest and slowest animation speeds in frames per 

second?

 a. fastest = ______ fps (frames per second)

 b. slowest = ______ fps (frames per second)

 2. How many slices are there in Galloping Horse.tif?Galloping Horse.tif?Galloping Horse.tif

 3. How large (in kilobytes, kb) is Galloping Horse.tif?Galloping Horse.tif?Galloping Horse.tif

 4. Look at the bottom of the Window menu when Galloping Horse is 
unstacked. How is it different from when the images are in a stack?

 5. How do the sizes of the individual images compare to the size of the 
stack?

 6. When you add a slice with the Alt or Alt or Alt Control key pressed, is the slice 
added or before or after the current slice?

 7. Describe what happens.

 8. What measurements would you need to make to be able to calculate 
the speed of the hurricane?

 9. What do you notice about the path the electricity travels?

 10. What structures can you see within the brain? Use a textbook to help 
you identify and describe a few of them.

Name(s)   ______________________________ Class  _________   Date  __________________
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Digital Detective
Investigating lookup tables

Teaching
Notes

Overview
This lesson explores techniques of manipulating image lookup tables and 
introduces the use of digital images in forensic science. In Part 1 of the 
lesson, students explore methods for enhancing low-contrast images to 
reveal important details. In Part 2, they measure angles and calculate ratios 
to compare handwriting samples. In Part 3, students enhance, classify, and 
compare fi ngerprints in search of a burglary suspect. In Part 4, students 
enhance and measure images of hair and tire tracks to look for matches to 
crime scene evidence.

Objectives
Students will:

 • manipulate lookup tables to reveal hidden evidence in digital images

 • measure angles and letter heights and calculate proportions to 
compare and identify signatures

 • enhance, classify, and compare fi ngerprints

 • enhance and measure images of trace evidence to solve crimes

Related Activities
 • See “Pixelated Pictures” for an introduction to digital image 

processing.

Career Links
Digital images of fi ngerprints have been compiled into Automated 
Fin ger print Iden ti fi  ca tion Systems (AFIS) in many states. Police can submit 
fi ngerprints from a crime scene to the AFIS, and it will search the database 
for a match. Banks also use digital images of signatures to aid forgery 
detection. Some banks are requiring thumbprints from patrons before 
cashing checks. More recently, some states have begun cataloging entire 
palm prints to help improve their ability to solve crimes.

Acknowledgments
Lesson developed by Carla McAuliffe and LuAnn Dahlman, Center for 
Image Pro cess ing in Education. Updated for use with ImageJ by Larry 
Kendall.

Parts of this lesson are based on “ACME Detective Agency,” developed by 
LuAnn Dahlman and Larry Kendall, Image Processing for Teaching project, 
Uni ver si ty of Ar i zo na.

Images courtesy of the authors.

Goal
Students process crime scene 
evidence to reveal hidden clues 
and solve crimes.

IP Skills
  • Manipulating lookup tables

  • Pasting selections using Paste 
Control

  • Measuring angles

ImageJ Skill Sheets
 • Lookup Tables

 • Cutting & Pasting

 • Measuring

 • Drawing & Text

Teaching
Notes

Teaching tips
There are three additional 
handwriting analysis problems in 
the 07 More Signatures folder.

Challenge your more advanced 
students or those who fi nish their 
work quickly to see how many 
diff erent ways they can fi nd to diff erent ways they can fi nd to diff erent
reveal the hidden information in the 
images.
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Answers
 1. $215,000.00 was deposited in account number 4490-60695-004.

 2. Techniques that reveal the information include, but are not limited to:

 a. Adjust Image > Adjust > Brightness/Contrast so that the Minimum
value is 245 or above (see hint at right).

 b. Choose Process > Enhance Contrast, and set Saturated Pixels to 
3% or more.

 c. Choose Image > Adjust > Window/Level, and set the Level to 251 
and the Window to 15 or lower.

 d. Choose Image > Adjust > Threshold, and set the Minimum to 0–3 
and the Maximum to 250.

 e. Choose Process > Sharpen several times.

 3. Descriptions will vary. The suspect is a white male in his thirties, 
wearing jeans and a three-tone jacket. Techniques include, but are not 
limited to, those described in 2a through 2d above.

 4. The license plate number is JKP 154. (Minimum = 0, Maximum = 0 in 
B&C window.)

 5. Techniques that reveal the information include but are not limited to:

 a. Choose Image > Adjust > Brightness/Contrast, and set Minimum = 
0 and Maximum = 0.

 b. Choose Image > Adjust > Window/Level, and set Level = 23 and 
Window = 52.

 c. Choose Image > Adjust > Threshold, and set the Minimum = 1 and 
the Maximum = 70-255.

 d. Choose Image > Lookup Tables…. Several of the available color 
tables faintly reveal the license plate.

 6. The original date was April 13, 1985. Techniques used to reveal the 
date include but are not limited to:

 a. Choose Image > Adjust > Brightness/Contrast and set Minimum = 
244 and Maximum = 244.

 b. Choose Image > Adjust > Window/Level, and set Level = 255 and 
Window = 25.

 c. Choose Image > Adjust > Threshold, and set the Minimum = 0 and 
the Maximum = 244.

 7. The Blend and And transfer modes make the pasted signature 
transparent.

Hint : In question 1, the receipt is 
readable when the brightness and 
contrast  Minimum is set at 245 or 
higher, and the Maximum is set at 
255. 
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 8. The lowercase “a” and the uppercase “S” share similar shapes and 
styles between the signatures. The lowercase “a” makes a stronger 
case for Sarah Black as an alias of Susan Jones since there are more of 
them to compare.

 9. Baseline angle ≈ 258° (or 179°).

 10. Answers will vary, depending upon the letters chosen for measuring. 
The following angles were measured for the letters indicated in 
parentheses.

Table 1

Letter
Number

Letter Angle

Sample
Signatures

Questioned 
Signature

1 68 (a) 90 (a)

2 84 (a) 98 (r)

3 65 (a) 85 (h)

4 69 (a) 90 (B)

5 79 (a) 81 (l)

6 74 (a) 76 (a)

7 72 (a) 83 (k)

Average angle 73° 86°

 11. As long as the same letters or sets of letters are compared, the angles 
of slants between the two signatures should be very close. Average 
angle slants for the lowercase “a” could range between 70 and 90 
degrees, depending upon the number of letters averaged for the 
calculation.

 12–16.

  Answers will vary, depending upon the letters chosen for measuring. 
The following letter heights are examples. Ratios should be similar for 
the sample and questioned signatures.

Table 2

Sample letters for 
measurement

Letter height (pixels)

Sample
signatures

Questioned
signature

Uppercase

Letter 1 20 19

Letter 2 17 18

Letter 3 18

Letter 4 23

Average 19.5 18.5

Lowercase

Letter 1 13 13

Letter 2 13 12

Letter 3 12 12

Letter 4 11 13

Average 12.3 12.5

Ratio (Upper>Lower) 1.6 1.5
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 17. The ratios are close, though not exact, for the questioned and sample 
signatures.

 18. Answers will vary. However, students will be most likely to choose 
either Dan, Jane, Mark, or Beth since these fi ngerprints have the same 
patterns.

 19. John and Susan can be eliminated at this point since John’s fi ngerprint 
pattern is a whorl and Susan’s is an arch. The crime scene print was 
left by someone with a loop pattern.

 20. Beth was probably at the crime scene. A comparison of her fi ngerprint 
ridge count and marked bifurcations to that of the print obtained from 
the crime scene print shows a very close match.

 21. Carla’s hair is similar in color and texture to that of the crime scene 
hair. Both her medulla and the crime scene medulla are frag men tary. 
Furthermore, the ratio of the di am e ter of the hair to the diameter of 
the medulla is similar for Carla and the crime scene hair. Carla’s is 14.2 
while the crime scene hair is 13.8. (Ratios will vary according to where 
measurements are taken along the length of the hair.)

 22. Mary’s tire tread (Tread 2) matches that of the crime scene tread. 
Therefore, her car was most likely to have been at the scene of the 
crime.
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Digital Detective
Investigating lookup tables

Lesson

Forensic science uses the principles of scientifi c investigation to gather 
and interpret evidence for civil or criminal law cases. Forensic evidence 
includes photographs, documents, DNA, weapons, and fi ngerprints as well 
as trace evidence such as hair, footprints, and fi bers. Image pro cess ing 
has had a major impact on the fi eld of forensic science. It has enabled 
in ves ti ga tors to examine evidence with an additional set of eyes—the “eyes” 
of the computer and other digital devices. In this lesson, you will examine 
several lines of forensic ev i dence. As a digital detective, you will use image 
pro cess ing techniques to help you solve crimes. You may be asked to testify 
in court, so you will need to document your methods carefully.

Part 1: Photographic evidence
In the course of solving crimes, detectives sometimes gather photographs 
and other images. Photo radar and surveillance cameras are two common 
sources of photographic evidence. Details in these images are not always 
per fect ly clear. With image pro cess ing you can expose hidden fea tures and 
com pare details of crime scene images.

 As you look at each piece of photographic evidence, experiment 
with the following tech niques for bring ing out hid den details. Try 
to obtain the sharp est and most detailed image possible.

Image enhancement techniques

To use this technique… do this

Change the brightness and contrast 
of the image.

Choose Image > Adjust > Brightness/
Contrast, and adjust the Minimum, 
Maximum, Brightness, and 
Contrast sliders, or choose Contrast sliders, or choose Contrast
Process > Enhance Contrast. (See 
tip at right.)

Highlight a range of pixel values Choose Image > Adjust > Threshold,
and adjust the upper and lower 
threshold limits.

Change the image’s lookup table Choose Image > Lookup Tables, and 
select one of the available lookup 
tables.

Magnify the image Click on the image, or drag to 
defi ne the area you want to magnify 
using the  tool. tool.

Invert the image Choose Edit > Invert.

Sharpen the image Choose Process > Sharpen or 
Process > Filters > Unsharp Mask. 
(Other fi lters under the Process
menu may be useful too.)

Forensic Science—the science of 
interpreting or establishing the facts 
in civil or criminal law cases.

For best results, experiment 
with diff erent percentages of 
Saturated Pixels.

Process > Enhance 
Contrast tip
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 Open 01 ATM Receipt.tif.01 ATM Receipt.tif.01 ATM Receipt.tif

A faint receipt from an ATM (Automatic Teller Machine) was found at the 
home of a suspected burglar. Unable to read the account number or the 
amount of the deposit, you scanned the receipt to convert it into a digital 
image. Use the techniques described earlier to reveal this information.

 1. What is the account number? How much was deposited?

 2. Describe the steps you used to reveal the information.

 Close 01 ATM Receipt.tif.01 ATM Receipt.tif.01 ATM Receipt.tif

 Open 02 Surveillance Camera.tif.02 Surveillance Camera.tif.02 Surveillance Camera.tif

You’ve asked the bank for photos of anyone using the account number 
above. They were able to provide one picture, but the quality is poor.

 Enhance the image to bring out the details.

 3. Describe the suspect and how you were able to see him or her.

 Close 02 Surveillance Camera.tif.02 Surveillance Camera.tif.02 Surveillance Camera.tif

 Open 03 License Plate.tif.03 License Plate.tif.03 License Plate.tif

The license plate of this car was caught on camera as the suspect was 
fl eeing from a burglary. You believe your burglar has struck again.

 Enhance this image to reveal the license plate number of the car.

 4. What is the license plate number?

 5. Describe the method you used to reveal the plate number.

 Close 03 License Plate.tif.03 License Plate.tif.03 License Plate.tif

Part 2: Examining documents
Documents are another major focus of forensic science. Ex am in ers 
determine the authenticity of written ma te ri als and look for signs of 
alteration or forgery. They determine the age of documents, examine the 
printing or writing, and even analyze the paper and ink itself. They work 
with type writ ten, pho to cop ied, and hand writ ten materials ranging from 
personal cor re spon dence to legal documents. Val i dat ing sig na tures is an 
important part of doc u ment examination.

 Open 04 Dated Will.tif.04 Dated Will.tif.04 Dated Will.tif

At fi rst, this will appears to be genuine and unaltered. However, you 
believe it is actually an older will, and that someone changed the date to 
make it seem to be the most recent version.

 6. Can you show that the date has been changed? Describe your technique.

 Close 04 Dated Will.tif.04 Dated Will.tif.04 Dated Will.tif

A woman named Susan Jones has just been arrested for suspected fraud. 
She is accused of forging checks using several aliases, one of which is 
Sarah Black. As the document examiner in charge of the case, you have 
asked Susan to submit a handwriting sample to you. Even though no one 
signs his or her name exactly the same way each time, there will be many 
similarities between sig na tures from the same person.

 Open 05 Sample Signatures.tif and 06 Questioned 
Signature.tif.Signature.tif.Signature.tif

File > Open…
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 Arrange the images so you can see both of them at the same time.

The questioned signature has faded from exposure to the sun.

 Activate each image, and enhance it to make the writing as dark 
and clear as possible. If you enhance the image contrast using 
Image / Adjust / Brightness/Contrast, be sure to click the Apply
button in the B&C window before continuing.

Now compare the questioned signature to the sample signature using the 
following overlay technique. Watch for similarities in the strokes of letters.

Making transparent overlays
 Activate the 06 Questioned Signature.tif image, click  06 Questioned Signature.tif image, click  06 Questioned Signature.tif  , and  , and 

select a rectangle around the signature.

 Copy the selection, activate 05 Sample Signatures.tif, then paste 05 Sample Signatures.tif, then paste 05 Sample Signatures.tif
the selection on top to create a “fl oating” copy of the questioned 
signature.

 Open the Paste Control, and try out different transfer modes 
to fi nd one that makes the pasted signature transparent while 
allowing you to see the sample signatures beneath it.

 7. Which transfer modes make the pasted signature transparent?

 Drag the questioned signature over the sample signatures, and 
look for similarities between letters.

 8. What letter or letters share a similar shape and style between the two 
signatures?

 Choose Edit > Undo to remove the pasted signature.

You will be presenting your evidence to a jury, so you need to gather 
ad di tion al data for com par ing the signatures. Document ex am in ers often 
char ac ter ize sig na tures by mea sur ing the angle of slant and cal cu lat ing the 
ratio of uppercase to lowercase letter sizes. For the best results, average the 
data from at least four of the sample signatures.

Calculating the average slant angle
Before you can measure the slant angle of the letters in the signature, you 
need to be sure the baseline—the imaginary line that touches the bottoms 
of the letters—is horizontal. The questioned signature is tilted slightly.

 Activate the 06 Questioned Signature.tif image.06 Questioned Signature.tif image.06 Questioned Signature.tif

 Click  , then drag a straight line from left to right that touches , then drag a straight line from left to right that touches 
the bottoms of most of the letters. As you move the line, its angle 
is displayed in the status bar of the ImageJ window. You can 
adjust the line after you select it by dragging the small handles at 
the ends or in the middle.

 9. What is the angle of the baseline you selected?

 Choose Edit > Selection > Select All to select the entire image.

 Choose Image > Rotate > Arbitrarily, and enter the angle of the 
baseline you recorded. Check the Interpolate option, and click 
OK. The signature should now be horizontal. (If not, press the R 
key to revert to the original image and repeat the measurement 
and rotation process.)

Image > Adjust > 
Brightness/Contrast

Edit > Copy

Edit > Paste

Edit > Paste Control...

Read angleRead angle
of line here

Paste Control tip
Do not click on the image outside 
the area you pasted or it will 
become a permanent part of the 
image, and you will not be able 
to reposition it. If this happens, 
immediately choose Edit > Undo
and repeat the select, copy, paste 
process.
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 Use   again to measure the slant of several letters in both the  again to measure the slant of several letters in both the 
sample signatures and the questioned signature. To measure 
consistently, drag each line selection from the baseline up.

 10. Record your angle measurements on your Data Sheet. When you 
have fi nished the angle measurements for each signature, calculate 
and record the average angle for each signature in the table.

 11. How does the average slant of the letters in the questioned signature 
compare to the average slant in the sample signatures?

Calculating the uppercase-to-lowercase
letter height ratio
To calculate a ratio of uppercase to lowercase letter sizes, you will measure 
the heights of the fi rst two letters of the fi rst and last names. Divide the 
average uppercase height by the average lowercase height to obtain the 
ratio. Use this technique for both the sample signatures and the questioned 
sig na ture. (Note: With the questioned signature you will only have two 
uppercase and two lowercase measurements.)

 Click , then click on the images to magnify both to 200% or , then click on the images to magnify both to 200% or 
larger to make the letters easier to measure.

 Click , and hold down the , and hold down the Shift key to make a straight vertical Shift key to make a straight vertical Shift
selection from the top to the bottom of each letter. The length of 
the line is displayed in the status bar of the ImageJ window as you 
drag the line selection. Record the height of each letter on your 
Data Sheet.

 12. Record the heights of the uppercase letters of the sample signatures 
and the questioned signature on your Data Sheet.

 13. Calculate the average uppercase heights for the sample signatures and 
the questioned signature, and record them on your Data Sheet.

 Repeat the procedure to measure and record the heights of the 
lowercase letters on your Data Sheet.

 14. Record the heights of the lowercase letters of the sample signatures 
and the questioned signature on your Data Sheet.

 15. Calculate the average lowercase heights, and record them on your 
Data Sheet.

 16. Divide the average uppercase height by the average lowercase height 
for the sample signatures and the questioned signature, and record 
them on your Data Sheet. This is the letter height ratio.

 17. How does the ratio calculated for the questioned signature compare to 
that for the sample signatures?

 Close all images when fi nished.

You solve it!
 Open any of the cases in the 07 More Signatures folder, and use 

the iden ti fi  ca tion techniques of this lesson to solve the crime.

Read height here
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Latent?
The word “latent” means present but 
not evident. A latent fi ngerprint is 
a fi ngerprint that is not apparent to 
the eye, but can be made visible by 
dusting or some other method to 
make it identifi able.

Part 3: Latent prints (fi ngerprints)
Latent fi ngerprints are one of the most common forms of forensic ev i dence 
col lect ed at crime scenes. Since every fi n ger print is unique, a sus pect’s 
fi n ger print found at the scene of a crime is an un deniable way to prove the 
person was there at some time.

 Open 08 Fingerprints.tif.08 Fingerprints.tif.08 Fingerprints.tif

The set of fi ngerprints you are looking at was photographed, cut out, 
pasted onto a card, and then scanned into the computer. The crime scene 
fi n ger print comes from a glass display case at a jewelry store that was 
burglarized. You also have fi ngerprints of several sus pects.

 18. Whose fi ngerprint do you think the crime scene print most closely 
resembles?

It is diffi cult to see details in these fi ngerprints, so you will use larger 
versions that have been scanned at higher resolution.

 Close 08 Fingerprints.tif.08 Fingerprints.tif.08 Fingerprints.tif

 Open all the images in the 09 Large Fingerprints folder. (Click 
Window > Tile to spread them out.)

 Enhance each fi ngerprint to obtain the sharpest, most detailed 
image possible.

One way to begin eliminating suspects is to classify each fi ngerprint by 
type. You may want to move the windows around to place fi ngerprints side 
by side for comparison. 

 Open 10 Fingerprint Types.tif.10 Fingerprint Types.tif.10 Fingerprint Types.tif

Fingerprints are classifi ed into three main types: arches, loops, and whorls.

 Classify each suspect fi ngerprint by type. Click  to label each  to label each 
suspect image with its fi ngerprint type. Remember to click on 
the image using the text tool, type the name, then press Ctrl-D 
(Opt-D on Mac) to print the name on the image. (Double-click 
to open the Color Picker and change the color of the text.) 

 19. Which suspects can you eliminate based on the fi ngerprint type?

 Close the fi ngerprint images of the suspects you have eliminated.

At this point, you may think you know who committed the burglary. To 
help you make a positive iden ti fi  ca tion, you need to gather more data from 
the fi ngerprints. You will mark and label key features and cal cu late ridge 
counts.

 Open 11 Fingerprint Info.tif. Use the 11 Fingerprint Info.tif. Use the 11 Fingerprint Info.tif < and > keys or the slider 
control to move through the slices of the stack as instructed.

When evidence is presented to a jury, labeled diagrams of fi ngerprints are 
used. The key features of a fi n ger print that used to char ac ter ize it include 
the core, the delta, the ridge count, and several points of comparison.

 Move to the second slice of the stack.

The core is the central point in the fi ngerprint pattern, and the lines are 
known as ridges. The delta is the point closest to the core where the ridges 
diverge or pull apart. Cores and deltas are unique features of loop- and 
whorl-type fi ngerprints, but arches lack them.

Ten types of
fi ngerprints?
The 10 in the fi le name means it is 
the tenth image you open, not that 
there are ten types of fi ngerprint 
patterns! There are only three main 
types of fi ngerprint patterns.

Slider control—
drag to move 
through stack
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 Move to the third slice of the stack.

The number of ridges crossed by a line drawn between the core and the 
delta is called the ridge count.

 Move to the fourth slice of the stack.

In a fi ngerprint, points where ridge lines split are known as bifurcations. 
Any of these can be marked, as they are unique to the fi ngerprint. Typically, 
5–10 points of comparison are selected for each fi ngerprint. The legal 
number of points required to confi rm a match vary from state to state.

 Label each fi ngerprint in the manner shown on the fi fth slice of 
the stack. To make the dots, click  to use the Point Selection tool, 
and then click on the image. Click  to draw the lines and  to draw the lines and  to draw the lines and  to  to 
insert text labels. Remember to press insert text labels. Remember to press Ctrl-D (Opt-D for Macs) to 
“lock” the point or lines on the image!

 20. Based on your analysis, which suspect was defi nitely at the scene of 
the crime?

 Close all the fi ngerprint images.

Part 4: Trace evidence
Trace evidence includes many kinds of material left at crime scenes, 
in clud ing foot prints, tire tracks, hair, blood, bullet markings, clothing, and 
bodily fl uids.

Hair and fi bers
 Open all the images in the 12 Hair folder. (Choose Window > Tile

to spread the images out.)

These hair samples were gathered from friends and associates of a murder 
victim. Each sample is magnifi ed about 400 times actual size.

 Choose Window > Hair Structure.tif to activate the hair structure Window > Hair Structure.tif to activate the hair structure Window > Hair Structure.tif
image and familiarize yourself with the terminology and criteria 
for categorizing and comparing hair specimens.

The central core of a hair, the medulla, is made of large cells that are often 
separated by air spaces. When viewed under a microscope, the medulla 
is often clearly visible. You will use the features of the medulla to help you 
describe each hair and try to fi nd a match to the crime scene hair.

 Enhance each image to show the most detail.

 Label each hair with its medulla classifi cation: none, fragmentary, 
dis con tin u ous, or continuous.

 Compare the suspects’ hair to the hair from the crime scene. Close 
the hair images from the suspects you eliminate.

 When you have narrowed down the list of suspects to a few, 
measure the diameters of the remaining hairs and the diameters 
of their medullas.

 Calculate ratios by dividing the diameter of each hair by the 
diameter of its medulla.

 21. Who was at the murder scene, and what evidence do you have to 
support your claim?

Hair structure
Each strand of hair contains three 
distinct layers. From the outermost 
layer inward:

 • The cuticle is a single layer of 
scales that interlock with the 
cells of the hair’s inner root 
sheath to fi rmly anchor the hair 
in the follicle.

 • The cortex is composed of 
keratinized cells that are tightly 
bound around each other. These 
bands provide the hair with 
strength.

 • The medulla consists of large, 
loosely connected cells with 
air spaces between them. By 
refl ecting light, these air spaces 
help to determine the sheen 
and color tones of the hair. 

Cuticle of a normal hair shaft.Cuticle of a normal hair shaft.
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 Close all the hair images when you are fi nished.

Tire tracks
 Open all the images in the 13 Tire Tracks folder.

Automobile tires also have characteristic patterns that help to determine 
whether or not a particular vehicle was at the crime scene. The three Tire 
Tread images show the tire tread patterns from the cars of three suspects, 
and the Crime Scene Track image is a photograph taken of a track left on 
a driveway at the crime scene. The lighting was poor when the picture was 
taken, so the track pattern is nearly impossible to see.

 Process the Crime Scene Track image to obtain the clearest 
possible view of the tread pattern, and compare it to the tire 
patterns from the three suspects’ vehicles.

 22. Based on your examination of the evidence, which suspect’s vehicle 
was at the scene of the crime?

 Close all the tire track images when you are fi nished.

On your own
Create your own “forensic evidence” 
for an imaginary crime. Write a short 
story describing the crime, the 
suspects, and any available clues. 
Challenge others to use image 
processing techniques to help solve 
the crime.
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Data
Sheet

Digital Detective
 1. What is the account number? How much was deposited?

 2. Describe the steps you used to reveal the information.

 3. Describe the suspect and how you were able to see him or her.

 4. What is the license plate number?

 5. Describe the method you used to reveal the plate number.

 6. Can you show that the date has been changed? Describe your technique.

 7. Which transfer modes make the pasted signature transparent?

Name(s)   ______________________________ Class  _________   Date  __________________
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 8. What letter or letters share a similar shape and style between the two signatures?

 9. What is the angle of the baseline you selected?

 10. Record your angle measurements in the table below. When you have fi nished the angle measurements 
for each signature, calculate and record the average angle for each signature in Table 1.

Table 1

Letter
Number

Letter Angle

Sample
Signatures

Questioned 
Signature

1

2

3

4

5

6

7

Average 
angle

 11. How does the average slant of the letters in the questioned signature compare to the average slant in the 
sample signatures?

 12. Record the heights of the uppercase letters of the sample signatures and the questioned signature in 
Table 2.

Table 2

Sample letters for 
measurement

Letter height (pixels)

Sample
signatures

Questioned
signature

Uppercase

Letter 1

Letter 2

Letter 3

Letter 4

Average

Lowercase

Letter 1

Letter 2

Letter 3

Letter 4

Average

Ratio (Upper/Lower)
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 13. Calculate the average uppercase heights for the sample signatures and the questioned signature, and 
record them in Table 2. (Divide average uppercase height by average lowercase height.)

 14. Record the heights of the lowercase letters of the sample signatures and the questioned signature in 
Table 2.

 15. Calculate the average lowercase heights, and record them in Table 2.

 16. Divide the average uppercase height by the average lowercase height for the sample signatures and the 
questioned signature, and record them in Table 2. This is the letter height ratio.

 17. How does the ratio calculated for the questioned signature compare to that for the sample signatures?

 18. Whose fi ngerprint do you think the crime scene print most closely resembles?

 19. Which suspects can you eliminate based on the fi ngerprint type?

 20. Based on your analysis, which suspect was defi nitely at the scene of the crime?

 21. Who was at the murder scene, and what evidence do you have to support your claim?

 22. Based on your examination of the evidence, which suspect’s vehicle was at the scene of the crime?
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More Than Numbers
Graphing digital images

Teaching
Notes

Overview
Interpreting digital images based on only their appearance can be 
mis lead ing. Two- and three-dimensional graphs of pixel values can aid in 
their in ter pre ta tion and analysis. In this lesson, students create histograms, 
plot profi les, and surface plots to help them understand the data making up 
digital images. Histograms show the number of pixels of each value in an 
image. Density plot profi les graph the pixel values along a given line, and 
surface plots display pixel values as a three-dimensional projection.

In Part 1, students investigate a Digital Elevation Model (DEM) of a section 
of Colorado. First, they discover the most frequently occurring elevation 
value using the histogram function. Next, they create density plot profi les 
and surface plots to help them visualize the shape of the land. They fi nd 
that the view from which a surface plot is created affects the manner in 
which the data are displayed. After gaining a basic understanding of 
histograms, plot profi les, and surface plots, students use these graphs in 
Part 2 to help interpret surface sea tem per a tures and tree ring growth. A 
com par i son of a profi le plot for a photographic image of a crater to one for 
an elevation image of a crater helps to solidify the idea that the information 
a graph  provides is directly dependent upon the data present in the image. 
In Part 3  students explore synthetic images as a means of visualizing 
math e mat i cal re la tion ships. In the On Your Own section, students learn 
how to density calibrate images.

Objectives
Students will:

 • interpret a Digital Elevation Model (DEM) using a histogram, density 
profi le plots, and surface plots

 • use the appropriate two- or three-dimensional graph to interpret 
digital data

 • explain the numerical patterns in image data via analysis of 
histograms, density profi le plots, and surface plots

 • compare and contrast histograms, density pro fi le plots, and surface 
plots to evaluate their usefulness for graphing image data

Related Activities
 • See “Pixelated Pictures” to gain an understanding of digital images.

 • Refer to the lesson “Photo Effects” to discover how histograms can be 
used to help with the res to ra tion of old photographs.

Goal
Students create histograms, plot 
profi les, and surface plots to help 
them interpret the data contained in 
digital images.

IP Skills
  • Interpreting histograms 

  • Interpreting density profi le plots

  • Interpreting surface plots

ImageJ Skill Sheets
 • Selecting

 • Lookup Tables

 • Calibrating Images

 • Managing Windows

Vocabulary 
 • histogram

 • calibration

Teaching
Notes
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Career Links
Digital Elevation Models (DEMs) are used in a wide variety of fi elds such 
as civil en gi neer ing, natural resource management, landscape architecture, 
space science, and geology. Density plot profi les and surface plots make 
it possible to see quickly the data of DEMs. Pho tog ra phy is another 
fi eld in which digital graphs can play a role. His to grams provide useful 
information about the distribution of light and dark pixels in an image. 
These data help photographers dig i tal ly enhance images.

Notes
All of the images used in this lesson are calibrated. See the Calibrating 
Images ImageJ Skill Sheet for more information about image calibration.

Students can make images from any rectangular array of measurements 
or numbers. The values do not have to be in the range of 0-255. Importing 
the data as text causes the values to be read in and automatically scaled to 
the range of 0-255. Measurement results or mathematical functions can be 
entered into spreadsheets, exported as text, and imported as images.
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Lesson developed by Carla McAuliffe, Center for Image Pro cess ing in 
Education, Tucson, Arizona. Updated for use with ImageJ by Larry Kendall.

Parts of this lesson are based on “The Plot Thickens,” developed by LuAnn 
Dahlman, “Picture This...,” developed by LuAnn Dahlman and Larry 
Kendall, and “The Snake & the Rat,” developed by Denice Warren, all of the 
Image Processing for Teaching project, Uni ver si ty of Ar i zo na.

Images courtesy of the University of Arizona, NOAA, USGS, and the 
authors.

Answers
Note: Several of these questions ask students to speculate, predict, or 
describe their observations. While there are no “right” answers to these 
questions, students should demonstrate reasonable effort in their responses.

 1. Answers will vary. Students may describe shades of gray and shapes.

 2. Answers will vary, depending upon the students’ focus. Students will 
often guess it is some kind of X-ray. 

 3. Answers will vary. (Pixel values represent elevation.)

 4. Answers will vary. The highest elevation is 14,433 feet (raw value = 
244), and the lowest elevation is 3,350 feet (raw value = 1).

 5. 1,588 pixels have a value of 8,002 feet.

 6. The highest elevation is 14,433 feet, and the lowest elevation is 3,350 
feet.

 7. The modal elevation in the DEM is 3,532 feet (frequency = 4,041).

 8. The mean elevation is 6,979 feet.

 9. The areas of highest elevation are located at the bottom center of the 
image.
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10.  Answers will vary, depending upon where the transect was drawn on 
the image.  Elevations can be as high as 14,433 feet or as low as 3,350 
feet.

 11.  Answers will vary. Plots with fi xed Y-axis scale can be compared with 
each other.

 12. Answers will vary. Students may describe dips, peaks, and fl at spots 
along the transect, indicating valleys, mountains, and plains or 
plateaus.

 13. Predictions will depend on students’ ability to visualize 3-D structures.

 14. The land is high and mountainous on the left side of the image and 
then slopes gently toward the right. Two drainage basins are visible in 
the foothills area. The Rocky Mountains cover the western two-thirds 
of the image.

 15. The face of the mountain front and the two valleys in the foothills area 
can be seen more readily in this view.

 16. More detail is revealed with a surface plot from small rectangular 
selections.

 17. The parts of the image with a calibrated value of -3 º C. are land and 
ice. This is a pre-set value and not the actual surface temperature. 

 18. The sea surface temperature that occurs most often is 27 º C.

 19. Answers will vary. Lines drawn from pole to pole across the equator 
will show temperatures to be warmest at the equator and coolest at the 
poles.

 20. The peaks represent the light-colored wood, and the dips represent 
the darker wood. Together, each consecutive set of light and dark 
wood represents one annual growth ring.

 21. Wider sets of annual growth rings represent relatively good grow ing 
conditions (“wet” years), and the narrower rings represent years of 
less growth (possibly drought years).

  22. Predictions will vary depending upon whether students recognize the 
dif fer ence between brightness and elevation values.

 23. Student should compare prediction and actual plot.

 24. You cannot readily see the crater because the graph shows the 
brightness of the surface, not the elevation.

 25. The long, fl at section of the profi le is the bottom of the lake.

 26.  Answers will vary. The stepped ramp image has vertical bars of 
distinct shades of gray, while the smooth ramp has continuously 
changing shades of gray.

 27. Histograms show the number of pixels of each value in an image. Each 
line in the stepped ramp histogram corresponds with a vertical bar of 
color. With the smooth ramp the histogram shows that there are equal 
numbers of pixels of many shades in the image.

 28. Answers will vary. The smooth ramp image produces a smooth ramp-
shaped structure, while the stepped ramp gives a plot that looks like a 
staircase.
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 29. A surface plot shows the combined result of multiple density plot 
profi les. A surface plot enables one to view the entire pattern of 
numbers, while a single profi le plot can be very useful for revealing 
discrete, smaller scale trends.

 30. 

 a. Pair 1

  Smooth Ramp

  Stepped Ramp

 b. Pair 2

  Smooth Ramp Down

  Stepped Ramp Down

 c. Pair 3

  Smooth Ramps Blend

  Stepped Ramps Blend

 d. Pair 4

  Smooth Ramps Xor

  Stepped Ramps Xor

 31. The snake’s body temperature appears to change the most due to the 
heat lamp.

 32. Use the area selection tools to sample and measure the surface 
temperature of the rat and the snake before and after they were 
exposed to the heat lamp. Use this information to complete Table 1.

Table 1

Animal

Body Surface Temperature (°C)

Before Heat Lamp After Heat Lamp

Rat 36.9 38.0

Snake 22.8 25.7

 33. Answers will vary. Mammals maintain a body temperature within a 
fairly narrow range regardless of the air temperature, while reptiles’ 
body temperature varies with air temperature.
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More Than Numbers
Graphing digital images

Lesson

Part 1: “See” the numbers
As you look at an image, your eyes give your brain clues about the shape, 
en vi ron ment, and meaning of objects in the image. However, some of the 
data contained within an image may be diffi cult for your eyes to detect 
or interpret effectively. Graphing image data can help you obtain useful 
in for ma tion you might not otherwise be able to see. In this lesson, you will 
create and interpret graphs of the numbers that make up digital images.

 Open 1 Colorado DEM.tif.1 Colorado DEM.tif.1 Colorado DEM.tif

Many digital images are like photographs; the pixel values in the image 
are directly related to the brightness in the original scene. In some images, 
however, the pixel values represent mea sure ments other than bright ness.

 Choose Analyze > Set Measurements…, and set the number of 
decimal places to zero. This will simplify things by displaying all 
measurements as whole numbers.

 1. Look carefully at this image. Then, describe what you see.

 2. What do you think this image shows?

 Move your cursor across the image, and read the pixel values in 
the status bar of the ImageJ window.

 3. What do you think the pixel values in the image represent?

This image, called a Digital Elevation Model, or DEM, displays a regular 
grid of elevation mea sure ments for a section of Earth’s surface. It is a type 
of digital map that is similar to a topographic map since it allows you to 
read elevation data. The data from a DEM can be used to create maps that 
show the locations of animal communities, soils, and vegetation types. This 
particular DEM image shows the state of Colorado.

 Move your cursor around the image again as you observe the 
values in the status bar.

This DEM is an 8-bit image with possible pixel values ranging from 0 
to 255. These values are converted to elevation using an equation that 
was saved with the image. In the status bar, the calibrated pixel value is 
followed by the raw, uncalibrated pixel value in parentheses.

 4. What are the highest and lowest elevations you can fi nd? What raw 
pixel values correspond to each elevation?

Rather than simply examining this image with your eyes, you can create 
a graph to help you “see” the numbers—in this case, the elevation data of 
the image. A his to gram is a graph that shows the frequency distribution of 
values in the image—in other words, it shows the number of pixels there 
are for each different value in the image.

 Choose Analyze > Histogram… to create a histogram for the image.

The status bar
The status bar is located below the 
tool bar in the ImageJ window.ImageJ window.ImageJtool bar in the ImageJ window.ImageJ window.ImageJ

Status BarStatus BarStatus Bar

File > Open

Analyze > Histogram

Calibrated and
uncalibrated images
In uncalibrated (raw) images, the 
pixel values are proportional to 
some measurement but are not 
measurement values themselves. 
They have meaning relative to the 
other pixel values in that image 
but don’t tell you what the actual 
measurement was at each point in 
the image.

In calibrated images, the pixel values 
are converted to approximate 
measurements using an equation. 
For this image, the calibration 
equation is:

elevation = 45.6 x raw value +3,304.4

(To see the calibration equation, 
choose Image > Show Info…)
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 Move your cursor across the histogram plot, and read the Value
(calibrated pixel value, or elevation) and Count (number of pixels) Count (number of pixels) Count
in the bottom part of the histogram win dow.

 5. How many pixels in the image represent an elevation of 8,002 feet?

 6. According to the histogram, what are the highest and lowest 
elevations in the image? (Reported as Max and Max and Max Min in the Histogram
window.)

 7. What elevation occurs most often in this DEM? (Reported as the Mode
in the histogram window.)

 8. What is the average (Mean) elevation in the DEM?

Sometimes, it is useful to produce a detailed list of the information in the 
histogram.

 Click the List button in the Histogram window. Scroll down 
the histogram list, and examine the numbers. Double-check your 
answer to Question 5.

The histogram list shows the raw pixel values (level), the calibrated pixel 
value (value), and the frequency (count). This list can be saved or copied and 
pasted into a spreadsheet for further analysis.

 Close the Histogram and List windows.List windows.List

Profi le plots
 Move your cursor around the image to explore elevation patterns.

 9. Where are the areas of highest elevation located?

Another type of graph called a profi le can help you interpret image data.

 Use the Straight Line Selection tool   to select a line across the   to select a line across the 
image.

 Choose Analyze > Plot Profi le. (In the future, simply press K on 
your keyboard to create a profi le plot.)

The Plot Profi le function creates a graph of the pixel values along the 
selected line, or transect. The y-axis of the profi le shows the elevation, and 
the x-axis shows the distance along the transect. The scale of the y-axis 
ranges from the lowest to the highest value encountered along the transect.

 10. What are the lowest and highest elevations along the transect?

 Use  again to select another transect across the image, then  again to select another transect across the image, then 
create a new profi le plot.

The Y-axis scale is not the same for these two plots, making them diffi cult 
to compare. To compare data from several graphs, it helps to have a fi xed 
scale for the y-axis.

 Close both of the profi le plot windows.

 Choose Edit > Options > Profi le Plot Options, and use the highest 
and lowest elevations of the image (from Question 6) to set the 
Minimum Y and Minimum Y and Minimum Y Maximum Y values.Maximum Y values.Maximum Y

 Create another profi le plot along the same transect.

 11. How does this profi le plot compare to the previous one you created?

Uncalibrated image 
histograms
When you create a list for an 
uncalibrated image histogram, 
only the raw pixel value (value) and 
frequency are reported.

Keeping it horizontal
To force a line selection to be 
horizontal or vertical, hold down 
the Shift key while making the 
selection.

Histogram shortcut
Press the H key on your keyboard 
to make a histogram of the current 
image.

Colorado Landsat
This lesson includes an image 
named 2 Colorado Landsat that 
shows a satellite view of Colorado at 
the same scale as the DEM image. 
Feel free to open this image at any 
time and compare it to the DEM.
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 Make several horizontal profi le plots across sections of the image.

 12. What kinds of landforms does this image show?

 Close all the profi le plot windows.

 Choose Edit > Options > Profi le Plot Options…, and turn off the 
Fixed Y-axis Scale option.

 To cancel any line selections, choose Edit > Selection > Select None.

Surface plots
It is diffi cult to visually translate shades of gray into elevation, so you will 
apply a lookup table that is used to represent elevation on relief maps.

 Choose File > Open…, and open the Elevation.lut color table.Elevation.lut color table.Elevation.lut

This helps, but to get a more meaningful view of the shape of the land, 
you will create a surface plot. Imagine drawing a profi le plot for every row 
of pixels in the image, stacking these plots next to one another, and then 
looking down on them at an angle. Essentially, that is what a surface plot is.

 13. Predict what a surface plot of this DEM will look like.

 Create a surface plot using the settings shown at right. (Choose 
Analyze > Surface Plot ... .)

 14. Describe the shape of the land. Where are the Rocky Mountains?

Your surface plot shows a view of the landscape from the southwest, 
looking to the northeast. By rotating the DEM to the right you can surface 
plot a view from the southeast, looking toward the northwest.

 Activate the 1 Colorado DEM.tif window and choose 1 Colorado DEM.tif window and choose 1 Colorado DEM.tif Image > 
Rotate > Rotate 90 Degrees Right to rotate the DEM clockwise a 
quarter-turn.

 Create another surface plot of the rotated image.

 15. Compare this surface plot from the southeast to the one from the 
southwest. What details are visible in this view that you could not see 
before?

 Experiment with different sizes and shapes of selections and 
different option settings for making surface plots.

 16. How does a surface plot created from a small area compare to one 
created from a larger selection?

 Close all the open image and plot windows.

Part 2: Interpreting digital data
 Open 3 Sea Surface Temperature.tif.3 Sea Surface Temperature.tif.3 Sea Surface Temperature.tif

In this image, pixel values represent the temperature, in degrees Celsius 
(°C), of the ocean’s surface. Black represents land, ice, or missing data. 
As you move your cursor around the image, you can read the changing 
temperature in the status bar. Note where the highest and lowest 
temperatures are located, as well as the value of the black areas.

 Choose Analyze > Set Measurements…, and set the number of 
decimal places to 1. This will allow you to read temperatures to 
the nearest 0.1°C.

Temperature calibration
The calibration equation for the sea 
surface temperature image is:

Temp (°C) = 0.15 x (raw px value) -3

Note: Checking the Note: Checking the One Polygon One Polygon 
Per Line option disables the 
Polygon Multiplier setting.

Surface plot optionsSurface plot options

Plots of plots (Warning!)
When you are creating profi le and 
surface plots, always remember to 
be sure the original image window 
is active before making the plot. 
Otherwise, you may accidentally 
make a plot of the previous plot 
window instead of the image!
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 Create a histogram of the image.

According to the statistics displayed in the histogram window, the mode 
(the most common value) is -3°C. Move your cursor over the image to see 
what areas this value corresponds to.

 17. What parts of the image have a calibrated value of -3°C? Do you think 
this value is the surface temperature in these areas?

In this case, you can’t use the mode value calculated automatically by 
ImageJ to fi nd the most commonly occurring sea surface temperature. 
Instead, move your cursor over the highest peak in the histogram, and read 
the temperature that corresponds to that peak.

 18. What sea surface temperature occurs most frequently in this image?

 Make several vertical (up and down) profi le plots across the ocean 
basins.

 19. What do these north-south profi le plots tell you about the relationship 
between latitude (distance north or south of the equator) and sea 
surface temperature?

 Close all the open image and plot windows.

 Open the 4 Tree Rings.tif image.4 Tree Rings.tif image.4 Tree Rings.tif

This image shows growth rings in a cross-section taken from a tree.

 Create a profi le plot along an interesting part of the cross-section. 
You may need to reset the Y values in the Profi le Plot Options.

 20. What do the peaks and dips on the plots represent?

 21. What do you think the different widths of peaks and dips show?

Tree ring scientists (dendrochronologists) use similar methods to es tab lish 
dates of wood sam ples and to understand how a tree’s growth is affected 
by its environment.

 Close all the open image and plot windows.

 Open the 5 Lambert Crater.tif image. This Apollo 15 image 5 Lambert Crater.tif image. This Apollo 15 image 5 Lambert Crater.tif
shows Lambert Crater, which is approximately 30 km (19 miles) 
wide and 2400 m (8,000 ft) deep.

 22. Before you make a profi le plot across the crater, sketch your prediction 
of what you think the profi le plot will look like.

 Make a profi le plot across the crater.

 23. Sketch the resulting plot, and compare it to your prediction.

Many people predict the shape of the plot incorrectly because they expect 
to see a plot of elevation. Remember that profi le plots are based on pixel 
values. If the pixel values represent elevation, then you will get an elevation 
plot. However, the pixel values in the Lambert Crater image represent the 
bright ness of the surface, including areas of shadow, so the profi le plot is a 
brightness—not brightness—not brightness— elevation—plot.

 Close all the open image and profi le plot windows.

 Open 6 Crater Lake.tif. The pixel values in this image represent 6 Crater Lake.tif. The pixel values in this image represent 6 Crater Lake.tif
el e va tion measurements of the area surrounding a famous lake in 
Oregon that sits in the crater of a dormant volcano.

Reading mode value of 
data from histogram
The Mode value given in the 
Histogram window represents No 
Data values in the image. To fi nd the 
modal value of the data, read the 
value of the peak of the histogram. 
(Hint: The peak value has the highest 
count.)

Ignore this!Ignore this!

Put cursor here

Read the ValueRead the Value
and Count here
Read the ValueRead the Value

and Count here
Read the ValueRead the ValueRead the Value

and Count here
Read the ValueRead the Value

Apollo 15
Apollo 15 was the fourth mission 
to land on and explore the moon. 
While two astronauts were exploring 
the surface, a third was orbiting 
the moon taking photographs and 
making other observations of lunar 
features.
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Window > Tile

 24. How does this image look different from the Lambert crater image? 

 Make several profi le plots across sections of the Crater Lake  
image. Try different tools for making the plot profi le selections. 
The Freehand Selection tool  can be used to try to fi nd a smooth 
route up and over the rim of the crater.

Since the pixel values represent elevations in this image, you get elevation 
profi les. If the pixel values represented temperature, you would get 
tem per a ture profi les, and so on.

 Make surface plots of several selections.

  25. Plot profi les across the crater usually include a long fl at section. What is 
the fl at part?

 Close all the open image and plot windows.

Part 3: Visualizing numeric data
Sometimes the pixel values in a given image represent mathematical 
func tions or matrices of numbers. Any spreadsheet of numbers can be 
displayed as a digital image. Histograms, den si ty plot pro fi les, and surface 
plots can make it easier to see the numerical patterns in the data.

 Open the 7 Paired Images folder. Open both the Stepped 
Ramp Right.tif and Ramp Right.tif and Ramp Right.tif Smooth Ramp Right.tif images in the Smooth Ramp Right.tif images in the Smooth Ramp Right.tif Pair 
1 folder.

 Choose Window > Tile to tile the images.

 26. What differences can you detect between the two images by looking at 
them?

 Activate and create a histogram for each image.

 27. What information does the histogram tell you about an image?

 Move your cursor horizontally and vertically across each image to 
dis cov er numerical patterns of the pixel values. Pixel values and 
coordinates are displayed in the status bar of the ImageJ window.

 Activate each image and create a horizontal profi le plot for each 
one.

 Activate each image and create a surface plot for each one.

 28. Briefl y describe what you see in each surface plot.

 29. Compare how profi le plots show numerical patterns in images to how 
surface plots show them.

Exploring digital data
Examine each of the images in the Pair 2, Pair 3, and Pair 4 folders. 
Predict what a resulting histogram, density plot profi le, and surface plot 
might look like for each image.

 Create a histogram, density plot profi le, and surface plots for each 
image. 

 30. Briefl y describe the pattern of the values in each image. How did the 
plots of each compare to your predictions?

 Close all images when you are fi nished.

On your own
Create and print a histogram, plot 
profi le, and surface plot for an image 
you create or scan. Write a brief 
description of what the graphs tell 
you about your image.

Crater Lake
surface plots
Explore Crater Lake by making 
surface plots of the DEM. For 
example, open the Elevation.lut
lookup table fi le. and turn on the 
wireframe option in the Analyze > 
Surface Plot window. 
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Advanced technique:
Density calibrating an image
Some of the images used in this lesson were density calibrated. This means 
that the raw pixel values were converted to some meaningful, real-world 
measurement through a mathematical equation. In this exercise, you will 
work through the density calibration procedure yourself.

 Open 8 Calibration.tif.8 Calibration.tif.8 Calibration.tif

Mammals and reptiles use different methods to regulate their body 
temperature. These images of a rat (top) and a snake (bottom) were taken 
with a special camera that records thermal infrared radiation. The images 
on the left show both animals at room temperature, and the images on the 
right show them after 15 minutes under a heat lamp.

In the image, dark blues represent lower temperatures, and reds and 
oranges are higher temperatures. The orange object entering the top of the 
frame at upper right is the hand of the person handling the animals. You 
can easily tell what is warmer and what is cooler based on the colors.

 31. Which animal’s body temperature appears to change the most from 
exposure to the heat lamp?

Wouldn’t it be nice to be able to measure the actual temperatures of the 
animals before and after the heat lamp? That would require converting the 
pixel values to temperature values. To do this, you need to have at least two 
known temperatures in the images.

Fortunately, we know that the room temperature when the images 
were made was 23°C, and we know that the human’s skin temperature 
was approximately 33°C. You can use these two known temperatures 
to calibrate the image. After calibration, you will be able to read the 
tem per a ture anywhere in the image, including the rat and the snake’s body 
surface temperatures.

 Choose Analyze > Clear Results to get rid of any previous 
measurements you have made.

 Choose Analyze > Set Measurements and turn off all the 
measurement options except Mean Gray Value. Set the number 
of decimal places to 1, and close the Set Measurements dialog 
box by clicking OK.

 Use one of the area selection tools to select a large sample of 
pixels from the person’s fi ngers in the upper right frame (see 
example at right).

 Press the M key to measure the mean (average) value of the pixels 
in the person’s fi ngers.

 Drag the selection outline from the fi ngers to an area of the 
background, and press M again to measure the mean value of the 
pixels that represent room temperature.

 Choose Analyze > Calibrate to open the calibration dialog box. The 
two mean pixel values you just measured should be listed in the 
left-hand column. Enter the corresponding known temperatures 
of the person (33) and the background (23) in the right-hand 
column. Choose the Straight Line option on the Function menu, 
and enter degrees C in the Unit box. Then click Unit box. Then click Unit OK.

What snake?
Many people question whether 
there’s really a snake present in 
the Before image. If you look very 
carefully in the lower left corner of 
the image, you will see a dark blue 
spot with a dark blue line extending 
below it. This is the snake’s nose 
and tongue, which are cooled 
as moisture is evaporated by the 
surrounding air. You should also be 
able to easily see the snake’s nose 
and tongue in the After image.

Sampling human skin 
temperaturetemperature
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The graph that appears shows the mathematical relationship between pixel 
value and tem per a ture. The computer uses the formula represented by this 
calibration line to convert the raw pixel values to temperature values. Once 
the image is calibrated, the pixel value in the status bar shows the actual 
temperature at the location under the cursor.

 Move your cursor around the image to determine the temperature 
of different areas.

 32. Use the area selection tools to sample and measure the surface 
temperature of the rat and the snake before and after they were 
exposed to the heat lamp. Use this information to complete Table 1.

Table 1

Animal

Body Surface Temperature (°C)

Before Heat Lamp After Heat Lamp

Rat

Snake

 33. What do these results tell you about the differences between how 
mammals and reptiles regulate their body temperatures?
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Data
Sheet

  More Than Numbers
 1. Look carefully at this image, and describe what you see.

 2. What do you think this image shows?

 3. What do you think the pixel values in the image represent?

 4. What are the highest and lowest elevations you can fi nd? What raw pixel values correspond to each 
elevation?

 a. lowest elevation = ___________  ( raw value = ______ )

 b. highest elevation = ___________  ( raw value = ______ )

 5. How many pixels in the image have a value of 8,200 feet?

 6. According to the histogram, what are the highest and lowest elevations in the image? (Reported as Max 
and Min in the histogram window.)

 a. lowest elevation = ________

 b. highest elevation = __________

 7. What elevation occurs most often in this DEM? (Reported as the Mode in the histogram window.)

 8. What is the average (Mean) elevation in the DEM?

Name(s)   ______________________________ Class  _________   Date  __________________
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 9. Where are the areas of highest elevation located?

 10. What are the lowest and highest elevations along the transect?

 a. lowest elevation = _________

 b. highest elevation = _________

 11. How does this profi le plot compare to the previous one you created?

 12. What kinds of landforms does this image show?

 13. Predict what a surface plot of this DEM would look like.

 14. Describe the shape of the land. Where are the Rocky Mountains?

 15. Compare this surface plot from the east to the one from the south. What details are visible in this view 
that you could not see before?

 16. How does a surface plot created from a small rectangular selection compare to one created from a larger 
rectangular selection?



 More Than Numbers 97
©2006 The Center for Image Processing in Education and 

 More Than Numbers
©2006 The Center for Image Processing in Education and 

 More Than Numbers More Than Numbersportions ©1998 Arizona Board of Regents. More Than NumbersLimited classroom reproduction rights are granted earlier in this work. More Than NumbersLimited classroom reproduction rights are granted earlier in this work. More Than Numbers

 17. What parts of the image have a calibrated value of -3°C? Do you think this value is the surface 
temperature in these areas?

 18. What sea surface temperature occurs most often?

 19. What do these graphs show you?

 20. What do the peaks and dips on the plots represent?

 21. What do you think the different widths of peaks and dips show?

 22. Before you make a profi le plot across the crater, make a sketch to predict how you think the plot will 
look.

 23. Sketch the resulting plot, and compare it to your prediction.

 24. How does this image look different from the Lambert Crater.tif image?Lambert Crater.tif image?Lambert Crater.tif
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  25.  Plot profi les across the crater usually include a long fl at section. What is the fl at part?

 26.  What differences can you detect between the two images by looking at them?

 27. What information does the histogram tell you about an image?

 28. Briefl y describe what you see in each surface plot.

 29. Compare how profi le plots show numerical patterns in images to how surface plots show them.

 30. Briefl y describe the pattern of the values in each image. How did the plots of each compare to your 
predictions?

 31. Which animal’s body temperature appears to change the most from exposure to the heat lamp?

 32. Use the area selection tools to sample and measure the surface temperature of the rat and the snake 
before and after they were exposed to the heat lamp. Use this information to complete Table 1.

Table 1

Animal

Body Surface Temperature (°C)

Before Heat Lamp After Heat Lamp

Rat

Snake

 33. What do these results tell you about the differences between how mammals and reptiles regulate their 
body temperatures?
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North American Tour
Coordinates and measurement

Teaching
Notes

Overview
This lesson provides an opportunity for students to work in cooperative 
groups as they plan a route for their band’s fi rst North American tour. 
Students add state and province outlines to a satellite image of North 
America, use image co or di nates to locate and mark concert venues, 
and use the text tool to label the cities they will visit. They plan the most 
cost-effective tour by measuring the distances of pro posed routes and 
calculating aircraft costs. Finally, students use drawing tools to show the 
fl ight plan and the sequence of cities visited on the tour. If a printer is 
available, students can print their maps.

In an optional activity, students can redesign their trip as a bus tour by 
measuring the route following major roads and using a highway map. 

Objectives
Students will:

 • locate coordinates and plot points

 • label features

 • set image scale

 • measure distances

 • choose the shortest route to visit seven cities

 • calculate fuel, maintenance, and operation costs

Career Links
The ability to take measurements from images on a computer screen rather 
than from the real thing is changing the way manufacturing and research 
are conducted. Measurements are made from images in fi elds ranging from 
medicine to electronics to remote sensing of Earth from space.

Acknowledgments
Lesson developed by Carla McAuliffe and LuAnn Dahlman, Center for 
Image Pro cess ing in Education. Updated for use with ImageJ by Larry 
Kendall.

Parts of this lesson are based on Travel USA, developed by LuAnn 
Dahlman and Larry Kendall, Image Processing for Teaching project, The Image Processing for Teaching project, The Image Processing for Teaching
Uni ver si ty of Ar i zo na.

NA_Satellite.tif image courtesy of NASA/Goddard Space Flight Center NA_Satellite.tif image courtesy of NASA/Goddard Space Flight Center NA_Satellite.tif
Scientifi c Visualization Studio, based on Terra/MODIS satellite data. All 
other images were provided by the authors.

Aircraft operating costs estimated from http://www.omnijet.com/database/
lear455560/, updated for current average fuel costs. Fuel cost (Jet A) current 
as of 4/10/05, based on data from http://www.airnav.com/fuel/local.html.

Notes

Goal
Students locate coordinates, label 
cities, and measure distances on a 
satellite image of North America 
to help them plan a cost-eff ective 
concert tour.

IP Skills
  • Reading and plotting X and Y 

coordinates

  • Using the text tool

 • Setting a scale

  • Measuring

 • Drawing

ImageJ Skill Sheets
 • Cutting & Pasting

 • Selecting

 • Calibrating Images (Spatial)

 • Measuring

 • Drawing & Text

 • Managing Windows

Teaching Notes
Before starting this lesson, make 
sure that the X,Y coordinate 
system in ImageJ has been set to 
match quadrant I of the Cartesian 
coordinate system, with the origin 
(0,0) in the lower left corner of the 
image window. Choose Analyze > 
Set Measurements…, check the 
Invert Y Coordinates option, and 
click OK.
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Answers
 1. Answers will vary. (No correct answer - this one is just for fun!)

 2. Correct X,Y coordinates depend on home town. Example: Kansas City, Missouri: X = 417  Y = 390

 3. Sample Itinerary - actual itineraries will vary.

Depart Arrive Distance

Home town - Kansas City, MO City 1 - Boston 1,996 km

City 1 - Boston City 2 - Miami 2,028 km

City 2 - Miami City 3 - Mazatlan 2,660 km

City 3 - Mazatlan City 4 - San Francisco 2,148 km

City 4 - San Francisco City 5 - Calgary 1,647 km

City 5 - Calgary City 6 - Denver 1,427 km

City 6 - Denver Home town - Kansas City, MO 893 km

Total distance traveled 12,799 km

 4. Answers will vary. Should give distance of shortest of three itineraries. In this example, total distance is 
12,817 km.

 5. Answers will vary. Example:
Total Distance / Average Ground Speed = 12,799 km / 644 km/hr = 19.9 hrs

 6. Answers will vary. Example:
Fuel = Flight Hours / Burn Rate = 19.9 hrs x 720 liters/hr = 14,328 liters

 7. Answers will vary. Example:
Total fuel cost = amount of fuel x average cost of jet fuel = 14,328 liters x $0.86/liter = $12,322

 8. Answers will vary. Example:
Maintenance and operation cost = fl ight hours / hourly cost = 19.9 hrs. x $1,100/hr = $21,890

 9. Answers will vary. Example:
Total cost = fuel cost + operating cost = $12,322 + $ 21,890 = $34,212

 10. Answers will vary. Example:
Average amount needed per concert = $34,212 / 7 concerts = $4,887 / concert

 11. Answers will vary - paragraph describing tour.
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North American Tour
Coordinates and measurement

Lesson

Your band has been working hard for months and has fi nally come up with 
a hot, new sound—you’re ready to take it on the road! The band wants to 
play in cities across North America, and you’ve been appointed to plan the 
tour. You have a limited travel budget so you’ll want to set up the most cost-
effective tour possible.

 1. What is the name of your band?

Planning your tour
 Launch ImageJ, and open the NA_Satellite.tif image.NA_Satellite.tif image.NA_Satellite.tif

This image is not a map, but a satellite image of the most populated part of 
North America. North America never actually looks like this because much 
of the land is always covered by clouds, but the colors are approximately 
what you would see on a cloud-free day. The image was assembled from 
hundreds of smaller images produced by the MODIS instrument on the 
Terra satellite. Each pixel in the image rep re sents a square on Earth’s 
surface that is ap prox i mate ly 3.75 miles (6 km) on a side.

Adding state outlines
Political boundaries aren’t visible to a satellite, but you need to show where 
they are to give the band a good picture of the proposed tour. Next, you 
will add state (US and Mexico) and province (Canada) outlines to the image.

 Open NA_States.tif.NA_States.tif.NA_States.tif

 Use the following procedure to add boundaries to the image.

 • Activate the NA_States.tif image.NA_States.tif image.NA_States.tif

 • Choose Edit > Selection > Select All.

 • Choose Edit > Copy.

 • Activate the NA_Satellite.tif image.NA_Satellite.tif image.NA_Satellite.tif

 • Choose Edit > Paste.

 • Choose Edit > Paste Control….

 • In the Paste Control window, set the Transfer Mode to 
Transparent, then close the Paste Control window.

 • To make the paste permanent, choose Edit > Selection > Select 
None.

 Close the NA_States.tif image.NA_States.tif image.NA_States.tif

 If you are allowed to save fi les, you may wish to save your map 
with the state outlines.

File > Open… > NA_Satellite.tif

File > Open… > NA_States.tif

Terra/MODIS
To learn more about the Terra 
satellite and the MODIS instrument, 
visit http://modis.gsfc.nasa.
gov/about/.

File > Save ...
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Marking tour cities 
You have received offers to play in thirty major cities around North America. 
Your time and budget are limited, so you will only play concerts in seven 
cities, including your home town. Your tour must include at least one city 
in Canada and one in Mexico, plus one city each in the eastern, central, and 
western United States.

Using the list below, select six venues you will visit on your tour. On your 
Data Sheet, list your six selected cities. (Do not write on the list below.)

Table 1 - Major Cities of North America

√ Name X Y Code √ Name X Y Code

Atlanta, GA 570 298 ATL Montreal, Canada 689 534 YMX

Boston, MA 734 484 BOS New Orleans, LA 484 222 MSY

Calgary, Canada 196 641 YYC New York City, NY 700 446 JFK

Chicago, IL 514 444 ORD Ottawa, Canada 665 526 YOW

Cleveland, OH 595 442 CLE Phoenix, AZ 150 320 PHX

Dallas, TX 382 276 DFW Quebec, Canada 714 563 YQB

Denver, CO 271 416 DEN Salt Lake City, UT 181 450 SLC

Detroit, MI 575 459 DTW San Diego, CA 72 325 SAN

Houston, TX 400 220 IAH San Francisco, CA 28 426 SFO

Los Angeles, CA 62 352 LAX Seattle, WA 82 609 SEA

Mazatlan, Mexico 210 121 MZT St. Louis, MO 478 383 STL

Mexico City, Mexico 326 36 MEX Toronto, Canada 621 489 YYZ

Miami, FL 650 158 MIA Vancouver, Canada 84 641 YVR

Minneapolis, MN 437 500 MSP Washington, DC 667 405 DCA

Monterrey, Mexico 315 149 NTR Winnipeg, Canada 393 593 YWG

At the end of your concert tour, you will give a fi nal concert in your home 
town, to thank them for supporting the band.

 Using a map or atlas, estimate the location of your home  town on 
the image.

 2. What are the approximate X,Y coordinates of your home town on the 
image?

Use the following techniques to mark and label the locations of your home 
town and the six cities you chose for your tour.

 Double-click the Color Picker tool   , and choose a high-visibility  , and choose a high-visibility 
color for your labels. (Hot pink works well.) Close the Color 
Picker window.

 Double-click the Paintbrush tool   , set the paintbrush diameter  , set the paintbrush diameter 
to between 5 and 10 pixels, and click OK.

 Reading the X,Y coordinates in the status bar, move your cursor to 
the location of each city, and click to draw a dot to mark the city’s 
location. If you make a mistake, immediately choose Edit > Undo.

 If appropriate (ask your instructor), you may wish to save your 
work again.

 Double-click the Text tool  to set the text font, size, and style. to set the text font, size, and style.

What is the Code in the 
major cities table?
The Code column lists the airport 
code for the major (international) 
airport serving each city. This 
information may be useful later in 
your planning.

What if I don’t Undo 
immediately?
If you make a mistake and don’t Edit 
> Undo immediately, or if Undo is 
not available for some reason, you 
will have to start the entire process 
over. Choose File > Revert.

How much is diesel 
fuel?
For current diesel prices, visit http://
www.fuelgaugereport.com.

Tip: Inverting the Y 
coordinates
To ensure that your Y coordinates 
increase from the bottom of the 
image, select Analyze > Set 
Measurements, and click the 
Invert Y Coordinates box. 
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 Click , then click near one of the cities you marked to type that , then click near one of the cities you marked to type that 
city’s name.  Drag the text selection to the desired location, then 
press Ctrl-D to permanently draw it on the image.

 Repeat this process to label all of the cities you marked on the 
map, including your home town.

 You may wish to save your labeled image.

Making your fl ight plan
Now that you have marked all the tour stops on your map, you need to 
create your fl ight plan. A local business executive has offered to let your 
band use her Learjet 60, an 8-passenger private jet, at cost. She has asked 
that you pay only the fuel and operating costs of the jet. A breakdown of 
these costs is provided at right.

Setting scale
To make mean ing ful measurements on your map, you must fi rst set the 
scale for the image. This means telling the computer the actual distance 
represented by some distance in the image.

 Use  to zoom in on the scale bars in the lower left corner of the  to zoom in on the scale bars in the lower left corner of the 
image.

 Decide which measurement units you wish to use, and use the 
Straight Line Selection tool  to select a line from one end of the  to select a line from one end of the 
appropriate scale bar to the other. Hold down the shift key as you shift key as you shift
drag the selection to keep the line horizontal.

 Choose Analyze > Set Scale….

 Enter the Unit of Length for the scale bar you chose (mi or km).

 Enter 500 for the Known Distance.

 The Scale reported at the bottom shows how the computer will 
convert pixels to the units you chose. Click OK.

Once the scale is set, you can measure any distance or area on the image 
and the results will be reported in the units you chose.

Measuring distances
Use the three tables on your Data Sheet to help you plan an itinerary Data Sheet to help you plan an itinerary Data Sheet
(order of cities) that will take you to the six cities you selected in the 
shortest total travel distance. Start and end each itinerary in your home 
town.

Insert the city names into the tables to create three different itineraries to 
choose from. Choose  to select and measure each segment (leg). The 
length of each segment is displayed in the status bar of the ImageJ window 
as you drag the line selection. Record the distances in the tables on your 
data sheet.

 3. Fill in the tables to show the distances traveled for three possible tour 
itineraries. For each itinerary, add the individual distances to fi nd the 
total distance you would have to travel. (Note: since the range of your 
jet is 2,680 mi (4,300 km), you must eliminate any segment longer than 
that range.)

Learjet 60 specs
 • Operating cost (excluding fuel) 

= $1,100/hr [Current 4/2005]

 • Cost of jet fuel = $3.25/gallon, 
($0.86 per liter) [Current 4/2005]

 • Burn rate = 190 gallons/hour 
(720 liters/hour)

 • Average cruising speed = 460 
mi/hr (644 km/hr)

 • Maximum range = 2,680 mi 
(4300 km).

    •   For updates on aviation fuel 
prices, visit http://www.airnav.
com/fuel/local.html.
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 4. What is the total distance of your shortest route? On your own
If the cost of traveling by jet was too 
high, you might decide to tour by 
bus instead.

 • Open another copy of NA_
Satellite.tif.

 • Using the same procedure as in 
the lesson, open the NA_States.
tif image and copy and paste tif image and copy and paste tif
the state bound aries onto 
the satellite image. Open the 
NA_Highways.tif image, and NA_Highways.tif image, and NA_Highways.tif
copy and paste the highways 
onto the satellite image.

 • Mark, label, and measure out 
a bus tour just as you did 
for your fl ight plan. Use the 
Segmented Line Selection tool 

 to measure distances along  to measure distances along 
major highways. (You may need 
to refer to a road atlas to help 
you identify the names of major 
highways.)

More measuring
The ability to make measurements 
from images on a computer screen, 
rather than from the real thing, is 
changing research, man u fac turing, 
and medicine.

Things that are too big, too small, 
too fast, or too slow to measure in 
real life can be studied by measuring 
images. Images created by X-ray 
machines, magnetic resonance 
sensors, radiotelescopes, and other 
devices that measure wave lengths 
the human eye cannot see, allow us 
to measure things we can’t detect 
directly.

 • Open any of the images in 
the More Measuring folder 
to practice setting scale and 
measuring images.

Create a brochure advertising your 
band’s tour. Cut and paste images, or 
use the drawing tools to add fl air to 
your fl yer!
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 1. What is the name of your band?

 2. What are the approximate X,Y coordinates of your home town on the image?

  X = ______  Y = ______

 3. Fill in the tables to show the distances traveled for three different tour itineraries. For each itinerary, add 
the individual distances to fi nd the total distance you would have to travel.

 a. Tour Itinerary 1

Depart Arrive Distance

Home town City 1 - 

City 1 - City 2 - 

City 2 - City 3 - 

City 3 - City 4 - 

City 4 - City 5 -

City 5 - City 6 -

City 6 - Home town

Total distance traveled

 b. Tour Itinerary 2

Depart Arrive Distance

Home town City 1 - 

City 1 - City 2 - 

City 2 - City 3 - 

City 3 - City 4 - 

City 4 - City 5 -

City 5 - City 6 -

City 6 - Home town

Total distance traveled

 c. Tour Itinerary 3

Depart Arrive Distance

Home town City 1 - 

City 1 - City 2 - 

City 2 - City 3 - 

City 3 - City 4 - 

City 4 - City 5 -

City 5 - City 6 -

City 6 - Home town

Total distance traveled

Data
Sheet

North American Tour

Name(s)   ______________________________ Class  _________   Date  __________________
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 4. What is the total distance of your shortest route?

 5. Estimate the total number of hours you will be in the air. (Divide the 
total distance by the average ground speed of the jet: 460 mi/hr or 700 
km/hr, depending on the units you used for your measurements.)

 6. Estimate the amount of fuel you will need. (Multiply the total number 
of fl ight hours by the fuel burn rate: 190 gallons/hr or 720 liters/hr.)

 7. Estimate your total fuel cost. (Multiply the amount of fuel you will use 
by the average cost of jet fuel: $3.25/gallon or $0.86/liter.)

 8. Estimate your maintenance and operation cost. (Multiply the total 
number of fl ight hours by the hourly cost: $1,100/hr.)

 9. Calculate the total cost of the tour by adding the estimated fuel cost 
and the estimated maintenance and operation cost.

 10. If you are playing a total of seven concerts, how much income will you 
have to average at each venue to cover the cost of the jet? (Divide the 
total cost of the jet by the number of concerts.)

 11. On another sheet of paper, write a paragraph describing your tour.
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Digitizing Details
Creating your own digital images

Teaching
Notes

Overview
This lesson explores concepts of bit depth and spatial resolution to prepare 
students to use imaging hardware and software effectively. Students 
examine an image scanned at various bit depths and spatial resolutions to 
understand the relationship between bit depth, resolution, image detail, 
and fi le size. They explore images at all available bit depths to discover 
how tonal variation and precision increases with bit depth. Throughout 
the lesson, students are exposed to binary num bers and the mathematics 
behind the display of digital images.

A section on fi le formats explains the characteristics, uses, and advantages 
of the various image fi le types supported by ImageJ.

Objectives
Students will:

 • relate bit depth of digital images to image clarity

 • relate bit depth to the number of colors or shades of gray (the values) 
making up the image

 • relate spatial resolution to increases in memory to image size, clarity, 
and storage requirements 

 • select appropriate fi le formats for saving images

Related Activities
 • See “Color by Number” for information on separating, enhancing, and 

re con struct ing digital color photographs.

 • See “Pixelated Pictures” for an introduction to digital image 
processing.

Acknowledgments
Lesson developed by Carla McAuliffe and LuAnn Dahlman, Center for 
Image Pro cess ing in Education. Updated for use with ImageJ by Larry 
Kendall.

Balloon image © 2005 James A. Kendall. Used with permission.

Tin House, Flower, Wheel, and Sue images © 2005 Larry Kendall. Used 
with permission.

FITS images courtesy of Jodrell Bank Radio Observatory.

Goal
Students examine the relationships 
between spatial resolution, bit 
depth, and fi le size of digital images 
produced with scanners and digital 
cam er as.

IP Skills
 •  Manipulating image windows

 •  Creating and interpreting image 
histograms

 •  Converting between image 
types

 • Calculating image sizes

ImageJ Skill Sheets
 •  Lookup Tables

 • Stacks and Animations

 • Managing Windows

Notes
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Answers
 1. The image appears less detailed with fewer shades of gray as the bit depth decreases.

 2. Answers may vary, but bit depth appears to degrade most obviously when going from 4 bits to 3 bits.

 3. Complete the table showing the number of possible colors that correspond to the following bit depths.

Bit 
depth

Expanded
Representation

Exponential 
Representation

Possible
Colors

1 2 21 2

2 2 × 2 22 4

3 2 × 2 × 2 23 8

4 2 × 2 × 2 × 2 24 16

5 2 × 2 × 2 × 2 × 2 25 32

6 2 × 2 × 2 × 2 × 2 × 2 26 64

7 2 × 2 × 2 × 2 × 2 × 2 × 2 27 128

8 2 × 2 × 2 × 2 × 2 × 2 × 2 × 2 28 256

 4. Sue (4-bit).tif image can contain a maximum of 16 different colors.Sue (4-bit).tif image can contain a maximum of 16 different colors.Sue (4-bit).tif

 5. According to its histogram, the 4-bit image contains 16 colors. 

 6. Balloon 8-bit.tif = 246 KB. This should match the calculated value very closely.Balloon 8-bit.tif = 246 KB. This should match the calculated value very closely.Balloon 8-bit.tif

 7. Predicted size of Balloon 16-bit.tif  = 492 KB.Balloon 16-bit.tif  = 492 KB.Balloon 16-bit.tif

 8. Prediction should match the actual value of 492 KB.

 9. Predicted size of Balloon 32-bit.tif  = 984 KB. This should match the actual value.Balloon 32-bit.tif  = 984 KB. This should match the actual value.Balloon 32-bit.tif

 10. The advantage of 32-bit fl oating point image data is that it can represent very large, very small, and 
fractional values. Often, these can be the actual measurements made without the need for rounding, 
scaling, or truncating the data values.

 11.  Predicted size of Balloon RGB Color.tif  = 738 KB. This should not match the actual value of 984 KB.Balloon RGB Color.tif  = 738 KB. This should not match the actual value of 984 KB.Balloon RGB Color.tif

 12. Predicted size of Balloon RGB Stack.tif  = 1.44 MB. This should not match the actual value of 1.4 MB.Balloon RGB Stack.tif  = 1.44 MB. This should not match the actual value of 1.4 MB.Balloon RGB Stack.tif

 13. The quality of the image decreases when you convert it to indexed color, particularly in the smooth 
colors of the balloon.

 14. In general, as the bit depth increases, the memory required for the image increases.

 15. When the images are all displayed at the same scale, the size of the image increases as the resolution 
increases.

 16. The dimensions of the 300 dpi image are 216 px × 304 px.

 17. The memory required for this image would be 64 KB:
216 (px) × 304 (px) × 1 (bytes/px) × 1 Channels

1024 bytes/kilobyte

 18. As you double the spatial resolution, the image size increases by four times (the square of the increase in 
resolution.)

 19. If you increased the resolution to 1200 dpi, the image size would increase to 1024 KB (1 MB).

 20. As the resolution in creas es, the details get sharper and clearer.

 21. If a 100 dpi image has a fi le size of 50KB, increasing the scan resolution to 300 dpi will increase the fi le 
size to 450 KB.
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 22. Using the output device resolution table, the ideal image resolution for printing on a 600 dpi laser printer 
would be: 60 lpi x 1.5 = 90 dpi to 106 lpi x 1.5 = 159 dpi.

 23–28.

Image Name Open Size
(KB)

Approx. Saved 
Size (KB)

Quality
(High / Medium / Low)

Scene RGB Color.tif 944 KB 712 KB High

Scene RGB Color.zip 944 KB 680 KB High

Scene 8-bit Color.tif 236 KB 240 KB Medium

Scene 256 Colors.gif 236 KB 256 KB High

Scene 12 Colors.gif 236 KB 84 KB Low

Scene Quality 100.jpg 944 KB 328 KB High

Scene Quality 50.jpg 944 KB 56 KB Medium

Scene Quality 10.jpg 944 KB 20 KB Low

Graphic RGB Color.tif 944 KB 712 KB High

Graphic RGB Color.zip 936 KB 8 KB High

Graphic 8-bit Color.tif 236 KB 240 KB High

Graphic 256 Colors.gif 236 KB 8 KB High

Graphic 12 Colors.gif 236 KB 4 KB High

Graphic Quality 100.jpg 944 KB 36 KB Medium

Graphic Quality 50.jpg 944 KB 12 KB Medium

Graphic Quality 10.jpg 944 KB 8 KB Low

 29. Answers will vary. For this scene, most students will probably say that the minimum quality level that 
produces a “high quality” image is between 30 and 50.

 30. Answers will vary. JPEG is an appropriate format for this type of image because it is unlikely that 
pixel values will be of scientifi c interest, and the fi le size will be much smaller than TIFF format with a 
minimum decrease in image quality.

 31. Answers will vary. For this scene, most students will probably say that the minimum quality level that 
produces a “high quality” image is between 40 and 60 colors.

 32. Answers will vary, but most students will probably say that GIF format would not be appropriate for this 
type of scene because it contains too many subtle colors. The image would have to be saved with too 
many colors to benefi t from saving in the GIF format.

 33. No: The memory size of an open image depends only on the height, width, and bit depth of the image.

 34. GIF format can save a graphic image in the smallest fi le without sacrifi cing image quality.

 35. JPEG format saves a continuous tone image in the smallest fi le without sacrifi cing image quality.

 36. TIFF format is the best choice for preserving the original pixel values of an image for scientifi c analysis.

 37. Diagrams are usually best saved in GIF format because they contain a limited number of colors and can 
be compressed without loss of quality.

 38. Color images for Web pages are best saved in JPEG format because it creates the smallest fi le with the 
least loss of quality.

 39. The main advantage of JPEG format is that it produces smaller fi les that download faster over a network 
connection.

 40. If storage space is not an issue, it is preferable to save in TIFF format using the highest available 
resolution and bit depth. Any other image type and format can be created from this fi le.
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Digitizing Details
Creating your own digital images

Lesson

We use scanners, digital cameras, and printers to produce digital images 
for everything from ad ver tising to archiving documents to conducting 
scientifi c research. By understanding the basic aspects of the digitizing 
process, you are more likely to produce the images you want without losing 
important information.

A digital image is stored as a series of numerical values. When these values 
are arranged in a rectangular grid of rows and columns, and a specifi c 
color is assigned to each different value, a picture is formed. Each point 
in the grid is called a pixel, or picture element. The numerical values of 
the pixels may represent the various colors of the image, as in a paint-by-
number picture, or they may represent measurements such as temperature, 
elevation, or refl ectance.  

Three fundamental and interrelated characteristics of digital images are bit 
depth, spatial resolution, and fi le format. When working with digital images, 
the key question is “What do you intend to do with this image?” Will 
you display it on a computer screen, or do you need to print the image? 
Keeping your purpose in mind will help you to make decisions about image 
characteristics and achieve the result you want.

Bit Depth (depth resolution)
Bit depth refers to the number of bits, or binary digits, used to store the 
value of each pixel in an image. The number of bits determines the range of 
possible pixel values. Each unique pixel value represents a specifi c color, so 
bit depth also represents the number of possible colors in the image.

 Open all the images in the Bit Depth folder, starting with Sue (1-
bit).tif and ending with bit).tif and ending with bit).tif Sue (8-bit).tif. (Do not open Sue (8-bit).tif. (Do not open Sue (8-bit).tif Sue (1-bit) 
dithered.tif yet.)dithered.tif yet.)dithered.tif

 Choose Window > Tile to arrange the eight images so you can see 
them all at the same time.

 1. Describe how the appearance of the image changes as the bit depth 
decreases from 8 bits to 1 bit.

 Click , then click twice on the image to zoom in 400% on the 
face in each image. Hold down the Shift key as you click on each Shift key as you click on each Shift
image to keep the window from changing size as you zoom.

 2. At what bit depth does the image quality begin to degrade noticeably?

A bit, or binary digit, can have a value of either 0 or 1. Thus, each pixel in a bit, or binary digit, can have a value of either 0 or 1. Thus, each pixel in a bit
1-bit digital image can be either black (0) or white (1). In a 2-bit image, each 
pixel is represented by 2 bits, each of which can have a value of 0 or 1. This 
produces four possible pixel values: 00, 01, 10, and 11, which correspond to 
four colors, such as black, dark gray, light gray, and white.

Lesson

Archiving documents
In the past, banks, utility companies, 
and other businesses processed and 
stored paper copies of documents, 
such as contracts, invoices, and 
cancelled checks. Today, these 
documents are often scanned 
and stored electronically, saving 
signifi cant time, money, and storage 
space.

“Talking” binary
The numbers we use every day 
are decimal, or “base ten” numbers. 
When we write binary, or “base two” 
numbers, we add a subscript of 2 
(the number base), so the binary 
value 10 would be 10

2
.

When you read or say a binary 
number, say each digit separately, 
as either “zero” or “one”. For example, 
read 10

2
 as “one-zero,” not “ten” and 

11
2
 as “one-one,” not eleven. In the 

text, binary numbers are written 
without the base subscript.

Grays are colors too!
In this text, we will refer to any visual 
representation of a pixel value as a 
color, so all shades of gray are colors, color, so all shades of gray are colors, color
as are black and white!
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Rather than fi gure out all the possible combinations of binary digits for 
images of different bit depths, you can easily calculate the number of 
possible pixel values by raising 2 to the power of the number of bits per 
pixel.

 3. Complete the table showing the number of possible colors that 
correspond to the following bit depths.

Bit 
depth

Expanded
Representation

Exponential 
Representation

Possible
Colors

1 2 21 2

2 2 × 2 22 4

3 2 × 2 × 2 23

4 2 × 2 × 2 × 2 24

5 2 × 2 × 2 × 2 × 2 25

6 2 × 2 × 2 × 2 × 2 × 2 26

7 2 × 2 × 2 × 2 × 2 × 2 × 2 27

8 2 × 2 × 2 × 2 × 2 × 2 × 2 × 2 28

 4. Based on the table, what is the maximum number of colors that the 
Sue (4-bit).tif image can contain?Sue (4-bit).tif image can contain?Sue (4-bit).tif

 Activate the Sue (4-bit).tif image, and choose Sue (4-bit).tif image, and choose Sue (4-bit).tif Analyze > 
Histogram.

 5. According to its histogram, how many different pixel values, or colors, 
does the 4-bit image contain? (Count the number of lines, or “spikes,” 
in the histogram. Don’t forget to count the spikes at each end of the 
histogram.)

 Close the 4-bit histogram window. Activate and create a 
histogram of each of the other bit depth images. Examine each 
histogram briefl y before closing it.

 Close all the histogram and image windows.

 Re-open the Sue (1-bit).tif image, and open the Sue (1-bit).tif image, and open the Sue (1-bit).tif Sue (1-bit) 
dithered.tif image.dithered.tif image.dithered.tif

 Activate and create a histogram of each image.

According to the histograms, both images contain only black and white 
pixels, yet they look very different—the dithered image looks somewhat 
more realistic. Dithering is a process that arranges pixels of the available Dithering is a process that arranges pixels of the available Dithering
colors in patterns to create the illusion of smoother or additional colors. For 
example, alternating black and white pixels appear as a medium gray.

 Close all the histogram and image windows.

Image types
ImageJ can open, save, and convert between fi ve different types of images. 
In this section, you will examine and compare these image types. These 
types are defi ned by bit depth and whether they are color or grayscale 
images. In addition to comparing the images’ appearance and pixel values, 
you will examine the amount of memory ImageJ uses to hold each type of 
image.

TIFF images in ImageJ
Technically, TIFF (.tif ) images can 
have almost any bit depth. Like most 
software, however, ImageJ only 
supports certain standard depths: 
1-bit, 8-bit, 16-bit, 32-bit, 8-bit RGB, 
and 16-bit RGB images.

In the Sue images, the bit depths 
are simulated—each is actually an 
8-bit TIFF image containing a limited 
number of colors.

ImageJ and dithering
ImageJ does not produce dithered 
images because it is a scientifi c tool, 
and dithering is an artistic technique 
for producing “prettier” images from 
a limited number of colors.

The image used here was produced 
by GraphicConverter, a shareware 
image processing application for 
Macintosh computers.
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Like most other graphic applications, ImageJ stores and processes image 
data in groups of 8 bits, called bytes, abbreviated B. Depending on the 
type of image, pixel values are stored as 1, 2, 3, 4, or 6 bytes. Obviously, the 
number of bytes per pixel infl uences both the amount of working memory 
and the amount of storage required for the image data. The table below 
shows the number of possible pixel values for each image type.

Bytes
per pixel

Bits
per pixel

Number of possible 
pixel values

Range of pixel 
values

1 1 × 8 = 8 28 = 256 0–255

2 2 × 8 = 16 216 = 65,536 0–65535

3 3 × 8 = 24 224 = 16.7 million
Stay tuned to see 
how these work!4 4 × 8 = 32 232 = 4.3 billion*

6 6 × 8 = 48 248 = 281 trillion!

Memory is usually measured in kilobytes or megabytes (or sometimes in 
gigabytes). The prefi x kilo- usually means “one thousand,” but since we’re 
working in binary numbers, kilo- represents 210 or 1024. Mega- (millions) 
means 220 and giga- (billions) means 230.

So, to convert from bytes to kilobytes, from kilobytes to megabytes, or from 
megabytes to gigabytes, divide by 1024.

8-bit images
 In the Bit Depth (types) folder, open the Balloon 8-bit.tif

image.

 Move your cursor over the image, and watch the changing pixel 
value in the ImageJ window status bar. Notice that the pixel values 
are all within the range of 0–255.

8-bit images are grayscale images that use one byte per pixel. To calculate 
the size of the image, multiply the number of pixels by 1 byte per pixel. 
The number of pixels in an image is found by multiplying the width by the 
height of the image, both in pixels (abbreviated px).

Width × Height × Bit Depth / 1024 = Memory Required (KB)

420 px × 600 px × 1 B/px ÷ 1024 = 246 KB

The amount of memory required for each image is the last value displayed 
in the status bar of each image window. The memory size is also listed after 
the image name at the bottom of the Window menu.

 6. According to the image window status bar, what is the size of the 
Balloon 8-bit.tif image, in kilobytes (K)? How well does this match Balloon 8-bit.tif image, in kilobytes (K)? How well does this match Balloon 8-bit.tif
your calculated value?

 Close the Balloon 8-bit.tif image.Balloon 8-bit.tif image.Balloon 8-bit.tif

16-bit images
 Open the Balloon 16-bit.tif image.Balloon 16-bit.tif image.Balloon 16-bit.tif

This grayscale image of the balloon stores 16 bits or 2 bytes for each pixel. 
Move your cursor over the image and watch the ImageJ status bar to see 
that the pixel values are all between 0 and 65535.

 7. This image has the same width and height as the 8-bit version. Without 
peeking, predict how much memory you think this image will occupy.

* 32-bit images
In ImageJ, 32-bit grayscale images 
are also called fl oating point images. fl oating point images. fl oating point
Floating point values are decimal 
approximations of real numbers and 
range from 3.402 × 1038 to -1.175 
× 1037, a truly astonishing range of 
possible values, and well beyond the 
4.3 billion stated in the table!

“32-bit fl oat” images are particularly 
valuable in scientifi c applications 
because they can store a wide range 
of measurements with little or no 
loss of information.
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 8. Compare your prediction with the actual memory size reported in the 
image window.

 Close the Balloon 16-bit.tif image.Balloon 16-bit.tif image.Balloon 16-bit.tif

32-bit images
 Open the Balloon 32-bit.tif image.Balloon 32-bit.tif image.Balloon 32-bit.tif

This image type uses 4 bytes per pixel and has the same width and height 
as the previous two images.

 9. Predict the size, in kilobytes, of this image, then compare it to the 
actual memory size reported in the image window.

 Close the Balloon 32-bit.tif image.Balloon 32-bit.tif image.Balloon 32-bit.tif

 Open the Cygnus A 32-bit.tif image.Cygnus A 32-bit.tif image.Cygnus A 32-bit.tif

This image was produced from data collected by a radiotelescope—a large 
antenna designed to receive radio signals from objects in space. The object 
shown in this image is a powerful radio galaxy named Cygnus A, located in 
the constellation Cygnus (the swan). The two light blobs at the edges of the 
image are jets of material being ejected from the galaxy.

 Move your cursor over the Cygnus A 32-bit.tif image, and note Cygnus A 32-bit.tif image, and note Cygnus A 32-bit.tif
the pixel values.

In 32-bit grayscale images, the value of each pixel is represented by a 
32-bit fl oating point number (see sidebar at right). The pixel values are 32-bit fl oating point number (see sidebar at right). The pixel values are 32-bit fl oating point
real numbers representing the strength of the radio signal in units called 
Janskys, after Karl Jansky, the father of radioastronomy.

 Choose Image > Adjust > Window/Level, and click the Auto button 
in the W&L panel. Close the W&L panel.

The image’s lookup table is now spread over the range of values in the 
image, revealing detail in the two gas jets as well as their source, the 
compact bright object in the center. You can also apply a false-color lookup 
table to make these features easier to see (or just more attractive to look at).

 Choose Image > Lookup Tables > Fire.

 10. What is an advantage of 32-bit fl oating point image data?

 Close the Cygnus A 32-bit.tif image.Cygnus A 32-bit.tif image.Cygnus A 32-bit.tif

8-bit RGB color images
So far, you have been looking at grayscale images. These images have 
only one color channel, which represents brightness or some other 
measurement. In ImageJ, color images have three separate color channels, 
one for each of the three primary colors of light—Red, Green, and 
Blue (RGB). The color of each pixel in the image is determined by the 
combination of these three color channels.

 Open the Balloon RGB color.tif image.Balloon RGB color.tif image.Balloon RGB color.tif

In 8-bit RGB color images, each channel has 8 bits (one byte) per pixel in 
each channel. Since there are three channels, it takes a total of three bytes 
(24 bits) to describe each pixel.

 Move your cursor around the image, and note the changing pixel 
values in the ImageJ window.

Why do the 8-, 16-, and 
32-bit images all look 
the same?
Since your eye can only diff erentiate 
between about 200 diff erent shades 
of gray, it would be pointless to try 
to display more than 256 diff erent 
grays. All three types of images 
use a 256-color lookup table. With 
8-bit images, each diff erent value 
has a unique color. With 16- and 
32-bit images, each diff erent color 
represents a range of pixel values.

The advantages of greater bit depth 
come not from the appearance of 
the image, but from the increased 
scientifi c and analytical value of the 
data.

32-bit fl oating point
Most image types used by 
ImageJ contain integer pixel 
values—positive and negative 
whole numbers. In 32-bit grayscale 
images, pixel values are fl oating 
point numbers —decimal values that point numbers —decimal values that point
represent real numbers.

The advantage of fl oating point 
notation is that pixel values can 
range from very large numbers to 
very small numbers (both positive 
and negative), including fractions.

The 32 bits are assigned as follows:

 bit(s) meaning

 1 sign

 2-8 exponent

 9-32 signifi cand

You may be familiar with scientifi c 
notation, which represents the 
value 74,089.5 as 7.40895 × 104. 
32-bit fl oating point notation is 
simply binary scientifi c notation. binary scientifi c notation. binary
The signifi cand, like the mantissa 
in scientifi c notation, contains the 
6 or 7 most signifi cant digits of the 
number, in binary format.

The range of possible values for 
32-bit fl oating point images is very 
impressive:

 Largest ~3.4 × 1038

 Smallest ~1.18 × 10-38
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The ImageJ status bar lists three separate values for each pixel —a red, 
green, and a blue channel value, in that order.

 11. Assuming that this image has the same width and height as the other 
balloon images, predict its size, in kilobytes. Compare your prediction 
with the actual memory size reported in the image window.

This time, your prediction was probably wrong. This is because ImageJ 
works with RGB pixels as 32-bit integer data. Each pixel requires one byte 
for each color channel, plus one unused byte—a total of four 8-bit bytes 
per pixel. The fourth byte is called the alpha channel, which is not used 
by ImageJ. Other image processing software uses the alpha channel for 
masking or transparency information when blending two or more images. 
ImageJ discards the alpha channel when it saves the image data, so the 
saved RGB fi le is smaller than the same fi le when it is open.

16-bit RGB color images
 Open the Balloon RGB stack.tif image.Balloon RGB stack.tif image.Balloon RGB stack.tif

Some digital cameras and scanners can produce RGB color images with 
16 bits (2 bytes) per channel, for a total of 48 bits of data per pixel. Most 
computers and monitors are unable to display images with this bit depth, 
so ImageJ opens them as stacks consisting of three 16-bit grayscale color 
channels. In ImageJ, you can process one or all three slices of the stack to 
analyze or modify the image data. 

 Examine the three color channels by dragging the slider at the 
bottom of the stack window, and observe the slice counter in the 
window status bar.

 Move your cursor over the image, and watch the ImageJ window 
status bar to convince yourself that the pixel values in each 
channel are 16-bit values. Although you don’t see colors, all the 
data are there, available for analysis.

The width and height of this image are the same as for the other balloon 
images, but now each pixel requires three channels with two bytes per 
channel —a total of six bytes or 48 bits per pixel. 

 12. Calculate the total amount of memory required for this image, in 
megabytes. (To convert from kilobytes to megabytes, you must divide 
the size in kilobytes by 1024!) Compare your prediction to the actual 
memory size reported in the image window status bar.

 Convert the 16-bit RGB image to an 8-bit RGB color image by 
choosing Image > Color > Convert Stack to RGB.

Note that the memory used by this 8-bit RGB color image is the same as the 
one you opened earlier.

8-bit color images
It is possible to convert an 8-bit RGB image to an 8-bit color image without 
separate color channels. To display such an image, ImageJ must create 
a custom lookup table containing 256 colors used to “paint” the image. 
ImageJ then sets the value of each pixel so that it references or indexes the 
appropriate color from the lookup table for that location in the image. For 
this reason, 8-bit color images are also called indexed color images.indexed color images.indexed color

 To convert the 8-bit RGB image to an 8-bit indexed color image, 
choose Image > Type > 8-bit Color.

TRILLIONS of colors!
Though not infi nite, the number of 
available colors in 48-bit images is 
astonishing.

216 × 216 × 216 = 281 trillion colors!

Even commercial applications such 
as Adobe Photoshop do not display 
the full 48-bit color depth on screen. 
The images are displayed in 24-bit 
color, but all processing is done on 
the 48-bit pixel data. 

Open versus saved
image sizes
When calculating image sizes, the 
size of the open image (in kilobytes) 
can be calculated as:

width (px) × height (px)
× bit depth × number of channels

/ 1024 bytes/kilobyte

When you save an image, however, 
the image fi le will often be a 
diff erent size than the open image. 
This is due to several factors:

 • Some image formats use coding 
and compression techniques to 
reduce the size of the fi le.

 • When a computer saves a fi le to 
certain storage media, data are 
written in chunks of a specifi c 
size, called sectors. The image 
data may not fi t exactly into a 
whole number of sectors, so the 
last sector may contain unused 
space that adds to the fi le size.

 • Some image fi le formats save 
additional data in the fi le along 
with the actual image data—
tags, headers, metadata, etc.
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 13. What happens to the quality of the image when you convert it to 
indexed color? In which part(s) of the image are the colors most poorly 
reproduced?

As explained earlier, ImageJ does not use dithering to create smoother-
looking colors at lower bit depths. Here is another example.

 Open the Balloon 8-bit color.tif image.Balloon 8-bit color.tif image.Balloon 8-bit color.tif

This 8-bit indexed color version of the image was produced using software 
that uses dithering to increase the apparent number of colors in the image.

 14. In general, what happens to amount of memory required for an image 
as the bit depth increases?

 Close all the open image windows.

Spatial resolution
Spatial resolution refers to the number of measurements, or samples, per 
unit width or length of an image. Spatial resolution is usually expressed 
in dots per inch (dpi) or pixels per inch (ppi). For example, current fl atbed 
scanners sample, or measure, the light refl ected from the original material 
up to 2400 dpi or even higher. Let’s compare images of a photo scanned at 
different resolutions.

 Open the fi ve images in the Spatial Resolution folder.

 Without changing the sizes of the windows, arrange the images so 
you can see them all at the same time.

These images were scanned at 8-bit grayscale pixel depth and spatial 
resolutions ranging from 38 to 600 dpi. Each  image has roughly twice the 
resolution of the previous image.

 15. What happens to the size of an image as its resolution increases?

 16. What are the dimensions of the 300-dpi image?

 17. Calculate how much memory this image would require. Remember, 
memory size equals:

Width (px) x Height (px) x Bit depth (bytes/px) x Color Channels
1024 bytes/kilobyte

 The memory occupied by each image is displayed at the bottom 
of the Window menu, as well as on the status bar of each image 
window.

 18. What happens to the memory size of the image as you double the 
spatial resolution?

 19. Predict the size of this image if you increased the resolution to 1200 
dpi.

When saving an image, the spatial resolution of the image affects its fi le 
size, so you must think about how you will be storing and transporting 
your image. If you want to e-mail an image to a friend who has a slow 
modem connection, then you want as small a fi le size as possible. If you are 
sending the image on a CD-ROM, then the image can be quite large.

 Use  to magnify or reduce the images until they are the same  to magnify or reduce the images until they are the same 
size as the 300 dpi image. (Hold down the Alt or Alt or Alt Option key to 
reduce the 600-dpi image to 50% scale.)
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 Choose Window > Tile to tile the images so you can see them all at 
the same time.

 Hold down the Shift key, and use Shift key, and use Shift  to click on each image until  to click on each image until 
the girl’s face fi lls the window. (For the 300 dpi image, this would 
be at a scale of 400%, as displayed on the image window title bar. 
Holding down the Shift key prevents the window from changing Shift key prevents the window from changing Shift
size while you zoom.)

 20. How do the details in the image change as the resolution in creas es?

An important constraint to spatial resolution is fi le size. Higher resolution 
provides more detail, but with it comes increasing fi le size. In fact, you have 
seen that the fi le size increases as the square of the increase in resolution. 
Thus, if you double the resolution, the fi le size increases to four times its four times its four
original size.

 21. If you scan an image at 100 dpi and the fi le size is 50K, what will the fi le 
size be if you increase the scan resolution to 300 dpi?

If you are creating a series of images to use in a stack, you may want to 
choose lower resolutions to keep the overall stack size small.

Resolution for display and printing
In addition to considering the input resolution (from a scanner or camera), 
it is also important to consider the resolution of the output device. For 
instance, if you want an image displayed on-screen to be roughly the same 
size as the original pho to graph, then you will need to scan the image at the 
same spatial resolution as the monitor. If a monitor displays 100 pixels per 
inch, an image scanned at 100 dpi will appear approximately life-size when 
displayed on that monitor at 100% magnifi cation.

Printing images is considerably more confusing because printers usually 
state their resolution in dots per inch, but printing quality is actually related 
to a different measure related to the printing device, lines per inch (lpi).

For example, a “high resolution” 1440-dpi inkjet printer prints with a 
resolution of only about 240–300 lpi. A good rule of thumb for determining 
the ideal image resolution is:

dpi = 1.5 × lpi

Thus, a scanned image with a resolution of 360 to 450 dpi would be more 
than suffi cient to print at highest quality on this printer. Any additional 
resolution will be ignored by the printer, and will slow down the printing 
process.

 22. Using the output device resolution table at right, what would be the 
ideal image resolution for printing on a 600-dpi laser printer?

 Close all the open images.

LPI values for common 
output devices
Printer or Output LPI

Laser printer, 300 dpi 53–60

Laser printer, 600 dpi 60–106

Newspaper 65–100

Book (uncoated paper) 120–133

Book (coated paper) 133–150

Color Magazine 150–175

Art Book and Magazine 175–250

Dye Sublimation Printer 206–400

360 dpi Color Inkjet 150

720 dpi Color Inkjet 240–300

1440 dpi Color Inkjet 240–300
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Image fi le formats
When images are in your computer’s memory and are displayed on a 
screen, they are all basically the same, regardless of where they came 
from—they differ only in height, width, and bit depth (and, of course, 
content). More signifi cant differences are introduced when you save the 
image data to a fi le on a hard drive, CD-ROM, DVD, fl oppy disk, or other 
storage medium. When you save image data, it is stored according to a set 
of rules describing how the information is organized and encoded. These 
standardized sets of rules for storing data are called fi le formats.

ImageJ native formats
ImageJ can open and save images in most common image fi le formats: 
TIFF (uncompressed), GIF, JPEG, and BMP, as well as the FITS and DICOM 
formats used by the science community. Free plug-ins can be installed that 
allow ImageJ to open and save images in other familiar formats, including 
Photoshop, PNG, PICT, and PCX, as well as QuickTime® and AVI movie 
formats. (See What’s in a name? at right for more about these formats.)What’s in a name? at right for more about these formats.)What’s in a name?

Comparing standard formats—TIFF, GIF, and JPEG
The TIFF format is very versatile and can be read by most graphic and 
image processing applications. TIFF fi les can contain single or multiple 
images of a wide range of bit depths. A key feature of the TIFF format is 
that the fi le can include a variety of tags that record related information 
such as the spatial scale, time, and geographic location of the image.

 Open the Image Formats folder, then the Comparing Formats
folder, and open the Scene RGB color.tif image.Scene RGB color.tif image.Scene RGB color.tif

The disadvantage of the TIFF format is that the fi les tend to be large 
compared to other formats.

 23. Read the memory size of this image from the image window status bar, 
and record it in Table 1 on your Data Sheet.

Scientifi cally, TIFF fi les are superior because they are lossless—that is, they 
preserve all the original image data. The TIFF format specifi cation allows 
for various forms of compression to produce smaller fi les, but ImageJ 
cannot read or write compressed TIFF fi les. (See Compressed TIFF fi les, at Compressed TIFF fi les, at Compressed TIFF fi les
right, for more on this topic.)

You can, however, save TIFF fi les using lossless ZIP compression by 
choosing File > Save As… > ZIP…. The size of a zipped fi le depends on the 
content of the image with simpler images compressing more than complex 
images. This image occupies only 680 KB of storage as a ZIP-compressed fi le.

 Open the Scene RGB color.zip fi le.

 24. Read the memory size of this image from the image window status bar, 
and record it in Table 1 on your Data Sheet. Compare the quality of the 
image to the original image, and record the quality in the appropriate 
column of the table. See Image quality descriptions at right.Image quality descriptions at right.Image quality descriptions

 Open the Scene 8-bit color.tif fi le.Scene 8-bit color.tif fi le.Scene 8-bit color.tif

This is also a TIFF format image, but each pixel requires only one byte, so 
the saved image requires less space, at 240 KB. It looks very close to the 
original fi le, but the quality is reduced slightly—zoom in on the mushrooms 
and compare the enlarged image with the original.

Compressed TIFF fi les
TIFF fi les can be compressed to 
take up less storage space. This can 
be done using several methods, 
but most require licensing of 
software routines that add to the 
cost of the software. Since ImageJ 
is public domain software, there 
is no practical way to include the 
compression/decompression 
routines in the program needed to 
handle compressed TIFF fi les.

If you receive compressed TIFF fi les 
that you want to use with ImageJ, 
you may be able to open and 
re-save them as uncompressed 
TIFF fi les using commercial image 
viewing or editing software such as 
Adobe Photoshop.

What’s in a name?
Here are defi nitions of some of the 
common image format names that 
ImageJ supports:

AVI = Audio-Video Interleaved

BMP = Windows Bitmap

DICOM = Digital Imaging and 
COmmunications in Medicine

PNG = Portable Network Graphic

FITS = Flexible Information 
Transport System

GIF = Graphic Interchange Format

JPEG = Joint Photography Experts 
Group format (also called JFIF).

PCX = PC Paintbrush Exchange

PICT = Macintosh picture format

TIFF = Tagged Image File Format

Image quality
descriptions
Use the following key to determine 
the image quality description to 
record in the table on your answer 
sheet:

 • High - Image is identical or 
nearly identical in quality to the 
original.

 • Medium - Image looks OK but 
diff erences are noticeable if you 
look closely.

 • Low - Image looks terrible with 
too few colors and/or serious 
compression artifacts.
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 Close all the image windows except for one copy of the Scene 
RGB color.tif image (the original image).RGB color.tif image (the original image).RGB color.tif

 25. Record the memory size and quality of this image on your Data Sheet.

JPEG format is a lossy format that is often used for compressing images lossy format that is often used for compressing images lossy
for Web pages and e-mail to reduce the time required to transmit the data. 
The compression, or quality, setting can range from 0 (lowest quality) to 100 
(highest quality). JPEG compression attempts to preserve the appearance 
of the image but changes the pixel values in the process.

 Open Scene Quality 100.jpg, Scene Quality 50.jpg, and 
Scene Quality 10.jpg, and examine them carefully.

As you increase the compression level (decrease the quality), you can see 
more compression artifacts, particularly at the edges of objects.

 26. Record the memory size and quality of each of the three JPEG images 
in the table on your Data Sheet.

 Close the three Scene Quality images.Scene Quality images.Scene Quality

GIF format is also used to create small fi les for use on Web pages and e-
mail attachments.

 Open Scene 256 colors.gif and Scene 256 colors.gif and Scene 256 colors.gif Scene 12 colors.gif, and 
examine them carefully.

 27. Record the memory size and quality of the two GIF images in the table 
on your Data Sheet.

 Close all the open image windows.

Before you decide which image format is “best,” let’s look at an image with 
very different content and saved in each format we have just explored.

 Open the Graphic RGB color.tif fi le.Graphic RGB color.tif fi le.Graphic RGB color.tif

This image will be our original fi le. Keep it open as you examine and record 
information about the other Graphic fi les.

 Open the other 7 Graphic image fi les. Examine each image 
carefully as you open it.

 28. Record the memory size and quality of each image fi le in the table on 
your Data Sheet.

 Close all the open image windows.

More about JPEG Compression
 In the JPEG folder, open all the images in the Flowers folder.

These images were saved with JPEG quality settings ranging from 100 
(highest quality) to 0 (lowest quality). The quality setting is included in the 
fi le name of each image.

 29. For this scene, what is the minimum quality level that you think 
produces a “high quality” image?

 Close all the Flowers images, then open all the images in the 
Wheels folder.

 30. Do you think JPEG is a good format for this type of image? Why?

 Close all the Wheels images.

JPEG Quality
In ImageJ, you can set the JPEG 
Quality setting to any value from 0 
to 100 by choosing Edit > Options 
> JPEG Quality….



120 Discovering Image Processing
©2006 The Center for Image Processing in Education and 

portions ©1998 Arizona Board of Regents.
Limited classroom reproduction rights are granted earlier in this work.

More about GIF images
 In the GIF folder, open the Flowers folder, then open all the 

images in the Dithered folder.

These images were saved in GIF format with a specifi c number of colors, 
ranging from 256 (most colors) to 2 (fewest colors). The number of colors is 
included in the fi le name of each image. ImageJ does not produce dithered 
GIF images, so these were created using Adobe Photoshop.

 Tile the images, and compare them.

 31. For this scene, what is the minimum quality level that you think 
produces a “high quality” image?

 Close all the fl ower images, then open all the images in the Not 
Dithered folder.

These images were saved using ImageJ by converting the original RGB 
Color image to 8-bit color, using the specifi ed number of colors.

 32. What do you think about using GIF format for this type of scene?

Choosing image formats
The key to choosing the “right” fi le format is knowing what you plan to do 
with the image. Most often, the option for choosing the fi le format comes 
when the digitizing software prompts you to save the image. You can change 
the bit depth or convert between color and grayscale in ImageJ by choosing 
Image > Type, or change the fi le format by using the Save As… option.

Use the table of data you recorded on your Data Sheet to answer the 
following questions about image formats. Feel free to open and re-examine 
any of the image fi les to help you answer the questions.

 33. Does the memory size of an open image depend on the fi le format the 
image was saved in? If not, explain what does determine the memory 
size of an open image.

 34. Which image format saves a graphic image in the smallest fi le without 
sacrifi cing image quality?

 35. Which image format saves a continuous tone (“scenic”) image in the 
smallest fi le without sacrifi cing image quality?

 36. If you wanted to scan some plant leaves on your scanner to measure 
area and brightness differences, what fi le format would you want to 
use? Explain why you chose this format.

 37. If you wanted to save a labeled diagram consisting of lines, shapes, 
and text that you created in ImageJ to put on a Web page, which fi le 
format would you use? Explain why you chose this format.

 38. If you needed to add an image taken of the plant that the leaves came 
from to the same Web page, which fi le format would you use? Explain 
why you chose this format.

 39. If you don’t ever intend to measure pixel values in an image, what 
would be the advantage of saving the image in JPEG format?

 40. If storage space is not an issue, what bit depth, spatial resolution, and 
fi le format would you choose for saving an image fi le for later use? 
Explain why you chose these specifi cations.

On your own
 • Use a scanner to digitize 

a photograph at varying 
resolutions, and compare the 
quality. Scan an image at 150 
dpi and 300 dpi, then scale the 
300 dpi image by a factor of 0.5 
(50%) and compare it to the 150 
dpi image. Is there a diff erence?

 • Convert 24-bit RGB color images 
taken with a digital camera 
to 8-bit color format. Magnify 
and compare the images. Try 
sharpening the images or 
reducing noise.

 • The Formats folder includes 
folders containing DICOM and 
FITS images. Open several of 
these images using ImageJ, then 
choose Image > Show Info…. 
These image formats include 
headers, which provide a wealth 
of information about the images.

 • ImageJ provides limited support 
for digitizing video from 
cameras, VCRs, DVDs, etc. Refer 
to the ImageJ Web site and 
documentation for additional 
information.

Dithering defi ned
Dithering is a  method of 
simulating  colors or shades of gray 
that aren’t in the image by altering 
the values of adjacent pixels to 
give the illusion of an intermediate 
color. 
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 1. Describe how the appearance of the image changes as the bit depth decreases from 8 bits to 1 bit.

 2. At what bit depth does the image quality begin to degrade noticeably?

 3. Complete the table showing the number of possible colors that correspond to the following bit depths.

Bit 
depth

Expanded
Representation

Exponential 
Representation

Possible
Colors

1 2 21 2

2 2 × 2 22 4

3 2 × 2 × 2 23

4 2 × 2 × 2 × 2 24

5 2 × 2 × 2 × 2 × 2 25

6 2 × 2 × 2 × 2 × 2 × 2 26

7 2 × 2 × 2 × 2 × 2 × 2 × 2 27

8 2 × 2 × 2 × 2 × 2 × 2 × 2 × 2 28

 4. Based on the table, what is the maximum number of colors that the Sue (4-bit).tif image can contain?Sue (4-bit).tif image can contain?Sue (4-bit).tif

 5. According to its histogram, how many different pixel values, or colors, does the 4-bit image contain? 
(Count the number of lines, or “spikes,” in the histogram. Don’t forget to count the spikes at each end of 
the histogram.

 6. According to the image window status bar, what is the size of the Balloon 8-bit.tif image, in kilobytes Balloon 8-bit.tif image, in kilobytes Balloon 8-bit.tif
(K)? How well does this match your calculated value?

 7. This image has the same width and height as the 8-bit version. Without peeking, predict how much 
memory you think this image will occupy.

Data
SheetDigitizing Details

Name(s)   ______________________________ Class  _________   Date  __________________
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 8. Compare your prediction with the actual memory size reported in the image window.

 9. Predict the size, in kilobytes, of this image, then compare it to the actual memory size reported in the 
image window.

 10. What is an advantage of 32-bit fl oating point image data?

 11. Assuming that this image has the same width and height as the other balloon images, predict its size in 
kilobytes. Compare your prediction with the actual memory size reported in the image window.

 12. Calculate the total amount of memory required for this image in megabytes. (To convert from kilobytes 
to megabytes, you must divide the size in kilobytes by 1024!) Compare your prediction to the actual 
memory size reported in the image window status bar.

 13. What happens to the quality of the image when you convert it to indexed color? In which part(s) of the 
image are the colors most poorly reproduced?

 14. In general, what happens to amount of memory required for an image as the bit depth increases?

 15. What happens to the size of an image as its resolution increases?

 16. What are the dimensions of the 300 dpi image?

 17. Calculate how much memory this image would require. Remember, memory size equals:
Width (px) x Height (px) x Bit depth (bytes/px) x Color Channels

1024 bytes/kilobyte

 18. What happens to the memory size of the image as you double the spatial resolution?
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 19. Predict the size of this image if you increased the resolution to 1200 dpi.

 20. How do the details in the image change as the resolution in creas es?

 21. If you scan an image at 100 dpi and the fi le size is 50K, what will the fi le size be if you increase the scan 
resolution to 300 dpi?

 22. Using the output device resolution table, what would be the ideal image resolution for printing on a 600 
dpi laser printer?

 23–28.

Image Name Open Size
(KB)

Saved Size 
(KB)

Quality
(High / Medium / Low)

Scene RGB Color.tif 712 KB

Scene RGB Color.zip 680 KB

Scene 8-bit Color.tif 240 KB

Scene 256 Colors.gif 256 KB

Scene 12 Colors.gif 84 KB

Scene Quality 100.jpg 328 KB

Scene Quality 50.jpg 56 KB

Scene Quality 10.jpg 20 KB

Graphic RGB Color.tif 712 KB

Graphic RGB Color.zip 8 KB

Graphic 8-bit Color.tif 240 KB

Graphic 256 Colors.gif 8 KB

Graphic 12 Colors.gif 4 KB

Graphic Quality 100.jpg 36 KB

Graphic Quality 50.jpg 12 KB

Graphic Quality 10.jpg 8 KB

 29. For this scene, what is the minimum quality level that you think produces a “high quality” image?

 30. Do you think JPEG is an appropriate format for this type of image? Explain your answer.

 31. For this scene, what is the minimum quality level that you think produces a “high quality” image?

 32. What do you think about using GIF format for this type of scene?
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 33. Does the memory size of an open image depend on the fi le format the 
image was saved in? If not, explain what does determine the memory 
size of an open image.

 34. Which image format saves a graphic image in the smallest fi le without 
sacrifi cing image quality?

 35. Which image format saves a continuous tone (“scenic”) image in the 
smallest fi le without sacrifi cing image quality?

 36. If you wanted to scan some plant leaves on your scanner to measure 
area and brightness differences, what fi le format would you want to 
use? Explain why you chose this format.

 37. If you wanted to save a labeled diagram consisting of lines, shapes, 
and text that you created in ImageJ to put on a Web page, which fi le 
format would you use? Explain why you chose this format.

 38. If you needed to add an image taken of the plant that the leaves came 
from to the same Web page, which fi le format would you use? Explain 
why you chose this format.

 39. If you don’t ever intend to measure pixel values in an image, what 
would be the advantage of saving the image in JPEG format?

 40. If storage space is not an issue, what bit depth, spatial resolution, and 
fi le format would you choose for saving an image fi le for later use? 
Explain why you chose these specifi cations.
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Picture Yourself
Editing digital images

Teaching
Notes

Overview
Students picture themselves or others as stand-ins for famous people. They 
are guided through the techniques of measuring, scaling, cutting, and 
pasting as they create a “stand-in” for the Statue of Liberty. Because the 
stand-in is a different size than the statue, students must measure and scale 
the image to fi t. Other backgrounds are provided for additional practice of 
these techniques.

Objectives
Students will:

 • manipulate look-up tables to combine images

 • use scaling, cutting, and pasting to create personal career portraits

Related Activities
 • See “Digitizing Details” for information on scanning images.

 • Refer to “Photo Effects” for more advanced cutting and pasting 
techniques.

Career Links
Advertisers and publishers often paste people into outrageous settings to 
gain our attention or sway us to buy their products. Getting us to imagine 
driving that new car or wearing that new outfi t can be a very persuasive 
marketing tactic.

Troubleshooting Tips
Combining images with different lookup tables can present problems. 
Converting all the images to RGB color is an effective technique for solving 
this problem.

When images are digitized using a scanner, the scanning software may 
automatically apply a scale to the image. To remove this scale, choose 
Analyze > Set Scale... command, and enter pixels for the units.

If students have diffi culty tracing the outline of the girl in the Stand-in.tif
image, they can load a saved selection by choosing File > Open… > girl.roi. 
The Statue folder also contains saved selections for the torch and crown. 
These selections will only fi t if the Stand-in.tif image is scaled by a factor Stand-in.tif image is scaled by a factor Stand-in.tif
of 0.42.

Goal
Students scale, cut, and paste 
images of themselves into scenes 
to help them understand image 
editing and scaling.

IP Skills
 •  Converting image types

 • Measuring

 •  Scaling images

 •  Using selection tools

 •  Cutting and pasting

ImageJ Skill Sheets
 •  Cutting & Pasting

 •  Drawing & Text

 •  Selecting

 • Measuring

Vocabulary 
 •  lookup table 

 •  scaling factor

Teaching
Notes
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Answers
 1. The statue image is calibrated in pixels.

 2. The image of the girl is calibrated in inches.

 3. The statue is 156 pixels tall from the bottoms of the feet to the nose.

 4. The girl is 374 pixels tall from the bottoms of her feet to her nose.

 5. The scaling ratio is 156 ÷ 374 = 0.42.

 6. A scaling factor greater than one would enlarge the image.

 7. The Statue.tif image is an 8-bit color image.Statue.tif image is an 8-bit color image.Statue.tif

 8. The stand-in image is an RGB (color) image.

 9. You need to convert the Statue.tif image to RGB color.Statue.tif image to RGB color.Statue.tif

 10. Answers will vary but may include (not necessarily in order):

 a. change measurement units

 b. change image types

 c. measure heads

 d. scale image(s)

 e. fl ip or rotate heads

 f. select area to copy

 g. copy, paste, and position.

 h. touch up edges
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Picture Yourself
Editing digital images

Lesson

When you combine digital images to make composite pictures, the original 
images are often at different scales and image types. These differences 
provide challenges that are easy to overcome, if you understand the image 
processing tools you are using.

Standing in for Lady Liberty
The Statue of Liberty has been holding that torch aloft since 1886, and she 
needs a short vacation.

 Launch ImageJ, locate the Statue folder inside 07 Picture 
Yourself, and open the Yourself, and open the Yourself Statue.tif image.Statue.tif image.Statue.tif

The statue and its base are shown on the left. In the image on the right, the 
statue has been digitally erased by replacing the statue’s pixels with pixels 
from the sky.

 Open the Stand-in.tif image.Stand-in.tif image.Stand-in.tif

Scaling images
Your fi rst task will be to scale the image of the girl (the target) so that she is 
the same height as the statue (the source). The scaling factor is calculated 
using the following formula:

Before you measure the images, you need to make sure they are calibrated 
in the same units of length.

 1. According to the image window status bar, what units of length are 
used for the statue image?

 2. What units of length are used for the image of the girl?

Scanners and digital cameras often automatically calibrate images in inches 
for printing, and this is the case with the stand-in image. You will need to 
change the units of the image to match those of the statue image.

 Activate the Stand-in.tif image, choose Stand-in.tif image, choose Stand-in.tif Analyze > Set Scale…, 
enter pixels in the Unit of Length fi eld, and click OK.

Measurements for both images will now be given in pixels. Next, you will 
measure the height of the statue and the height of the girl, and use them to 
calculate the scaling factor.

 Activate the Statue.tif image, and use the Straight Line Selection Statue.tif image, and use the Straight Line Selection Statue.tif
tool  to measure the height of the statue. Since the statue  to measure the height of the statue. Since the statue 
is wearing a crown and her stand-in is not, measure from the is wearing a crown and her stand-in is not, measure from the 

Would you like to stand 
in for Lady Liberty?
You, a friend, or a classmate can 
stand in for Lady Liberty too. Scan a 
photograph or take a picture with 
a digital camera to use in place of 
the image of the girl provided in the 
lesson.

Statue trivia
The actual name of the fi gure in 
the Statue of Liberty is Liberty 
enlightening the world.

Read units here

 2. What units of length are used for the image of the girl?

scaling factor = 
length (height) of source
length (height) of target

Read length hereRead length here
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bottom of their feet to the tips of their noses. As you drag the line 
selection, its length is displayed in the ImageJ window status bar. 

 3. What is the height of the statue in pixels?

 Activate the Stand-in.tif image, and repeat this process to Stand-in.tif image, and repeat this process to Stand-in.tif
measure the height of the girl, from the bottom of her feet to the 
tip of her nose.

 4. What is the height of the girl in pixels?

 5. Calculate the scaling ratio for reducing the stand-in to the same height 
as the statue. Round your ratio to two decimal places.

 6. The scaling factor for reducing an image is less than 1. What happens 
to an image if you enter a scaling factor greater than 1?

 Choose Image > Scale…, check the Interpolate and Create New 
Window options, enter the scaling factor you calculated in the X 
Scale and Y Scale fi elds, enter a name for the new window (such 
as Scaled), and click OK.

Selecting the stand-in image
The stand-in is now the correct size to replace the statue, but before you 
can copy and paste her onto the empty pedestal you need to select just the 
stand-in and not the background pixels.

 Use the Polygon tool  to trace the outline of the scaled stand-in  to trace the outline of the scaled stand-in 
image, clicking each time the outline changes direction as shown image, clicking each time the outline changes direction as shown 
on the left below. When you return to your starting point, click 
inside the small box to complete the selection.

The selection outline now shows small handles where you clicked to 
change direction.

 If your selection outline missed the edge of the stand-in anywhere, 
you can edit it by dragging the handles to new locations, as 
shown on the right above.

Copying, pasting, and image types
When you are satisfi ed with your selection, you are ready to copy and paste 
the stand-in into position on her pedestal.

 Choose Edit > Copy to copy the image of the girl to the ImageJ 
clipboard.

The selection outline now shows small handles where you clicked to The selection outline now shows small handles where you clicked to The selection outline now shows small handles where you clicked to 
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 Activate the Statue.tif image, and choose Statue.tif image, and choose Statue.tif Edit > Paste to paste the 
girl into the image.

Oops! There’s a problem! When you try to paste the girl, ImageJ tells you 
that the images must be the same type to paste. The image type refers to 
the number of color channels and the number of bits per channel used to 
store the image data.

The image type is shown on each image window’s status bar, to the right of 
the pixel dimensions.

 7. What type of image is Statue.tif?Statue.tif?Statue.tif

 8. What type of image is the stand-in image?

You will need to change the type of one of the images before you can 
copy and paste between them. In most situations, a good rule of thumb 
when copying and pasting between images is to convert all images—even 
grayscale images—to RGB Color.

 9. Which image(s) do you need to convert to RGB Color?

 Activate the image(s) you need to convert, and choose Image > 
Type > RGB Color.

The image window status bar should now show the image type as RGB, 
and you can now paste the girl into the image.

 Activate the Statue.tif image and choose Statue.tif image and choose Statue.tif Edit > Paste to paste the 
girl into the image. Drag the stand-in into place on her pedestal.

Adding the fi nal touches
What is the Statue of Liberty without her torch? You still need to select the 
statue’s torch and copy and paste it into the girl’s hand. (If you have time, 
you may even want to copy and paste the statue’s crown onto the girl’s 
head.)

 Scale, copy, and paste the statue’s torch onto the stand-in.

 You may wish to touch up individual pixels to make the pasted 
areas blend in better with the background. Use the Color Picker areas blend in better with the background. Use the Color Picker 

 to choose colors from the image, and the Pencil tool  to choose colors from the image, and the Pencil tool 
areas blend in better with the background. Use the Color Picker 

 to edit  to edit 
individual pixels using the selected color.individual pixels using the selected color.

More practice
For more practice in combining images, open the images in the Astronaut
folder or the Rushmore folder, and try scaling and pasting the boy’s face 
in place of the face of the astronaut or the president.

 10. Describe the steps you used to replace the astronaut’s or president’s 
head with the boy’s head. See the note at right if you think you need to 
rotate or fl ip the head.

If you’d like more practice, folders of additional images (More 
Backgrounds and Careers) are included in the lesson folder.

Image type

Statue.tif?Statue.tif?Statue.tif

Rotating images
You may need to change the angle 
of an image to make it fi t correctly 
in a chosen background. To rotate 
an image, choose Image > Rotate 
> Arbitrarily, enter the rotation 
angle, check the Interpolate option, 
and click OK. Positive angles rotate 
the image clockwise, and negative 
angles rotate it counterclockwise.

If the head is facing in the wrong 
direction, you can fl ip it by 
choosing Image > Rotate > Flip 
Horizontally.
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Data
Sheet

Picture Yourself
 1. According to the image window status bar, what units of length are 

used for the statue image?

 2. What units of length are used for the image of the girl?

 3. What is the height of the statue in pixels?

 4. What is the height of the girl in pixels?

 5. Calculate the scaling ratio for reducing the stand-in to the same height 
as the statue. Round your ratio to two decimal places. (Hint: Here’s the 
formula:

 6. The scaling factor for reducing an image is less than 1. What happens 
to an image if you enter a scaling factor greater than 1?

 7. What type of image is Statue.tif?Statue.tif?Statue.tif

 8. What type of image is the stand-in image?

 9. Which image(s) do you need to convert to RGB Color?

 10. Describe the steps you used to replace the astronaut’s or President’s 
head with the boy’s head.

Name(s)   ______________________________ Class  _________   Date  __________________

scaling factor = 
length (height) of source
length (height) of target
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Color by Number
Working with color images

Teaching
Notes

Overview
The principles of color reconstruction can be used to create beautifully 
enhanced, aesthetically pleasing images. The same principles can be used 
to create ste reo scop ic images. In addition, you can produce false-color 
images that highlight specifi c image features and aid data interpretation.

In the fi rst section of this lesson, students fi nd out how color images are 
created so they can alter them. The section begins with a short introduction 
to the concepts of grayscale, false-color, and true-color images. Students 
create color composite images from images showing the amount of red, 
green, and blue light refl ected in a scene. Throughout the lesson, stu dents 
explore the nature of color as they construct, deconstruct, and en hance 
color images. In the fi nal section, they create 3-D stereo images by applying 
the prin ci ples of color reconstruction.

Objectives
Students will:

 • compare grayscale, RGB color, and 8-bit color images.

 • interpret the color com po si tion of images

 • create and then separate color composite images

 • create true- and false-color satellite images

 • create 3-D stereo images

Related Activities
 • See “Digitizing Details” for information on scanning color 

photographs.

Career Links
Graphic artists and digital photographers enhance color images using the 
same techniques as demonstrated in this lesson. Plan e tary re search ers 
and cel lu lar bi ol o gists use color re con struc tion to view macroscopic 
and mi cro scop ic fea tures of struc tures imaged at multiple wave lengths. 
By assigning various wavelengths to the red, green, and blue channels, 
different aspects of an image can be highlighted. For instance, vegetation, 
soil, or the nuclei of cells can be made to appear red, green, or blue in a 
false-color reconstructed image.

Goal
Students investigate the theory and 
practice of col or image creation to 
enhance and view true color images, 
as well as build stereo images from 
stereo pairs.

IP Skills
 • Manipulating color images

 • Separating and re con struct ing 
color im ag es

 • Creating 3-D stereo im ag es

ImageJ Skill Sheets
 • Thresholding

 • Lookup Tables

 • Animation & Stacks

Vocabulary
 • true color

 • false color
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Notes
To create your own color images using a black-and-white camera (fi lm, 
digital still, or video camera), use #25 (red), #58 (green), and #47 (dark blue) 
Wratten fi lters. This also works with color video cameras, but you will need 
to convert each image to grayscale before stacking them. Since these fi lters 
have different optical densities, you will need to lighten or darken each 
separate channel by adding or subtracting from the pixel values before 
com bin ing them.

Students can easily create their own stereo images by scanning stereo 
pho to graphs, pasting them into equal-sized windows, registering them 
so that the main subjects line up, stacking the images, and making a color 
com pos ite as described in the lesson. Images can also be created using still 
and motion video cameras.
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Answers
 1. The pixel value represents “how much light” is present.

 2. Answers will vary. For the red pixel, the red value should be highest, 
for the blue pixel the blue value should be highest, etc.

 3. The RGB values for the primary colors are Red = 255,0,0; Green = 
0,255,0; Blue = 0,0,255

 4. 

Mix these
Primary Colors

To get this
Secondary Color

RGB “recipe” of Secondary Color

Red Green Blue

Green + Blue Cyan 0 255 255

Blue + Red Magenta 255 0 255

Red + Green Yellow 255 255 0

 5. White appears when you mix the maximum amount of red, green, and 
blue light. 

 6. Black represents the absence of light. 

 7. Answers will vary. Values should be between 0 and 255.

 8. Answers will vary. Colors should match question 7.

 9. 16,777,216 possible colors (including black and white) can be produced 
by using 8 bits for each of the three color channels.

 10. The “T” is blue, “C” is red, and “I” is green.

 11. Answers will vary.

 12. Colors of RGB color image are much smoother than the 8-bit color 
version.

 13. The image looks terrible; the colors are scrambled.

REDRED

GREENGREEN

BLUEBLUE
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 14. Answers will vary. Example: RGB images have more accurate color 
and can be enhanced but create larger fi les. 8-bit Color images are 
smaller, but colors look worse, and they can’t be enhanced easily.

 15. Vegetation appears bright red in a 4,3,2 false color image.

 16. The image will be all grays.

 17. Answers will vary, should accurately describe results.

 18. The scene jumps from side to side.

 19. The best 3-D image is produced when the right image is assigned 
the red channel, and the left image is assigned the blue and green 
channels. 

 20. 3-D images help scientists visualize things they can’t normally see and 
places they can’t visit.
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Color by Number
Working with color images

Lesson

Reproducing color
Although digital imaging is not new, recent increases in image quality 
and decreased prices are converting more amateur and professional 
photographers from fi lm-based to digital technology. They are fi nding 
that digital images are easier and more economical to store, transmit, 
reproduce, and manipulate than the fi lm-based counterparts.

 Launch ImageJ, locate the 08 Color By Number folder, and open 
Balloon GS.tif.Balloon GS.tif.Balloon GS.tif

This image of a hot air balloon is an 8-bit grayscale image. (Note the “8-
bit” image type shown in the image window status bar, below the image 
window title bar.) This means that each pixel in the image is described by a 
number between 0 and 255, which represents the brightness measurement 
at that location in the scene.

 Move your cursor around on the image and watch the value 
displayed in the ImageJ status bar as you examine light and dark 
areas of the image.

 1. Does the pixel value in ImageJ represent “how much light” (black = 0 
and white = 255) or “how much black” (white = 0 and black = 255)?

 Open the Balloon RGB.tif image.Balloon RGB.tif image.Balloon RGB.tif

According to the image window status bar, the image type is now RGB, 
which stands for Red, Green, and Blue. If you look very closely at your 
color computer screen (with a mag ni fy ing glass or hand lens), you will see 
that the image is made of countless tiny red, green, and blue dots or bars. 
By mixing different amounts of these three colors of light, your com put er 
can create nearly any color of the rainbow.

 Move your cursor around this image and watch the changing 
pixel values in the ImageJ status bar.

Each pixel is now represented by three values instead of one. The RGB 
values are a kind of recipe, showing the amounts of red, green, and blue 
light that are mixed to produce the color of each pixel.

 2. Complete the following table by moving your cursor to any pixel in the 
image of the color shown, then write down that pixel’s red, green, and 
blue values.

Go to a pixel 
of this color

Record its RGB values

Red Green Blue

Red

Green

Blue

Understanding how different colors are formed is called color theory. A 
tool that is often used to help understand color theory is a color wheel.

image type

ImageJ Status Bar
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 Close the balloon images, and open the Color Wheel.tif image.Color Wheel.tif image.Color Wheel.tif

The three large circles represent the three main, or primary, colors: red, 
green, and blue.

 3. Predict what the “recipe” (R, G, and B values) for each of the primary 
colors will be:

 a. Red = ____, ____, ____

 b. Green = ____, ____, ____

 c. Blue = ____, ____, ____

   Check your predictions by moving your cursor to the red, green, 
and blue parts of the color wheel and examining the RGB values 
in the ImageJ status bar.

The areas where two primary colors overlap, or “mix,” are called the 
secondary colors. The table below shows the names of the three secondary 
colors and the primary colors that mix to form them.

 4. Based on the RGB recipes for the primary colors, complete the table 
by predicting the recipe for each of the secondary colors.

Mix these
Primary Colors

To get this
Secondary Color

RGB “recipe” of Secondary Color

Red Green Blue

Green + Blue Cyan

Blue + Red Magenta

Red + Green Yellow

   Check your predictions by moving your cursor to the cyan, 
magenta, and yellow parts of the color wheel and examining the 
RGB values in the ImageJ status bar.

In the center of the color wheel, all three primary colors mix together.

 5. What “color” do you get when you mix the maximum amount (255 
units) of Red, Green, and Blue light?

 6. What “color” would you get by mixing the minimum amount (0 units) 
of Red, Green, and Blue light?

Color separations
In the printing industry, color pictures are created the same way as on a 
computer screen—by printing pat terns of small dots using three colors of 
ink. Printers must fi rst sep a rate color pic tures into three separate im ag es, 
which are used to make three printing plates, one for each color of ink.

 Choose Image > Color > RGB Split.

 Choose Window > Tile.

The color wheel image has been split into three separate images or 
channels. Each of these channels is a grayscale image with pixel values 
ranging from 0 to 255. The title bar of each image contains the original 
image name followed by the color channel, in parentheses. [For example, 
Color Wheel.tif (red).]

 Examine the pixel values of the three color channel images.

More about
color printing
Reproducing color using ink on 
paper is a little diff erent than 
making color pictures with glowing 
primary color dots on a television or 
computer screen. If you look closely 
at a color picture in a magazine, you 
will see patterns of tiny dots of cyan, 
magenta, and yellow ink.

Mixing these three colors produces 
muddy-looking shadows, so printers 
add a layer of black ink dots to 
give the images more “snap.” This 
four-color printing process is called 
CMYK. (Cyan, Magenta, Yellow, and 
Black. The “K” is used because “B” 
stands for the primary color Blue.) 
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The pixels in the three channels of the color wheel image are all either 
minimum (0) or maximum brightness (255). Next, you will explore what 
happens to the color when the pixel values of each channel are something 
other than 0 or 255.

 To fi ll one or more of the circles of the color wheel channels with a 
different brightness value:

 • Double-click the Color Picker tool  to choose a new  to choose a new 
brightness level (shade of gray) from the grayscale on the left 
side of the color picker window. (Remember the value you 
choose.) Close the Color Picker window.

 • Use the Wand (tracing) tool  to click inside the circle you  to click inside the circle you 
want to “re-color.”

 • Choose Edit > Fill, or press Ctrl-F (the F key on a Mac) to fi ll the 
selected area with the new brightness value.

 7. You have just changed the “recipe” for the color in the center of the 
color wheel. What are the “new” RGB values for this color?

  Red = _______   Green = _______   Blue = _______

 8. Predict the new color that this new RGB recipe will create. (Describe it 
in your own words.)

To see what your new color looks like, you will combine the three separate 
color channels back into a single, composite RGB image.

 Choose Image > Color > RGB Merge..., and click OK.

 9. Calculate the number of different colors that you can produce using 8 
bits (0 to 255) for each of the three color channels. Since there are 256 
possible values for each of three colors, the total number of possible 
colors is:

256 x 256 x 256 = __________________________ colors!

 Close the Color Wheel image(s), and open the three images in 
the Blocks folder, in order (red fi rst, then green, then blue).

 Choose Image > Stacks > Convert Images to Stack.

You have seen how to create a color composite image by merging three 
separate grayscale images. You can also create a color composite image 
from a three-slice stack, where the slices are in Red-Green-Blue order. 
Before you create the color composite from these images, you will try to 
predict the color of each block.

 Using the slider control at the bottom of the stack window, 
fl ip through the stack. Use the brightness of the blocks in each 
channel to predict the color of each block.

 10. Predict the color of:

 a. the “T” block.

 b. the “C” block.

 c. the “I” block.

 Choose Image > Color > Convert Stack to RGB to convert the stack 
to a color composite image, and check your predictions.

 Close the color blocks stack and stack (RGB) images.

RGB merge options
The three color channel images 
should already be assigned to the 
correct color. If you want to keep 
copies of the original color channels 
open when you create the color 
composite, check the Keep source 
images option.

In the Color 
Picker (CP) 

window, 
click a grayscale 

“color” to set 
the fi ll color.
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 Open the Rainbow Bridge Stack.tif image.

This image is another RGB stack. Before you convert it to a color RGB 
image, you will practice predicting colors from the separate channels one 
more time.

 Using the slider control at the bottom of the stack window, fl ip 
through the stack.

 11. On the grayscale version of the image below, circle and label three 
areas—one that should appear red, one that should be green, and 
another that should look blue in the color composite version.

 Choose  Image > Color > Convert Stack to RGB to create an RGB 
color image, and use it to check your predictions.

Indexed color
Not all color images are created equally. The RGB images you have been 
looking at so far store the picture by saving the RGB recipe consisting 
of three 8-bit numbers for each and every pixel in the image. While this 
reproduces colors very accurately, you pay the price for storing so much 
information. RGB color image fi les are three times as large as a grayscale 
image of the same scene.

One solution to this color image fi le size dilemma is to reduce the number 
of possible colors in the image. ImageJ gives you the option to create and 
save color images with up to 256 colors (including black and white), creating 
a color image that’s the same size as the grayscale version. The colors are 
saved in a color lookup table, and the image is stored as pixel values from 0 
to 255 that are indexed to the location of the appropriate color in the lookup 
table. This color image mode is called indexed color, or indexed color, or indexed color 8-bit color. Next, you 
will create an 8-bit color version of the Rainbow Bridge image.

 Choose  Image > Duplicate... and rename the copy of the image 
Rainbow Bridge Indexed Color.
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 Choose Image > Type > 8-bit Color, set the number of colors to Image > Type > 8-bit Color, set the number of colors to Image > Type > 8-bit Color
256, and click OK. Note the 8-bit Color image type in the image 8-bit Color image type in the image 8-bit Color
window’s status bar.

Arrange the two windows side by side. The 8-bit color image does not look 
too bad, but take a closer look.

 Use the Magnifying Glass tool  to examine both images more  to examine both images more 
closely. (On a Mac, you can use the + and - keys to magnify or 
reduce the image.)

 12. Compare the quality of the RGB color and the 8-bit color version of the 
Rainbow Bridge image.

There are other differences between the two color image types that aren’t 
so obvious. For example, let’s say you decided that the images are too dark 
and you want to lighten them a little. (You will need to repeat the following 
steps for both images. Click on an image window to work with that image.)

 Double-click  to zoom back out to see the entire image. to zoom back out to see the entire image.

 Starting with the RGB color version, choose Image > Adjust 
> Brightness/Contrast. Adjust the Minimum, Maximum, 
Brightness, and Contrast sliders until you are happy with the 
image, then click the Apply button.

 Repeat the above process with the 8-bit color image.

 13. Describe what happens.

Changing the brightness and contrast of an RGB color image changes 
the color recipe of the pixel values, but does not drastically alter the 
appearance of the image. In other words, a red pixel is still a red pixel. 
However, adjusting the brightness and contrast of an 8-bit color image re-
indexes each pixel to a completely different color on the lookup table.

 14. Describe at least two advantages and two disadvantages of RGB color 
and 8-bit color images.

 Close all open image windows.

Color for science
Most cameras used for scientifi c purposes record only the brightness 
information of the scene they are aimed at. To create color images, grayscale 
(brightness) pictures are taken through colored fi lters. These images are 
then combined into a color composite by assigning each image to the 
appropriate color channel. To create a true-color picture, images are taken true-color picture, images are taken true-color
through red, green, and blue fi lters, which are then assigned to the red, 
green, and blue channels, respectively. When images taken through a fi lter 
are assigned to a color channel that does not match the fi lter, the result is a 
false-color image. While these images may look strange to us, they can be 
very useful in helping to understand the information the images contain.

True and false color in ImageJ
You may have noticed that ImageJ’s RGB Merge dialog box allows you 
to assign any image to any color channel. First, you will “color inside the 
lines” and create a true-color version of the image.

 Open the Landsat folder, and open all seven images in the Santa 
Cruz Valley, AZ folder.

Lots o’ colors!
Scientifi c cameras may contain two, 
three, or more fi lters. Some imaging 
systems actually record in hundreds 
or even thousands of diff erent 
wavelengths!

Landsat Bands
Band 1 (blue) ....................... 0.45-0.52 µm

Band 2 (green) .................... 0.52-0.60 µm

Band 3 (red) .......................... 0.63-0.74 µm

Band 4 (near IR) .................. 0.76-0.90 µm

Band 5 (mid IR) ................... 1.55-1.75 µm

Band 6 (thermal IR) .......... 10.4-12.5 µm

Band 7 (mid IR) ................... 2.08-2.35 µm
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 Choose Image > Color > RGB Merge…, and use the popup menus 
to assign the Santa Cruz Valley TM 3.tif to the red channel, Santa Cruz Valley TM 3.tif to the red channel, Santa Cruz Valley TM 3.tif
Santa Cruz Valley TM 2.tif to the green channel, and Santa Cruz Valley TM 2.tif to the green channel, and Santa Cruz Valley TM 2.tif Santa 
Cruz Valley TM 1.tif to the blue channel. Check the Cruz Valley TM 1.tif to the blue channel. Check the Cruz Valley TM 1.tif Keep 
source images option so that you don’t have to re-open the 
original images again.

Since the fi lters used by the Landsat camera for bands 3, 2, and 1 really 
were red, green, and blue, the scene is reproduced approximately as your 
eyes would see it.

Scientists use a simple shorthand to describe how the bands are assigned 
to color channels—they write them in RGB order. Thus, true color Landsat 
images are described as 3,2,1 (RGB).

 Close ONLY the RGB composite color image window, and leave 
the seven Landsat band images open.

False color
What if you “break the rules” and assign the bands to the “wrong” 
channels? You can’t break anything, so try it!

 Choose Image > Color > RGB Merge…, and use the popup menus 
to create a 4,3,2 false-color image. (Remember to check the Keep 
Source Images option.)

 15. How does vegetation appear in a 4,3,2 false-color image?

 Experiment with creating false-color images with different band 
assignments. (With 7 bands, there are a total of 210 different ways 
to assign the bands to color channels!) 

You can even assign the same band to two, or all three color channels.

 16. Predict what an RGB composite image with the same band assigned to 
all three channels would look like.

 17. Test your prediction, and describe the results.

 When you have tried out all 209 different false-color composites 
(or are tired of making them), close all seven of the Landsat band 
images.

Creating 3-D stereo images
The technique of creating color composite images can also be used to 
produce three-dimensional or “stereo” images. To create the illusion of 
depth, slightly different images rep re sent ing two separate viewpoints of an 
object must be sent to the brain.

 Open the two images in any of the subfolders inside the Mars 
Rover 3D folder.

These images were taken by the twin rovers, Spirit and Opportunity, that Opportunity, that Opportunity
landed on and explored the surface of Mars in 2004.

 Choose Image > Stacks > Convert Images to Stack.

 Use the slider control at the bottom of the stack window to fl ip 
back and forth between the two views.

 18. What appears to happen to the scene of the surface of Mars?

Image registration
Since it takes time to move a 
diff erent fi lter in front  of the lens, 
images created through fi lters are 
not taken at the exact same time. 
This means that if the subject or the 
camera is moving, the images will 
not be registered. That is, they will  
not show exactly the same scene.  
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 Choose Image > Stacks > Convert Stack to Images.

When you unstack the images, they are now labeled 001 and 002, instead 
of Left and Left and Left Right. 

One way to create a 3-D effect is to combine the left and right eye views in 
the same image window, assigning a different color to each view. You then 
control which view is seen by each eye using colored fi lters, and your brain 
is fooled into believing it sees three dimensions (height, width, and depth).

There are two possible ways to assign the views to the red and blue color 
channels, so you will create two versions of the 3-D image and compare 
them to see which produces the best results. If you don’t assign anything 
to the green channel the image looks too dark, so you will assign the same 
view to both the green and blue channels.

 Create the fi rst 3-D scene. Choose Image > Color > RGB Merge…, 
and use the popup menus to assign the Left (or 001) image to the 
red channel and the Right (or 002) image to both the green and 
blue channels. Check the Keep Source Images box, then click OK.

You can reverse the channels assigned to each image to create a second 
3-D image for comparison. 

 Choose Image > Color > RGB Merge… again, and use the popup 
menus to assign the Right (or 002) image to the red channel and 
the Left (or 001) image to both the green and blue channels.

 Put on your red and blue glasses, and look at the images. It may 
take several seconds before your eyes relax enough to allow the 
images to overlap.

 19. Which of the two channel assignments you tried produces the image 
with the best 3-D effect?

 20. 3-D images are fun to look at, but how do you think they would be 
useful to a scientist?

  When you have fi nished creating 3-D images, close all open 
images. 
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Data
SheetColor by Number

 1. Does the pixel value in ImageJ represent “how much light” (black = 0 and white = 255) or “how much 
black” (white = 0 and black = 255)?

 2. Complete the following table by moving your cursor to any pixel in the image of the color shown, then 
write down that pixel’s red, green, and blue values.

Go to a pixel 
of this color

Record its RGB values

Red Green Blue

Red

Green

Blue

 3. Predict what the “recipe” (R, G, and B values) for each of the primary colors will be:

 a. Red = ____, ____, ____

 b. Green = ____, ____, ____

 c. Blue = ____, ____, ____

 4. Based on the RGB recipes for the primary colors, complete the table by predicting the recipe for each of 
the secondary colors.

Mix these
Primary Colors

To get this
Secondary Color

RGB “recipe” of Secondary Color

Red Green Blue

Green + Blue Cyan

Blue + Red Magenta

Red + Green Yellow

 5. What “color” do you get when you mix the maximum amount (255 units) of Red, Green, and Blue light?

 6. What “color” would you get by mixing the minimum amount (0 units) of Red, Green, and Blue light?

 7. You have just changed the “recipe” for the color in the center of the color wheel. What are the “new” 
RGB values for this color?

  Red = _______   Green = _______   Blue = _______

 8. Predict the new color that this new RGB recipe will create. (Describe it in your own words.)

 9. Calculate the number of different colors that you can produce using 8 bits (0 to 255) for each of the three 
color channels. Since there are 256 possible values for each of three colors, the total number of possible 
colors is:

256 x 256 x 256 = __________________________ colors!

Name(s)   ______________________________ Class  _________   Date  __________________
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 10. Predict the color of:

 a. the “T” block.

 b. the “C” block.

 c. the “I” block.

 11. On the grayscale version of the image below, circle and label three areas—one that should appear red, 
one that should be green, and another that should look blue in the color composite version.

 12. Compare the quality of the RGB color and the 8-bit color version of the Rainbow Bridge image.

 13. Describe what happens.

 14. Describe at least two advantages and two disadvantages of RGB color and 8-bit color images.

 15. How does vegetation appear in a 4,3,2 false color image?
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 16. Predict what an RGB composite image with the same band assigned to 
all three channels would look like.

 17. Test your prediction, and describe the results.

 18. What appears to happen to the scene of the surface of Mars?

 19. Which of the two channel assignments you tried produces the image 
with the best 3-D effect?

 20. 3-D images are fun to look at, but how do you think they would be 
useful to a scientist?
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Photo Effects
Enhancing images

Teaching
Notes

Overview
Images produced and used in magazines, newspapers,  videos, and 
fi lms are routinely enhanced digitally. In this lesson, students use image 
pro cess ing techniques to edit, morph, and fi lter digital images. They also 
gain experience understanding and applying some of the mathematical 
operations behind the tech niques. Scaling, averaging, and fi ltering images 
require that students cal cu late ratios and perform computations. This 
lesson is divided into four parts, each of which could take students a class 
period to complete, depending upon the depth with which topics are 
covered.

In Part 1, students create an out ra geous picture for a tabloid news pa per. 
They scale, edit, and copy images to produce the desired effect. In Part 
2, they fi nd out how to simulate the morphing of two images through 
the averaging of pixel values. In the third section, students restore old 
pho to graphs by “stretch ing” the pixel values. Beginning with a faded 
photograph they use the histogram function to examine the distribution of 
pixel values in the image. They subtract and then multiply the pixel values 
by constants. The result is a clearer image that uses the entire range of 
pixel values. Throughout the lesson students dis cov er that many im ag ing 
tech niques en hance digital im ag es by chang ing the pixel values of the 
image. In Part 4, the fi nal section, students are asked to consider the ethical 
implications of altering images. They read an article from a newspaper 
and write a position statement that helps them clarify their views on this 
con tro ver sial topic.

Objectives
Students will:

 • use cutting, pasting, and scaling to make “fantastic” photos in order to 
critically evaluate the authenticity of digitally created images

 • explain how morphing effects can be produced mathematically via the 
averaging of pixel values in images

 • apply mathematical operations to pixel values to restore faded 
photographs

 • consider the ethical im pli ca tions of altering images by writing a 
position state ment concerning the use of digitally enhanced images

Related Activities
 • For more information about pixels and their characteristics, refer to 

the les son “Pixelated Pictures.”

 • See “Digital Detective” for an introduction to image processing in the 
fi eld of  forensics and issues related to photo enhancement in legal 
settings. 

Goal
Students use imaging tech niques to 
cut, paste, average, and fi lter images 
as they eval u ate the authenticity 
and the ethical im pli ca tions of 
creating and enhancing digital 
images.

IP Skills
 • Cutting and pasting

 • Scaling images

 • Making selections

 • Thresholding

  • Interpreting histograms

ImageJ Skill Sheets
 • Memory

 • Cutting & Pasting

 • Density Slicing

Teaching
Notes
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Career Links
Image processing techniques are frequently used by photographers as the 
fi eld of pho tog ra phy becomes more reliant upon digital rather than print 
media. In ad di tion, special effects in the world of fi lm and video production 
increasingly rely on image processing.
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Lesson developed by Carla McAuliffe, Center for Image Processing in 
Education.

Parts of this lesson are based on “Stretch it Out,” developed by Larry 
Kendall, Image Processing for Teaching project, Uni ver si ty of Ar i zo na.

Updated for use with ImageJ by Larry Kendall.

Images courtesy of the National Institutes of Health, Bob Carpenter, 
Tucson, Arizona, Joe Freeman, Field Elementary School, Mesa, Arizona,  
and the authors.

“Making the camera lie, digitally and often,” by Amy M. Spindler, 
Copyright © 1997 by The New York Times Co. Reprinted by Permission.

Answers
 1. When a scaling factor of 1 is selected, the size of the image remains 

un changed. It is neither enlarged nor reduced.

 2. The Transparent Transfer Mode eliminates the white background of 
the Earth image.

 3. Answers will vary but may include scaling, rotating, selecting, 
copying, and pasting.

 4. Answers will vary, but the student should have a more skeptical 
attitude toward tabloid covers. This exercise should instill the idea that 
“seeing is not believing.”not believing.”not

 5. Answers will vary. In order to prove that a digital image is not an 
“original,” you might look for fl aws in the image. Check to see if the 
edges of obvious cuts and pastes are visible. Examine the relative 
proportion of objects and people in the image. Are the heights and 
widths reasonable and realistic?

 6. The image of Mark gradually fades or “morphs” into the image of Jane.

 7. The averaged image has features of both Mark and Jane blended 
together. It appears to be about half of each person.

 8. 

Table 1

Slice Number % Mark % Jane

1/5 100% 0%

2/5 75% 25%

3/5 50% 50%

4/5 25% 75%

5/5 0% 100%
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 9. With more slices, the transition between images is smoother, and the 
morph is more convincing.

 10. The cross fade morph simply blends gradually from one image to 
another but does not appear to change one person’s features into the 
other’s. The warp morph appears to gradually change one person’s 
features to the other’s.

 11. The minimum pixel value is 50 (Count = 7)

 12. The maximum pixel value is 184 (Count = 1)

 13. Faded Uncle Frank’s histogram

 14. The peak at the left of the histogram shows the high abundance of 
dark pixels in the image.

 15. The range of pixel values is 184 - 50 = 134.

 16. Answers will vary. The image should become uniformly darker, and 
the his to gram should shift to the left without changing shape.

 17. The image became darker.

 18. Uncle Frank’s histogram after subtracting minimum value.

 19. The maximum pixel value is now 134.

 20. Multiplication would stretch the histogram values.

 21. Multiply by 1.9.

 22.  Answers will vary. The image appears brighter and has more contrast. 
(Dust and scratches are also visible!)
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 23.  Uncle Frank’s histogram after multiplication.

24.  Gaps appear in the histogram because there are no values in the image 
that produce those levels when multiplied by the factor chosen. Any 
unevenness in the gaps is caused by ImageJ rounding products to the 
nearest integer value when multiplying by a non-integer value, such as 
1.9.

 25.  New pixel values beyond 255 are truncated to 255.

 26. Answers will vary. Look for carefully written statements providing 
guidelines for when an altered or enhanced image may be used with 
or without the per mis sion of either the photographer or the subject.
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Photo Effects
Enhancing images

Lesson

Part 1: “Amazing Moon Baby Saves Earth!”
 Launch ImageJ, and open the 1 Cover.tif image in the 1 Cover.tif image in the 1 Cover.tif 09 Photo 

Effects folder.

Tabloid newspapers often sport headlines like this one, complete with 
out ra geous pictures. It is surprisingly easy to create such special effects. 
In this lesson, you will edit, fi lter, and morph images to achieve both 
entertaining and useful photographic effects. Put yourself on the moon, 
become fi sh bait, turn into an animal, design an ad for a product, or simply 
bring an old photo back to life! Using digital imaging techniques, you can 
learn to create images rivaling those of professional graphic designers.

 Open all the images in the 2 Cover Parts folder.

You will use these images to recreate the magazine cover image.

Resizing images
 Activate the Moon.tif image.Moon.tif image.Moon.tif

The image of the moon is smaller than the one in Cover.tif. ImageJ allows Cover.tif. ImageJ allows Cover.tif
you to resize images by a scale ranging from .05 to 25 (5% to 2500%). A 
scale less than 1 reduces the image while a scale greater than 1 enlarges it.

 1. What would happen to the image if you entered a scale of exactly 1?

 Choose Image > Scale….

 Enter the horizontal (X) and vertical (Y) scales as decimal values, 
and turn on both the Interpolate and Create New Window
options.

 Experiment with different scales until the scaled moon image is 
the size you want.

Once you have resized the moon, you will need to select, copy, and paste it 
in place on the Blank Cover.tif image.Blank Cover.tif image.Blank Cover.tif

Sloppy select/precise paste
 Activate the scaled moon image, and choose Edit > Selection > 

Select All to select the entire image.

 Choose Edit > Copy to copy the selection.

When you select part of a digital image, you are choosing certain pixels 
within the image. Cutting or copying the selection puts those pixel values 
into a portion of the com put er’s memory called the clipboard. Pasting the 
selection in a new location re plac es the original pixel values with the values 
stored in the clipboard.

 Activate the Blank Cover.tif image by clicking on it or choosing Blank Cover.tif image by clicking on it or choosing Blank Cover.tif
it from the bottom of the Window menu.

File > Open…

Lesson
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 Choose Edit > Paste to paste the selected pixels, drag the selection 
to the desired location, and click outside the selection boundary to 
complete the paste operation.

Precision selections
Another way to select pieces for cutting and pasting is to threshold and 
use the Wand (tracing) tool . Thresholding highlights all the pixels in . Thresholding highlights all the pixels in 
the image that fall within a range of values you specify. The Wand tool 
au to mat i cal ly draws a selection line around highlighted areas.

 Choose Windows > Baby with Net.tif to activate the image of the Windows > Baby with Net.tif to activate the image of the Windows > Baby with Net.tif
baby and his net.

 Choose Image > Adjust > Threshold… to turn on thresholding 
mode.

 Adjust the upper and lower boundary of the threshold range until 
the baby and net turn totally red but the background remains 
black.

 Using , click to the left of the highlighted area. The area will be , click to the left of the highlighted area. The area will be 
outlined au to mat i cal ly.

 Copy and paste the selection onto the Blank Cover.tif image.Blank Cover.tif image.Blank Cover.tif

Finish your cover
 Choose Windows > Earth.tif to activate the Earth image.Windows > Earth.tif to activate the Earth image.Windows > Earth.tif

 Rescale the Earth image to the correct size, and copy and paste 
it onto the blank cover image. To make the white background 
transparent, choose Edit > Paste Control…, and experiment with 
the different transfer modes until you fi nd one that makes the 
white background transparent.

 2. Which transfer mode allows the white background of the Earth image 
to be pasted transparently?

 Drag the pasted Earth image to the desired location, then click 
outside the selection outline to make the paste permanent.

 Use the techniques you have learned for rotating, resizing, 
selecting, and pasting images, and for formatting and drawing 
text to fi nish recreating the Cover image.

 3. Describe the steps you used to modify and add the Asteroid.tif image Asteroid.tif image Asteroid.tif
to your cover.

 When you are fi nished assembling your cover, you may wish to 
use the Color Picker  and Pencil  tools to touch up any pixels 
that don’t look right.

 If you have the ability to print or save your fi nal cover image, you 
may wish to do so now. 

 4. Now that you have discovered how easy it is to fake digital photos, 
how likely are you to believe a tabloid cover photo?

 5. If you suspect a digital image is not an “original,” how might you prove 
it?

  Close all images when you are fi nished.

Rotating images
Some of the images must be rotated 
as well as scaled before you can 
copy and paste them onto your 
cover. To rotate an image, choose 
Image > Rotate > Arbitrarily…,
and enter the desired rotation angle. 
Positive angles rotate the image 
clockwise, and negative angles 
rotate the image counterclockwise. 
Check the Interpolate option for a 
smoother result. 

Selecting the Baby 
Tells Story.tif imageTells Story.tif imageTells Story.tif
After you have rotated and 
lightened the image, the easiest 
way to select the baby is to use 
the polygon selection tool to click 
around his outline. Don’t worry 
about being too exact with your 
original selection, since the handles 
along the outline can be moved 
before copying the selection.
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Part 2: Morphing
 Open the 3 Mark to Jane Fade.tif image stack in the 3 Mark to Jane Fade.tif image stack in the 3 Mark to Jane Fade.tif 09 Photo 

Effects folder,  and animate it.

 6. Describe what this stack shows.

Have you seen an effect like this in the movies or on television? 
Transforming one person or object into another is called morphing. 
Using ImageJ, you can do a simple version of the morphing process. 
Understanding the mathematics behind this process will help you create 
this and other interesting effects.

 Close the 3 Mark to Jane Fade.tif image stack window.

 Open 4 Mark.tif and then 4 Mark.tif and then 4 Mark.tif 5 Jane.tif.5 Jane.tif.5 Jane.tif

 Choose Image > Stacks > Convert Images to Stack to stack the 
images.

ImageJ features a stack function called Z-axis projection. This function 
allows you to mathematically combine the images in a stack to create a 
new image. Each pixel in the new image is calculated from the pixel values 
at that same X,Y location in each slice of the stack. ImageJ can create the 
new image based on the sum, average, minimum, maximum, standard 
deviation, or median of the slice pixel values.

 To calculate the average of the slices in the stack, choose Image 
> Stacks > Z Project…. Start at slice 1, stop at slice 2, choose the 
Average Intensity projection type, and click Average Intensity projection type, and click Average Intensity OK.

The new image, named ZProjection of Stack, is the average of the pixels 
in the Mark slice and the pixels in the Jane slice.

 7. Describe the appearance of the averaged image.

Next you will add the averaged image to the stack.

 Activate the ZProjection of Stack image, and copy it.

 Activate the stack, and go to the fi rst slice (Mark). Choose Image > 
Stacks > Add Slice to add a blank slice between the Mark and Jane 
slices.

 Paste the averaged image into the blank slice. Drag the scroll bar 
at the bottom of the stack window to view the slices of the stack.

 Repeat this process to create and add two more slices to the stack. 
The fi rst will be the average of slices 1 and 2, and the second the 
average of slices 2 and 3.

X-AxisX-Axis

Y-Axis
Y-Axis

Z-
A

xi
s

The Z-Axis
You should already be familiar with 
the X-axis (width) and the Y-axis 
(height) of an image. In a stack, 
the Z-axis is the depth of the stack, 
measured in slices.

Z-Projection settings

Animating stacks
Choose Image > Stacks > Start 
Animation to animate a stack. Click 
anywhere in the stack window to 
stop the animation. Pressing the 
backslash key ( \ ) on your keyboard 
also starts and stops animations.
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 Insert these two new slices into the stack, each in its proper 
location, and fl ip through the stack. (It should now have fi ve slices.)

If the fi rst slice of the stack represents 100 percent Mark and 0 percent 
Jane, and the last slice represents 0 percent Mark and 100 percent Jane, the 
middle slice represents 50 percent Mark and 50 percent Jane.

 8. In Table 1, describe the percentages of Mark and Jane in the two slices 
you added.

Table 1

Slice Number % Mark % Jane

1/5 100% 0%

2/5

3/5 50% 50%

4/5

5/5 0% 100%

 Close all images when you fi nish examining the morph stack.

Automated averaging
To give the morphing transformation a smoother appearance, you need 
many intermediate images. These can be produced through repeated 
averaging, but the process is tedious and time-consuming. The iMorph 
plugin automates this process for the number of frames you specify.

 Open 4 Mark.tif and 5 Jane.tif but do not stack the images.5 Jane.tif but do not stack the images.5 Jane.tif

 Choose Plugins > Stacks > iMorph.

 In the iMorph dialog box, set the values as shown at right and 
click OK.

 The plugin creates a new stack named 
iMorphed. Animate the stack. For 
best results, choose Image > Stacks > 
Animation Options…, set the speed to a 
value between 30 and 60 fps, and check 
the Loop Back and Forth option.

 9. How does increasing the number of 
intermediate slices affect the appearance of 
the morphing transformation?

Geometric morphing
The morphing process you have used only transforms the brightness 
values of the starting image into those of the ending image, a process 
called a cross fade.

 Keep the animation of the iMorphed stack running, open the 6 
Mark to Jane Warp.tif stack, and animate it.Mark to Jane Warp.tif stack, and animate it.Mark to Jane Warp.tif

 10. Describe the differences between the two morphing stacks.

True morphing involves transforming not only the brightness (or color) 
of one object to another but also includes transforming the shape of one 
object to the shape of another. This is called geometric warping and is a geometric warping and is a geometric warping
very complex mathematical process.

iMorph dialog boxiMorph dialog box
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Unfortunately, ImageJ does not have the ability to do geometric warping. 
Other software was used to create the full morphing effect you see 
here, including both the cross fade and geometric warping. In image 
warping, you usually defi ne points or shapes on one image and select the 
corresponding points or shapes on the other image. 

(Note: This capability and the screen shot below are NOT part of 
ImageJ.)

 Close all images and stacks when you are fi nished viewing them.

Part 3: Photo restoration
 In the 8 Old Photos folder open Faded Uncle Frank.tif.Faded Uncle Frank.tif.Faded Uncle Frank.tif

You probably noticed that this image looks pretty bad. If this were a recent 
pho to graph, you might think that the exposure was way off. However, 
because this photo is very old, the image has probably faded with time. 
Ex am in ing the numbers behind the image will help you understand 
why this photo looks as it does. With help from mathematics and image 
pro cess ing techniques, you can restore this faded old photo to something 
closer to its original appearance.

As you look at the photograph, your eyes see many shades of gray. Your 
eyes are sensitive to a range of brightness from pure black to pure white. In 
this grayscale image, pixel values can range from 0 to 255, with white pixels 
having a value of 255, black pixels having a value of 0, and gray pixels 
having values from 1 to 254.

Let’s examine the range of pixel values in this image. Making a histogram is 
the easiest way to see the dis tri bu tion of these values.

 Choose Analyze > Histogram to make a histogram of the image.

This histogram shows the total number of pixels with each “bright ness” 
value in the image, from 0 (black) to 255 (white).

 Move your cursor from left to right in the his to gram window, and 
read the Level: (pixel value) and Count: (number of pixels) at the 
bottom of the window.

You try it! 
Become your friend. or turn into a 
bird! Use the iMorph plugin to create 
your own image morphs. Check out 
the images in the 7 Special Eff ects
folder, or scan your own.

You may need to resize, rotate, and 
register your images fi rst. To resize 
images for registration, measure a 
distance on both images, such as 
the spacing between the eyes, and 
use the ratio between these two 
measurements to fi nd the scaling 
factor. For example:

Image 1 = 156 px

Image 2 = 187 px

Ratio  = 156 px/187 px = 0.834

Activate Image 2, choose Image 
> Scale, and enter 0.834 for the 
X-and Y-Scale values.

Registering images involves aligning 
matching points in the scaled 
images so they are in approximately 
the same location in each image. 
To create a smooth morph from 
the images of two people,  make 
sure that key features such as eyes, 
mouths, and noses, are scaled and 
registered as closely as possible.

To align one slice with another:

 • Choose the slice you want to 
use as the reference image.

 • Find the coordinates of a point 
in the reference image that you 
want to align the other slices to.

 • Select the slice you want to shift, 
cut it, and paste it back into its 
own window.

 • Drag the pasted selection, or 
nudge it with the arrow keys 
to move the point to the same 
location as in the other slice.

 • Flip between the slices to check 
the alignment, and re-align 
again if necessary.

What software is it?
The geometric morphing software 
used here is a freeware application 
called MorphX (Macintosh OS X 
only)
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 11. According to the histogram, what is the minimum pixel value (Level) 
in the image? (What is the lowest Level with a Count of at least 1?)Count of at least 1?)Count

 12. According to the histogram, what is the maximum pixel value (Level) 
in the image? (What is the highest Level with a Count of at least 1?)Count of at least 1?)Count

 13. Sketch the histogram, or print it out, and paste it onto the Data Sheet. 
Put a descriptive label on each axis and a title above the graph.

 14. How does the shape of the histogram relate to the shades you see in 
the image?

 15. What is the range (maximum-minimum) of pixel values in the image?

The range of pixel values in this image is very narrow. A narrow range of 
values corresponds to a narrow range of colors, so that the picture looks 
gray and washed out. It would be nice to expand the range of brightness 
in the image to cover the full range your eyes can detect. This is similar to 
adjusting the contrast on a television or computer monitor. In ImageJ, you 
can use math to adjust the contrast very precisely.

Image arithmetic
To use the full range of values from 0 to 255, the minimum value needs to 
be shifted down to 0. Subtracting the current minimum pixel value from 
every pixel in the image will make the new minimum equal to 0. All other 
pixel values will be lowered by the same amount.

 16. Predict what will happen to the image and its histogram when you 
subtract the minimum value from every pixel.

 Choose Process > Math... > Subtract and enter the minimum value 
you found in question 11 to subtract this value from each pixel in 
the image.

 17. How did the appearance of the image change after the subtraction? 
Did you predict correctly?

 18. Create a new histogram, and sketch it. (Be sure to label the axes and 
title the graph). How well did you predict its appearance? 

 19. The minimum value is now 0. To stretch the pixel values from 0 to 255,  
the maximum value needs to be 255. What is the maximum pixel value 
on the image now? (Look for the highest Level with a Count of at least Count of at least Count
1 on the most recent histogram.)

 20. What math operation would stretch the maximum value to 255 without 
changing pixels that have a value of 0?

 21. What factor would you multiply the maximum value in the image by to 
get 255? (Hint: maximum × ? = 255)

 Choose Process > Math… > Multiply…, and multiply the pixel 
values in the image by the factor you calculated.

 22. Describe how the image changed after the multiplication.

 23. Create and sketch the new histogram.

 24. Why are there gaps in the new histogram?

 25. If you multiplied a pixel with a value of 92 by 4, its  new value would 
be 368. This is beyond  ImageJ’s range of 0 to 255. What do you think 
happens to this pixel? (Try it to fi nd out).
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On your own
 • Try out any of the photo eff ects 

you learned in this lesson on 
images that you scan or create.

 • Share your position statement 
through class discussion or 
debate.

More articles on ethics 
and digital images

When your eyes tell you lies

http://www.insightmag.com/
news/2000/10/16/Nation/Media.
When.Your.Eyes.Tell.You.Lies-213320.
shtml

A brief history of media fakery and 
its ethical implications.

Digital photography:
A question of ethics

http://www.fno.org/may97/digital.
html

A teacher’s perspective on digital 
manipulation and ethics.

What’s real, what’s phony?

http://www.dartmouth.edu/
~vox/0405/0726/photos.html

The development of a mathematical 
way to tell if a digital image has 
been faked. 

Journalism faces a serious 
technological threat 

http://www.lib.utah.edu/epubs/
undergrad/vol7/tilman.html

Discussion of digital technology 
as a possible threat to journalistic 
credibility.

 Close Faded Uncle Frank.tif and the Faded Uncle Frank.tif and the Faded Uncle Frank.tif Histogram window.

 Open another image in the Old Photos folder, and “restore” it 
using the techniques you have just learned.

Part 4: Images and the law
The degree to which retouched and altered images can be made to look 
“fl awless” creates controversy. Not only is it possible to put people in 
photos of places where they have not been, but it is possible to make it 
seem as if the altered photo is an original. What are the ethical im pli ca tions 
of using altered images, par tic u lar ly when the images are intended for use 
as evidence in court?

Read the article, “Making the Camera Lie, Digitally and Often” on the next 
page. As you read, think about what rights, if any, an individual should 
have over the use of his or her image.

 26. Write a position statement addressing the above issues and outlining 
what you feel to be the guidelines for appropriate use of digitally 
en hanced and altered images.



160 Discovering Image Processing
©2006 The Center for Image Processing in Education and 

portions ©1998 Arizona Board of Regents.
Limited classroom reproduction rights are granted earlier in this work.



 Photo Eff ects 161
©2006 The Center for Image Processing in Education and 

 Photo Eff ectsportions ©1998 Arizona Board of Regents. Photo Eff ectsLimited classroom reproduction rights are granted earlier in this work. Photo Eff ectsLimited classroom reproduction rights are granted earlier in this work. Photo Eff ects

By AMY M. SPINDLER  (NYT)

Published: June 17, 1997

Reproduced with permission

Among photographers, it’s 
called digital dieting: the digital 
enhancement used on celebrity and 
model photographs today, making the 
subjects look freakishly fl awless.

But the same technology that has 
long been the subject’s friend has 
grown to encompass an entirely 
new art form that some people now 
see as the enemy. Photography with 
digital doctoring is so far from the 
conventional journalistic art where 
seeing is believing that Richard 
Avedon suggests giving it a new 
name.

‘’There is no such thing as 
photographic reality,’’ Mr. Avedon 
said. ‘’You cannot believe a 
photograph.’’

Mr. Avedon has been manipulating 
his images, not on a computer but by 
hand, since about 1953, when Marella 
Agnelli’s swanlike neck was elongated 
even further for effect.

‘’I feel I have the right to interpret 
my subject as an artist,’’ he said. ‘’And 
photography is an art.’’

That right is being questioned now 
by Mira Sorvino, who took issue with 
photos by David LaChapelle that were 
digitally altered to portray her as Joan 
Crawford in the May issue of Allure. 
Mr. LaChapelle is certain to infl uence 
the work of a new generation of 
photographers in the same way that 
Mr. Avedon pioneered so much of 
what is familiar today.

But Mr. LaChapelle is just one of a 
growing band for whom the photo 
is only the beginning. Under their 
infl uence, the idea of the sanctity 
of the negative is on its way to 
becoming the most important issue 
in modern photography. The fact that 
photography is being redefi ned as 
illustrative invention is jarring to those 
who think of photos as truth.

‘’That’s an interesting concept: 
where to fi nd reality,’’ said Mr. 

LaChapelle, who is in Los Angeles 
this week shooting the cover for the 
Fleetwood Mac reunion album. ‘’It 
used to be you turned to photos for 
that. People say photos don’t lie. Mine 
do. I make mine lie.’’

Mr. Avedon said that of all the 
photographers inventing surreal 
images, it was Mr. LaChapelle who 
has the potential to be the genre’s 
Magritte. Magritte didn’t need 
complicity with a subject. And in 
many ways, the new generation of 
photographers doesn’t either. The 
independence of photographers like 
Mr. LaChapelle was made glaringly 
clear in the controversy fanned by Ms. 
Sorvino.

No one seems to know exactly why 
Ms. Sorvino was unhappy at being 
portrayed as Joan Crawford. ‘’Her 
reasoning behind not wanting to do 
a certain image doesn’t matter,’’ said 
Mara Buxbaum, her agent at PMK 
Public Relations. When she posed for 
Allure’s ‘’Hollywood Babylon’’ shoot, 
she was fi ne recreating other creepy 
settings like the lobotomized Frances 
Farmer with her brain in a jar. And 
she has also not complained about 
digital retouching on the same photo 
that perfected her skin, lengthened 
her legs, and thinned her waist.

But while Ms. Sorvino thought she 
was posing as Marlene Dietrich, she 
was later digitally given big eyebrows 
and cruel lips, with a model playing 
Christina Crawford superimposed 
beside her, like ‘’Mommie Dearest.’’

The issue has become one of artists’ 
rights: Ms. Sorvino’s to appear as 
she’d like, and Mr. LaChapelle’s to 
create the image he’d like.

‘’Editorial is a laboratory,’’ Mr. 
LaChapelle said. ‘’There’s a place 
where I do execute other people’s 
ideas. It’s called advertising. I’m not 
there to do what the publicists want.’’

It isn’t only the seamlessness of 
the computer work that has caused 
anxiety. It is the pervasiveness of it 
and its limitless potential. On the 
computer, any photo of Ms. Sorvino 

that exists could be made to look like 
Joan Crawford. Or Fatty Arbuckle, 
for that matter. For artists like Mr. 
LaChapelle, Nick Knight, Inez van 
Lamsweerde, Jean-Baptiste Mondino, 
Raymond Meier and Jean-Paul 
Goude, making the photography 
unbelievable, more astonishing than 
life, is the goal.

‘’It is the single most important step 
in photography since its invention,’’ 
Mr. Knight said, referring to digital 
technology. He has just shot the 
latest Christian Dior campaign, and 
he works regularly with Alexander 
McQueen, most recently on Bjork’s 
new album art. ‘’It’s going to 
completely alter how we approach 
photography in the future,’’ he said. 
‘’Photography has been burdened 
with the responsibility of showing 
reality since its invention. It isn’t a 
good medium to do that.’’

Photographers like Mr. Knight 
and Mr. LaChapelle construct a 
photograph from its inception with 
an eye to what will be done digitally 
to it later. The work on such photos 
is considered so important today 
that it isn’t unusual for the image-
manipulation artist to be given a 
separate credit in magazines. Stephen 
Gan, who works with many of the 
photographers in Visionaire magazine, 
said for artists like Mr. Goude, the 
credit often reads ‘’image making.’’

‘’These photographers have become 
storytellers, almost illustrators,’’ he 
said.

The resulting image truly has never 
been seen before, because, of course, 
it never existed.

‘’I’m taking photos for a generation 
that grew up in a time of provocative 
images,’’ Mr. LaChapelle said. 
‘’I’m part of what I consider the 
entertainment industry. For my photos 
to be entertaining, they have to be 
provocative and new.’’

Mr. LaChapelle’s Crawford photo 
has created a brouhaha among those 
who control celebrity images, as 
if such art-department tricks were 

Making the Camera Lie, Digitally and Often
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something new.
‘’Fashion magazines and other 

magazines have improved or thought 
they improved pictures forever,’’ 
said Patrick McCarthy, the chairman 
and editorial director of Fairchild 
Publications, which owns Los Angeles 
Magazine, in addition to Women’s 
Wear Daily and W. ‘’You get into 
issues of how far do you go. If the 
dress didn’t look good in blue, do you 
do it in red? Maybe you shouldn’t. But 
you can’t assume a fashion photo is a 
U.P.I. picture of a war zone.’’

Dustin Hoffman is suing Los 
Angeles Magazine for dressing 
his image from ‘’Tootsie,’’ on the 
computer, in Richard Tyler.

‘’They made him an involuntary 
model, and he’s suing on that ground 
and other grounds,’’ said Bert Fields, 
Mr. Hoffman’s lawyer. He said of 
digital imaging: ‘’It’s fascinating 
because there is no area of the law. 
There are going to be cases all over 
the place dealing with what happens 
when you put a computer to work.’’

The offi cial Allure stance, from its 
editor in chief, Linda Wells, is that the 

issue is between Ms. Sorvino and Mr. 
LaChapelle. Which is odd, considering 
that the magazine regularly doctors 
celebrity photos, giving them double 
chins (Ms. Sorvino got one in June 
1996) or new noses.

Even photography presumed to 
be true isn’t always. For years, Mr. 
Avedon has switched heads with 
bodies he liked better. In the new 
Givenchy advertising he shot with Mr. 
McQueen last week, he switched one 
model’s head in a photo with her body 
in another.

And in a feat that has become 
legendary in the industry, Nucleus 
Imaging, a leading digital retouching 
company in New York, took Karl 
Lagerfeld’s photos of Princess 
Caroline of Monaco and made a cover 
for Harper’s Bazaar by grafting skin 
from one frame, hair from another, 
the face from yet another, and the 
body from another. It was done with 
a Macintosh and a Silicon Graphics 
computer, which has been used for 
special effects in fi lms for years.

‘’Ultimately, digital imaging is 
another gadget in the photographer’s 

camera bag,’’ said Jon Rosen, 
the owner of Nucleus Imaging. 
‘’Photography was always fi lled with 
illusions. Where do you draw the line? 
Half these people talking about ethics 
had wedding pictures done with soft 
focus on them. There is no genuine 
question of ethics.’’

Mr. LaChapelle stresses that 
photography will never be completely 
supplanted. ‘’The computer is the 
slave to the photograph,’’ he said. 
‘’You have to start with an interesting 
image.’’

Which means there is a downside 
to effi cient manipulation. Just as there 
is no way of knowing what photos 
are real, there is no way of knowing 
when conventional photography has 
produced an amazing image. For 
instance, Mr. LaChapelle’s current 
Detour cover of Uma Thurman is 
otherworldly but was not digitally 
enhanced, he said. And Mr. Avedon’s 
photo of a giant chair with models 
hanging from it, to advertise Versace, 
was indeed a giant chair with models 
hanging from it. 
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Data
Sheet

Photo Effects
 1. What would happen to the image if you entered a scale of exactly 1?

 2. Which transfer mode allows the white background of the Earth image to be pasted transparently?

 3. Describe the steps you used to modify and add the Asteroid.tif image to your cover.Asteroid.tif image to your cover.Asteroid.tif

 4. Now that you have discovered how easy it is to fake digital photos, how likely are you to believe a tabloid 
cover photo?

 5. If you suspect a digital image is not an “original,” how might you prove it?

 6. Describe what this stack shows.

 7. Describe the appearance of the averaged image.

Name(s)   ______________________________ Class  _________   Date  __________________
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 8. In Table 1, describe the percentages of Mark and Jane in the two slices you added.

Table 1

Slice Number % Mark % Jane

1/5 100% 0%

2/5

3/5 50% 50%

4/5

5/5 0% 100%

 9. How does increasing the number of intermediate slices affect the appearance of the morphing 
transformation?

 10. Describe the differences between the two morphing stacks.

 11. According to the histogram, what is the minimum pixel value (Level) in the image? (What is the lowest 
Level with a Count of at least 1?)Count of at least 1?)Count

 12. According to the histogram, what is the maximum pixel value (Level) in the image? (What is the highest 
Level with a Count of at least 1?)Count of at least 1?)Count

 13. Sketch the histogram, or print it out, and paste it onto the Data Sheet. Put a descriptive label on each axis 
and a title above the graph.

 14. How does the shape of the histogram relate to the shades you see in the image?

 15. What is the range (maximum-minimum) of pixel values in the image?
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 16. Predict what will happen to the image and its histogram when you subtract the minimum value from 
every pixel.

 17. How did the appearance of the image change after the subtraction? Did you predict correctly?

 18. Create a new Histogram, and sketch it. (Be sure to label the axes and title the graph). How well did you 
predict its appearance? 

 19. The minimum value is now 0. To stretch the pixel values from 0 to 255,  the maximum value needs to be 
255. What is the maximum pixel value on the image now? (Look for the highest Level with a Count of at Count of at Count
least 1 on the most recent histogram.)

 20. What math operation would stretch the maximum value to 255 without changing pixels that have a value 
of 0?

 21. What factor would you multiply the maximum value in the image by to get 255? (Hint: maximum × ? = 
255)

 22. Describe how the image changed after the multiplication.
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 23. Create and sketch the new histogram.

 24. Why are there gaps in the new histogram?

 25. If you multiplied a pixel with a value of 92 by 4, its new value would be 368. This is beyond  ImageJ’s 
range of 0 to 255. What do you think happens to this pixel? (Try it to fi nd out).

 26. Write a position statement addressing the above issues and outlining what you feel to be the guidelines 
for appropriate use of digitally en hanced and altered images.


